PS3 4.81 STARBUCKS COBRA 7.40 CFW by Habib

Discussion in 'PS3 News' started by habib, Dec 8, 2016.

By habib on Dec 8, 2016 at 3:46 AM
  1. 324
    322
    73
    habib

    habib Developer

    Joined:
    Oct 13, 2014
    Messages:
    324
    Likes Received:
    322
    Trophy Points:
    73
    The PlayStation 3 Custom Firmware developer who has a focus on bringing new features to CFW is here with a new release for 4.81. Developer @habib has released 4.81 STARBUCKS COBRA 7.40 CFW , with an updated COBRA payload that has some interesting advancements such as a new syscall (15) added to execute any LV2 Internal function, as habib explains this will allow devs to execute their own payload at a specific address. Other details and feature about Cobra 7.40 update can be seen in the "Cobra 7.40" tab. Other features such as Cinavia protection removed so you can digitalize your personal collection without intrusion this handles all content from HDD, BDMV & BDVD, Habib cover's the new additions in the details provided..
    -STLcardsWS​
    4.81_habib_Cobra_starbucks.png


    • 4.81 STARBUCKS [w/ COBRA v7.40] CFW
      by @habib

      CHANGELOG:
      1. MADE OUT OF 4.81 OFW
      2. HAVE INSTALL PACKAGE FILES AND APP_HOME
      3. HAVE reActPSN COMPATIBILITY
      4. PATCHED LV0 TO DISABLE ECDSA CHECK
      5. PATCHED LV2 TO ADD PEEK/POKE SUPPORT
      6. PATCHED LV1 TO DISABLE LV2 PROTECTION
      7. PATCHED LV1 TO ADD PEEK/ POKE SUPPORT
      8. IT CAN RUN GAMES SIGNED WITH KEYS UP TO 4.81
      9. CAN BE UPDATED OVER ANY CFW.
      10. CAN BE UPDATED OVER 3.55 OFW
      11. NOT ADDED NO BT/BD PATCHES
      12. RSOD BYPASS
      13. REACTPSN OFFLINE PATCH ADDED
      14. BETTER SYSTEM STABILITY
      15. REMOVED CINAVIA DRM FOR HDD CONTENT
      16. REMOVED CINAVIA FOR BDMV
      17. REMOVED CINAVIA FOR BDVD
      18. QA FLAG ENABLED BY DEFAULT IF PS3 WAS QA ON 3.55
      19. COBRA 7.40
      20. SYSTEM ACTS AS A COMPLETELY NORMAL CFW WHEN COBRA DISABLED
      21. FSELF COMPATIBILITY ADDED
      22. PATCHED DOWNLOAD PLUGIN FOR DEX PKGS(FOR E.G XMBPD)
      23. ENCHANCED REMOTE PLAY
      24. REMOTE PLAY SFO FLAG OBSOLETE
      25. NO EPILEPSY WARNING
      26. SYSCALL 15 ADDED TO EXECUTE ANY LV2 INTERNAL FUNCTION​
      UPDATE (v1.01) - day zero 1.01 update released.
      • fixed ps2 issue and whats new psn

      wanna buy me cookie?

    • COBRA 7.40 Changes:
      1. stage0_base updated for faster boot timings
      2. no more debug texts overwritten for devs
      3. syscall 15 added
      4. updates hashes to cobra internally​

      UPDATE HASH:
      • Make a text file named hash_recheck.txt
      • inside the file put new hashes in format filename:hash per line(e.g vsh.self:a0000101002e6534)
      • paste this file at /dev_hdd0/hash_recheck.txt
      • reboot ps3 and then reboot again
      SYSCALL 15:
      • allows calling of any lv2 internal function like internal memcpy to dump lv2. e.g(memcpy(dst, source, size, symbol);)
      • this also allows developers to execute their own payload at an address e.g you paste payload at 0x3d98 and then execute through sc15
      • example has been attached with new include file named "sc10_15.h"
      OTHER CHANGES COMPARED:
      • with ALL the current cobra cfw released they have a stage0 bug which overwrites another function stack, which could cause instability
      • one i checked didnt had hdd cinavia patched, this has it done

    Download: 4.81 STARBUCKS COBRA v7.40
    MD5:15660d36c3aa5197c97c87643acdca3c
     
    Last edited by a moderator: Dec 8, 2016

Comments

Discussion in 'PS3 News' started by habib, Dec 8, 2016.

    1. pasha4ur
      pasha4ur
      I was on rebug before. Same hdmi cable.

      It blinks very rare. Not big issue.
    2. habib
      habib
      But this why it blinks
      If we cant reproduce what you have, than you might even have this on next rebug which is due soon ;)
      If you want to contribute:
      Try different cable or different output
      Tell us how and when it happens and possible tests you can conduct which you think are related
      kozarovv likes this.
    3. ext10
      ext10
      I followed the update debug tutorial putting this .pup in hdd0/updater/01 folder, but when i go to update with the usb method option in xmb it won't displayed nothing to update.
    4. pasha4ur
      pasha4ur
      I understand

      But it's not in 3d. It's on disc loading screen or in garage in GT 6. Very rare. Monitor has only hdmi
    5. DeViL303
      DeViL303
      • You need to have your console QA flagged
      • Then go to network settings (dont enter it) and input the button combo that enables the Debug settings (Hold L2 + L1 + R1 + R2 + L3 + D-pad Down)
      • Then go into the debug settings and enable System Update Debug.
      • Then you can update fw - go to "Update via System Storage", not "Storage Media"
      Last edited: Dec 10, 2016
    6. bguerville
      bguerville
      Are you sure you read the complete tutorial properly?
      Those debug updates will only appear after taking some steps to enable the feature & it is unrelated to the system update via standard USB device...
      Last edited: Dec 10, 2016
    7. bguerville
      bguerville
      That doesn't help us to help you very much...
      You can't find a TV to test your console on?
      So far only you reported such an issue so we are curious & as habib mentioned we would all like to be able to prevent any bug to end up in the coming Rebug release...
    8. pinky
      pinky
      it should say update via system storage. there will be a star next to it denoting a debug option.
      ricardo likes this.
    9. DeViL303
      DeViL303
      FYI: Your tutorial does not have the step for entering the button combo to enable debug settings, I think that is why he had an issue.
    10. pinky
      pinky
      thanks for noticing that. I just added it. :)
      DeViL303 and kozarovv like this.
    11. ext10
      ext10
      Yes, it's weird... i think i have my console qa flagged, i qa flagged it in 3.55 longtime ago... I see debug settings in xmb and system update debug on. I don't know why it is not showing update via System Storage, i only get internet update and storage media options.
    12. pinky
      pinky
      not sure. I've never heard of this happening. ur on rebug, correct? check if qa is selected as ur mode in rebug toolbox. qa will be different from dex since dex has control over both qa and debug menu 2 (dex-only) options.
    13. ext10
      ext10
      Yes, i'm on rebug, effectively i have qa mode in rebug toolbox, not dex.
    14. pinky
      pinky
      no idea what's going on with ur system. boogs may know. I think he's asleep atm, so tomorrow, u might get a response from @bguerville (boogs).
      ext10 likes this.
    15. bguerville
      bguerville
      Let's recap then.
      What you did in the past cannot be relied upon so let's check what your current settings are:

      1. You are using Rebug 4.80.1 in CEX mode.
      2. In the Rebug Toolbox 02.02.10 Utilities Column, the first entry named Toggle QA shows enabled.
      3. Back in the Selector column, you chose
      Rebug System Mode
      Debug XMB operation mode
      CEX QA menu type.
      4. You created at least one numbered folder named 01, the resulting path would be:
      /dev_hdd0/updater/01/
      then you copied a PUP file in it.
      5. In XMB in the Settings column, you went into the Debug menu to toggle System Update Debug on.
      6. In the Settings column of the XMB, System Update should now have 2 more entries marked with a star character: Update via system storage & delete update data on system storage.
      Last edited: Dec 11, 2016
    16. ext10
      ext10
      Yes, thanks for the answer, i think my settings are correct:
      1. Yes
      2. Yes
      3. Yes, nevertheless, in here i always changed from rebug mode to normal mode before an cfw update, i don't remember where i read it and if it true but it is related to something called rsod of red screen that may occur. Still i put that settings you mentioned.
      4. Yes.
      5. Yes.
      6. I only have the regular 2 entries: internet update and storage media.

      Maybe it is my file system that it's corrupted i don't know... It's strange...
    17. No0bZiLLa
      No0bZiLLa
      then you either do not have qa enabled, or you have not went into debug settings and turned on update debug.

      lets go all the way back to the beginning and redo a few things. go ahead into rebug toolbox and turn off qa flag. then reboot.

      now go back into rebug toolbox and enable qa flag and reboot, then make sure update debug is on in debug settings on xmb.

      now go to system update at top of setting column and see if the two new options for updating are available.

      this may sound out of the ordinary, but i once had a system that was qa flagged on 3.55 but after updating to one of the 4.xx CFW along time ago (i think it was a cfw that had qa flagged enabled by default), it did infact disable qa somehow. not sure why or how but doing what i mentioned above solved the issue for me.
    18. bguerville
      bguerville
      To post those answers did you actually do all the steps mentioned in post #76 or are you just answering what you believe to be the case?
      I was asking you to do the former...
      It's not possible that all the conditions are ok but the feature does not work.
      You have to be making a mistake somewhere...
      No0bZiLLa likes this.
    19. bitsbubba
      bitsbubba
      I would also like to mention internet update will be greyed out and unselectable
      No0bZiLLa likes this.
    20. vagus02
      vagus02
      Anyone here can please tell me if multiman 4.80 work with this release?

Share This Page