PS3 PS3 4.83 OFW Now Live - Beware changes impacting HAN users - stay tuned for more info

Discussion in 'PS3 News' started by montcer, Oct 10, 2018.

By montcer on Oct 10, 2018 at 9:20 PM
  1. 105
    84
    32
    montcer

    montcer Member

    Joined:
    Mar 17, 2018
    Messages:
    105
    Likes Received:
    84
    Trophy Points:
    32
    Gender:
    Male
    BEWARE (Exploited PS3's) PlayStation firmware update 4.83 has just went Live, developer's from the PS3Xploit team have not had time to take a look at it yet since this has just been released (see update, devs are looking into it now and will update us here in this thread), This update could potentially be a patch for the PS3Xploit hacks (but they have not in a year which has been odd) or it could be a simple routine update for things such as the BluRay player. Developer's will look into this newly released update and we will keep us posted here in this thread. Its advised to stay on 4.82 until Ps3Xploit developer's verify the newly released Official firmware. Users and Ps3 Firmware Bot has confirmed the update is live.
    -STLcardsWS ​


    Update:
    (See "Ps3Xploit Status" TAB below for latest reports on PS3Xploit Status)


    ps3-system-software-update-two-column-01-ps3-eu-23mar15.png


    • WARNING 4.83 PS3 Firmware is NOW LIVE
      PS4_4.83.png

      Official Changelog via Sony:

      New for 4.83
      • This system software update improves system performance.

    • ps3xploit-logo.png
      Current Status for 4.83
      • PS3Xploit (for CFW enabled Console) - Do not update to 4.83 OFW (From 4.82 CFW you can update to a 4.83 CFW when available)
      • PS3Xploit HAN (for non CFW Compatible Consoles) - Do not update to 4.83, or you will lose various abilities of HAN

      Official Ps3Xploit Response via @bguerville

      RECOMMENDATION FROM PS3XPLOIT TEAM:
      FOR THE MOMENT, DO NOT UPDATE TO 4.83 UNLESS YOU HAVE DECIDED TO GIVE UP USING HAN PERMANENTLY ON THE CONSOLE.

      After a look at the update files & preliminary tests, I am afraid I am bearing some bad news for HAN users playing online.

      1. It would appear that [email protected] patched one of the 2 webkit exploits we currently use to trigger ROP chains.
      It means that we need to replace this exploit in order to get any ps3xploit tool working on 4.83. Work is already under way, obviously no ETA at this stage. Please don't ask.

      2.
      The kernel is completely untouched. No changes to either lv1 or lv2 which means CFWs will be easier to make. That's also good news for devs with any promising kernel vulnerability under investigation.

      3. Changes were made to vsh as usual & they seem extensive enough to suspect that they may have patched the HAN vulnerability as well. We have not yet had time to look into the matter at all but if they did, HAN might be gone for good past 4.82, leaving only CFW2OFW conversions installable & runnable on 4.83 whenever the patched webkit exploit gets replaced.


      In conclusion, the changes brought by the 4.83 update mean that anyone updating will lose usage of HAN, and possibly permanently until a kernel exploit comes out. Cfw2ofw conversions will be the only installed games that will still be working after updating.


      The nature of this update is upsetting our 4.0 release plans somewhat. It's still very early stages in our investigations & there are still many unanswered questions for the moment. I will keep you all posted whenever I have additional information to share.

    • PS3_4.83_CFW.jpg
      As 4.83 releases (CFW / Homebrew / Tools) are made , we will keep this linked thread below updated:

    Do not update to 4.83 or you could lose the ability to exploit your PS3

    Source: playstation.com / twitter.com/PS3FWBot
    (Thanks to montcer for the Alert in the forum :) )​
     
    Last edited by a moderator: Oct 12, 2018

Comments

Discussion in 'PS3 News' started by montcer, Oct 10, 2018.

    1. DeViL303
      DeViL303
      Backup/restore is just for some of the HDD data, it does not effect the flash/FW version. So you will still be on 4.83.

      Currently the only way to downgrade from 4.83 is with a hardware flasher on CFW compatible consoles.
      benfrost94 likes this.
    2. benfrost94
      benfrost94
      Ok thanks devil :)

      Sent from my MotoG3 using Tapatalk
    3. Cypher_CG89
      Cypher_CG89
      Well I am happy I can still get online with 4.82.2 and I haven't changed a thing yet with regards to what I use or do to get online. Hopefully that won't change but I am not holding my breath.
    4. Naked_Snake1995
      Naked_Snake1995
      I wont bother with this update mate, only my 4004C will be updated to 4.83 due to i still play PS3 sometimes, and i jailbroken units, so no sweat, and HAN isnt my exploit of choice, still prefere a CFW over the HAN, simpler and more functions ;)
    5. Naked_Snake1995
      Naked_Snake1995
      The Ultimate triggering firmware hahahahhahaha :D DSC_0404.JPG
      ilye_s and Javi007 like this.
    6. benfrost94
      benfrost94
      For those without cfw han is the best thing possible. and kindly appreciate the efforts of ps3 exploit team as the ps3 super slim would have never been exploited without them. They have done a great feat. and the team that made pkg linker and offline han enabler as well deserve a lot of credit

      Sent from my MotoG3 using Tapatalk
    7. Naked_Snake1995
      Naked_Snake1995
      Could agree more mate, although not my exploit of choice i am glad the developers took theyre time and gave 3K and 4K users something close to CFW :)

      We all should be thankful :)

      Sent from my F8331 using Tapatalk
    8. Naked_Snake1995
      Naked_Snake1995
      Could agree more mate, although not my exploit of choice i am glad the developers took theyre time and gave 3K and 4K users something close to CFW :)

      We all should be thankful :)

      Sent from my F8331 using Tapatalk
    9. YsonyY
      YsonyY
      YOU CAN USE IT FOR PARTS (BLURAY, HDD, FAN, POWER SUPPY!!) ALL THOSE GOOD STUFF. XD
    10. moongose
      moongose
      DeViL303 likes this.
    11. bguerville
      bguerville
      The trash? You cannot be serious...?
      Why would you throw such a tantrum?
      esc0rtd3w likes this.
    12. YsonyY
      YsonyY
      I haven't been online in LIKE 6 days because my hard drive has 38 bad sectors and making clicking grinding sounds :''(
    13. HolyFire29
      HolyFire29
      Yes. As a superslim owner myself, Han is the only way I could experience something close to a jailbroken ps3 and buying an older ps3 version is both impractical and I'm short on cash atm.
      Thanks to the ps3 exploit team for making Han accessible to us superslim owners and I hope they develop an exploit for 4.83 soon!
      ayassinsayed, ilye_s and benfrost94 like this.
    14. Ivor Pirela
      Ivor Pirela
      it will be possible an exploit for 4.83 in the future??? :(
    15. bguerville
      bguerville
      For parts? A console in perfect working order? Why would you not keep it that way?

      Before anyone else takes such drastic steps (within 24h of a system firmware release), I suggest a little patience maybe!

      You must have noticed that we have not yet confirmed publicly whether HAN was patched or not in 4.83. We only said that taking the decision to update at the moment meant agreeing to possibly give up HAN permanently. Users must act on that bottom line basis.

      So for the moment, we recommend to every HAN user to remain on 4.82 for 2 main reasons.

      1. In 4.83, a new webkit exploit is needed. No ps3xploit tool can be used on 4.83 until we get that done. It will happen, webkit is still just as old & buggy, BUT we cannot say yet when that will be.

      2. We do not yet have 100% confirmation that the HAN patch can still work on 4.83. From a first review of the disassembled code, it doesn't look like the HAN vulnerability was patched, our HAN Tools should still work but 100% confirmation requires going deeper in the disassembly, debugging & finally some testing, a process that has not been done yet.

      So basically, updating your firmware was a bad move BUT from what we know so far, there is still a good chance (a chance mind you, not a guarantee!) that your console might run HAN again before the end of the year. In the meantime, you can still run your retail discs, original PSN installations & any game that was installed with the Debug pkg Enabler.

      In the bigger picture, HAN was always meant to be temporary anyway, a stepping stone of sorts to give Slim > 25xx & SSlim console owners a few more options, the future is a kernel exploit. Not if but when it happens, the perfectly fine consoles you are considering to trash or use for parts, will eventually be able to mount ISO games like on CFW. Lol
      Last edited: Oct 12, 2018
      kenzy, YsonyY, Javi007 and 13 others like this.
    16. ilye_s
      ilye_s
      Thanks Devs keep it up

      Sent from my CAM-L21 using Tapatalk
    17. amirzaim
      amirzaim
      Well...no system will be secure...they will keep patching until PS5 comes out and they will clear entire PS3 libraries from PS Store while ending system support for PS3. It might take another more years to do it.
    18. mndx
      mndx
      amen brother, amen
    19. Raft
      Raft
      So I can play the games no-Han in 4.83?
    20. bguerville
      bguerville
      @Raft

      Installed games that were not resigned for HAN should still work fine.
      Unless Sony patched the vulnerability exploited by cfw2ofw conversions but quite frankly I doubt it.
      Try launching a game you previously installed with Debug pkg Enabler on 4.82 & you will have your confirmation.
      Raft likes this.
    Tags:

Share This Page