PS VITA / PS TV Yifanlu Releases USBMC Allowing USB Devices at Boot

Discussion in 'PS Vita News' started by atreyu187, Jun 19, 2017.

By atreyu187 on Jun 19, 2017 at 12:27 AM
  1. 4,378
    1,801
    123
    atreyu187

    atreyu187 Ensō Tester Moderator Developer

    Joined:
    Sep 29, 2014
    Messages:
    4,378
    Likes Received:
    1,801
    Trophy Points:
    123
    Gender:
    Male
    Occupation:
    Sony Fanboy
    Location:
    127.0.0.1
    Home Page:
    In anticipation for the new PSVSD adapter, Yifanlu has released a nice little plug-in that PlayStation TV (PSTV) users can use right away. USBMC allows one to mount a USB device at boot time and with Enso this means it will work all the time. Here is the Readme. I personally set this up to test earlier today with my 500gb hard drive and it has worked flawlessly.

    USBMC.png


    • usbmc
      This is VitaShell's patches for USB storage support as a standalone plugin. If loaded on startup (before SceShell), it will automatically mount the USB storage as ux0 instead of the memory card or internal memory.

      To install, copy the plugin to ur0:tai/usbmc.skprx and add that path to the taiHEN ur0:tai/config.txt under *KERNEL. If you have a memory card inserted or you have a Vita with internal memory (LCD and PSTV), you must deleteux0:tai/config.txt from the original memory and use ur0:tai/config.txtfrom now on. This is because taiHEN loads before the memory card redirection patches and will attempt to read config.txt from there first.

      Full credits to The_FloW for these patches

    Tested and confirmed working with latest Enso on PSTV. Now onto the support but first a mention to our Super Mod @kozarovv for bringing to my attention.

     
    Last edited by a moderator: Jun 19, 2017
    citra mulia, ed89, MixeryMaxe and 4 others like this.

Comments

Discussion in 'PS Vita News' started by atreyu187, Jun 19, 2017.

    1. pinky
      pinky
      so taihen loaded from ur0 will exist at all times since ux0 is changed to uma? I think this is y I had issues with adrenaline originally actually. the taihen config.txt was changed when booting from uma. placing it on both ux0's fixes this issue. this was before ur0 was possible.

      btw, y does tracker barrel trek in dkc 3 show it being downhill on the map, but ur going uphill in the stage? :-p
    2. pinky
      pinky
      sorry. I hope u all find that last statement funny instead of off topic. I've been playing a lot of dkc 3 lately via an emulator, 'cause my television no longer turns on. I plan to get a new one tomorrow. more money borrowed from my parents though. :( all of my electronics r falling apart from overuse or nonuse. it sucks.
    3. Jonathan oxley
      Jonathan oxley
      I can't seem to get it to work with my USBstuck 32gb I have done everything it say on the site editing the ur0:tai/config.txt and put the usbmc in ur0:/tai and deleted the other config.txt on memory card and internal memory and my other plugins work fine like the download one, the ds3 and ds4 which I use for third party controllers which don't work normally on the pstv
      Last edited: Jun 19, 2017
    4. pinky
      pinky
      r u sure u have the plugin in the kernel section? u can tell what's kernel or user by skprx or suprx. the k and the u will tell u which is which.
    5. atreyu187
      atreyu187

      How many plugins do you have enabled? And also until Enso is out it won't work on boot you will have to enable HENkaku first. This is aimed at Enso users with a PSTV or the PSVSD adapter right now. The plugin is useful for them and is more or less prep so when people make their own as the schematics for the board are already on his GitHub account and there are those that have already made external USB ports.
    6. nCadeRegal
      nCadeRegal
      you got a link, or pics of the usb mods?
    7. atreyu187
      atreyu187
      STLcardsWS and nCadeRegal like this.
    8. TOM1211
      TOM1211
      Going to be an exciting few months for the vita /vitatv can't wait to use enso and this but will hold out for release date.
    9. Jonathan oxley
      Jonathan oxley
      I have got enso installed and I have put it under kernel I have done everything it says to and the memory stick mounts in vitashell am of to try a USB Hard this week sometime to see if it will works that way
    10. Jonathan oxley
      Jonathan oxley
      this is my plugin config setting and is in ur0:tai/ and I have deleted the other configs from memory card and internal memory

      # For users plugins, you must refresh taiHEN from HENkaku Settings for
      # changes to take place.
      # For kernel plugins, you must reboot for changes to take place.
      *KERNEL
      # henkaku.skprx is hard-coded to load and is not listed here
      ur0:tai/usbmc.skprx
      *main
      # main is a special titleid for SceShell
      ur0:tai/downlaod_enabler.suprx
      ur0:tai/henkaku.suprx
      *NPXS10015
      # this is for modifying the version string
      ur0:tai/henkaku.suprx
      *NPXS10016
      # this is for modifying the version string in settings widget
      ur0:tai/henkaku.suprx


      please help me anyone
    11. pinky
      pinky
      First you need to install Ensō and use VitaShell to mount your USB drive as ux0. This will copy the required files to your USB drive. Unmount ux0 after the files are copied?
    12. Jonathan oxley
      Jonathan oxley
      I have got enso installed and I have mounted the drive and the files have copied over but still isn't working and I have now tried with a 250gb USB drive and 32gb USB stick
    13. hahahi123
      hahahi123
      what about a usb 2.0 hub? will that be recognized as multiple ports or storage space slots?
    14. atreyu187
      atreyu187

      No you can't use multiple USB storage devices. You can charge your controller while using the USB hub and a USB storage devices though.
    15. pinky
      pinky
      hdds seem to be hit-or-miss if they're unpowered. is urs? not sure about the flash drive. I don't have ensou henkaku installed, so I've never tested this plugin. I'm sorry I couldn't be of better help. :(
    16. atreyu187
      atreyu187
      Also have you gotten the updated VPK of Enso? That may also be your issue. They have released three builds since the first one. We aren't ever notified but I check every day or two just to check.

      So far there have been three. The leaked build is the first release of Enso and also aptly named by me "The Memory Card Destroyer" as it killed two of my cards beyond repair. Go back to HENkaku.xyz/dl and input your CID to grab the latest build.

      Install that vpk and do launch the app, use button sequence to activate the menu then uninstall. Reboot your system then go to HENkaku.xyz/go to get the latest payload. It will have the new features like the Content Downloader that will install a DRM free PKG file from any URL Sony based or likewise and the new reboot and reload options.

      Then you will for sure have the proper build of Enso and HENkaku/taiHEN installed. I'm willing to bet this is your issue as the older payloads and Enso builds didn't support the new plugin. If you are using the leak it won't work as you need the latest Enso and HENkaku payload in order to use the new plugin properly.

      Only other thing I can think of is to remove all plugins that aren't for HENkaku as Sony has a hardcoded number of SPURX/SKURX files that the team has to patch as it's handled by F00D which the keys to alter this haven't been made public.
      pinky likes this.
    17. pinky
      pinky
      this was going to be the last suggestion I could think of. not so much the number of plugins being used but that other plugins interfering with the one kernel (this) plugin he's using.
      atreyu187 likes this.
    18. atreyu187
      atreyu187
      The newer builds of HENkaku has the patches applied to allow plugins to be loaded dynamically, not sure if it has fixed the issue with the limit of plugins we can use as the changelogs haven't been published for the private builds to my knowledge.
      pinky likes this.
    19. pinky
      pinky
      I see. thanks for the info. I wasn't sure if the added plugins associated with specific title ids were indicative of ensou, 'cause my config.txt looks quite a bit different.

Share This Page