PS3 4.84.2 REBUG REX + COBRA 8.1 Released (Rebug Toolbox Updated / Font Fix / ...)

Discussion in 'PS3 Jailbreak CFW and PS3HEN' started by STLcardsWS, Mar 30, 2019.

By STLcardsWS on Mar 30, 2019 at 12:30 AM
  1. 8,604
    8,233
    1,022
    STLcardsWS

    STLcardsWS Administrator

    Joined:
    Sep 18, 2014
    Messages:
    8,604
    Likes Received:
    8,233
    Trophy Points:
    1,022

    Following the release of 4.84.1 REX a new update has been made by Team Rebug with the release of 4.82.4 REBUG REX (& D-REX) with the inclusion of COBRA v8.1 that we seen debut in @Joonie's latest PASTA (DEX) COBRA CFW. This update also corrects a long-standing bug (7 years) that resided in Rebug when trying to install in some region via Recovery Mode. Also PS3Xploit Support has been added (mostly for developer use), these features in REBUG REX and various fixes/changes can be seen below. Along with an overview of features REBUG REX can offer


    Rebug.png
    • What’s new since 4.84.1 REX/D-REX?
      • Installation issue fix (This has been bugged for the past 7 years due to missing the license agreement for 3 languages including English[UK], Brazilian Portuguese and Turkish. Certain users used to have a problem installing REBUG while on recovery mode, and this is finally resolved!) *no more data corruption error!*
      • Font fix: (some old games that use system font now display all letters correctly, Polish letter fix is removed due to this change )
      • PS3Xploit support: (The old webkit is brought back to allow PS3Xploit support, HAN can be used)
      • REBUG TOOLBOX 2.03.02 MULTI 16 (PS2 Emu swapper’s removed as this became obsolete since Cobra 8.1)
      • Cobra 8.1 (Enabled by Default) source available via this link (Stage0 now supports kernel & VSH plugin on both Cobra and non-Cobra mode, loadoptical flag(for BC and SemiBC) is created at all time as long as stage2 is disabled, this is only beneficial to BC/Semi-BC users for those who don’t use COBRA) More information available via this link

    • Features of 4.84.1 REBUG REX
      • FEATURE – Dual LV2 Kernels CEX/DEX (Swap your EID0/LV2 kernel using Rebug Toolbox in seconds)
      • FEATURE – ALL Retail functions available in CEX mode (No need to install different firmware)
      • FEATURE – ALL Debug functions available in DEX mode (No need to install different firmware)
      • FEATURE – COBRA v8.01 (ENABLED BY DEFAULT, a new change in 4.84 REX)
      • Background running plugins at boot time (sprx)
      • ISO Support: PS1/PS2/PS3/PSP/DVD/BluRay (Split ISO support on FAT32 drives)
      • Network Support: PS1/PS3/DVD/BluRay /PKGs
      • Blu Ray Movie region free functionality NTFS HDD Support (prepNTFS, or multiMAN Required to scan contents)
      • PS2 ISO Support for BC (HW) / non-BC (SW) Consoles
      • Syscall 11 – Cobra lv1 Peek
      • Syscall 15 – Allow execution of any LV2 internal function
      • PSNPatch stealth plugin support
        • ***ISO rips are required to get 100% support, for ex) after disabling syscalls, games like Call of Duty will not be able to play unless you use ISO rips, please DO NOT expect everything to be fully functional when you are disabling the built-in features from COBRA. Folder rips are NOT compatible with PSNPatch’s stealth mode due to its ability to disable COBRA’s disc-less feature for folder JB rips****
      • PS3MAPI support, allows you to attach process on both CEX/DEX via its own API app.
      • Backup Protection Removal, Add full PS3 Backup support on all multiMAN/sMAN/webMAN,IRIS manager forks and Managunz.
      • Allow modification on Syscall 6/7/8/9/10/11/15.
      • Burned/Burnt optical media support for PS1/PS3 Games on All models
      • Homebrew blocker – blocks homebrew access while Syscalls are disabled
      • new in 8.00 Run payload with Kernel privileges - Added option to run payload with kernel privileges like ps vita skprx. this is a big thing! one can make hooks, printf to socat, do whatever they feel like they need to do. at the current time only one payload is supported at a time. in the future i might increase this
        • New in 8.01 Added support for dynamic memory payloads, 5 of them can be started from "/dev_hdd0/boot_plugins_kernel.txt"
        • toolchain updated to support dynamic address loading.
        • For applications, you can also mount em, and unmount em separately
      • new in 8.00 Boot times vastly speed improved - as there is no stage1.
      • new in 8.00 PS2 bc and semi bc consoles wont load iso when cobra disabled - disable cobra using opcode)
      • FEATURE – FULL ProDG Connectivity in DEX mode (Full Support on both Normal mode and Cobra mode)
      • FEATUREQA Token compatibility
      • FEATUREOtherOS++ support enabled (Use Rebug Toolbox to Boot OtherOS with different LV1 patches)
      • FEATUREPackage Manager (Replacement for the standard ‘Install Package Files’ option)
      • FEATUREFSELF compatibility (Fake Signed ELF is supported on both CEX and DEX modes.)
      • FEATURE Fake Save Data Owner (Use Game Saves from ANY Owner)
      • FEATURE In Game Screenshot (Allows taking screenshots in Game)
      • FEATURE Disabled flag check in PARAM for Remote Play (For better compatibility with remote play, custom flags in PARAM is recommended)
      • FEATURELock/Unlock Trophies (Offline only)
      • FEATURE Cinavia protection fully disabled (Supports optical media/bd iso, AACS must be decrypted)
      • FEATUREFull BD/DVD Playback support on both CEX/DEX mode (BD/DVD movies can now be played on DEX mode, major thanks to mysis!)
      • FEATURE XMB CFW settings v0.1a (XMB icons for simple CFW tasks available via REBUG TOOLBOX 2.02.16)
      • FEATURE PSN/SEN Accesibility (PSN /SEN Accessible , until the next OFW update)
      • FEATUREXMBM+ Compatibility (XMB Manager Plus developed by Team XMBM now supported via standalone pkgs.)
      • FEATUREHAN Toolbox Compatibility (HAN Toolbox support added for developers)
      • PATCHEDAppldr: LV2 memory hash check is disabled (Memory protection on LV2 is disabled in higher level)
      • PATCHEDLV1: Disable System Integrity Check (Safe to use with mismatched COREOS/SYSCON versions or if PS3 is not QA enabled)
      • PATCHED LV1: Undocumented function 114 (Allow mapping of protected memory)
      • PATCHEDLV1: Skip all ACL Checks (Needed to allow booting of OtherOS)
      • PATCHED LV1: Peek and Poke support (Unused LV1 call 182 and 183)
      • PATCHEDLV2: Peek and Poke support (LV2 Syscall 6 and 7)
      • PATCHED LV2: Peek and Poke support for LV1 (LV2 Syscall 8 and 9)
      • PATCHED LV2: LV1 CALL System call (LV2 Syscall 10)
      • PATCHEDLV2: Allow execution of any LV2 internal function (LV2 Syscall 15)
      • PATCHED Recovery: Prevent accidental OFW update while on Recovery mode
      • PATCHED VSH: Allow Unsigned act.dat and *.rif files
      • PATCHED VSH: Auto unlocks c00 demo contents
      • PATCHED VSH: Disable Unlinking/Deleting of act.dat (Improved patches applied)
      • PATCHEDVSH: Disable NEW PSP DRM Check (Allowing unsigned PSP pkg contents on 4.75 or higher CFW)
      • PATCHEDVSH: Disable Epilepsy Warning for Faster Boot-Up Speed
      • PATCHEDVSH: XMB notification removal (Fake Save Data Owner and Game Quit: No Request Event will not be displayed)
      • INCLUDED – Rebug Toolbox 2.03.01 (Install included Rebug Toolbox or higher for full compatibility)

    Download @: rebug.me
     
    Last edited: Mar 30, 2019
    Maroon Storm, rocknard, n00b and 20 others like this.

Comments

Discussion in 'PS3 Jailbreak CFW and PS3HEN' started by STLcardsWS, Mar 30, 2019.

    1. Coldheart2236
      Coldheart2236
      An update is not needed. multiMAN 4.82 works perfectly fine on 4.84; the only thing that doesn't display correctly is the version number, but all functions and features work fine.
      T.A.U likes this.
    2. Yafte
      Yafte
      I've unchecked the ps1_netemu, and nothing.
      Every time I mount a psx iso says ps1_netemu.self in the upper right corner.
      My video settings are in automatic. All resolutions are marked.

      This issue happens in two different ps3...

      Any other suggestion?
    3. Joonie
      Joonie
      If you unchecked ps1_netemu it shouldn't load ps1_netemu

      @aldostools any ideas?

      Tell me the ps3 models numbers, I bet yours is old PHAT model, and name of the pal games that you have problems with.

      for the time being you can try changing XMB Operation mode to Retail via rebug toolbox to see if that fixes.
    4. ochentay4
      ochentay4
      ok, pkgtool gave errors on every os i tried xp / 7 / 10. now, i tried to put the keys, tried on xp, advanced a little more, but crashes at the end.
      could someone continue to help?

      Attached Files:

    5. Joonie
      Joonie
      Try launching the app with admin mode on windows
    6. ochentay4
      ochentay4
      Impossible on XP...
      Advanced a little more, here is the error log:

      Modifying XML file content
      Removing "bluetooth firmware" packages from UPL.xml
      pkg-ing / spkg-ing file: UPL.xml.pkg
      Executing command pkg_spkg $dir $pkg
      Building "NEW PKG & SPKG" retail package(s).....
      Executing shell new_pkg retail {C:\MOD\temp\PS3MFW-MFW\update_files\UPL.xml.unpkg} {C:\MOD\temp\PS3MFW-MFW\update_files\UPL.xml.pkg}
      perror: No such file or directory
      new_pkg.exe
      Modified by Evilnat
      Please wait...
      file suffix: retail (rev retail)
      key file: C:/MOD/pkg-key-retail (ERROR)
      key_get() failed
      FATAL ERROR: Could not pkg / spkg file: UPL.xml.pkg : child process exited abnormally
      Error running script: Could not pkg / spkg file: UPL.xml.pkg : child process exited abnormally
    7. Joonie
      Joonie
      looks like you didn't set your keypath on settings

      upload_2019-4-3_16-6-40.png
      T.A.U likes this.
    8. ochentay4
      ochentay4
      it seems that file has to be exactly named pkg-key-retail , which I did, now ask for more files, searched, downloaded, and another, man, this is hard. Where can I get all keys that it asks?
      Please wait...
      file suffix: retail (rev retail)
      file suffix: retail (rev retail)
      key file: C:/MOD/kkk/spkg-key-retail (ERROR)
      key_get() failed
      FATAL ERROR: Could not pkg / spkg file: UPL.xml.pkg : child process exited abnormally
      Error running script: Could not pkg / spkg file: UPL.xml.pkg : child process exited abnormally
    9. psykosis
      psykosis
      I hate when I lose my keys...
      [​IMG]
      Joonie likes this.
    10. Joonie
      Joonie
      you should already have them in your ps3keys folder (inside ps3mfw folder)..

      upload_2019-4-3_16-14-13.png
      T.A.U likes this.
    11. ochentay4
      ochentay4
      I downloaded all keys from https://github.com/Evilnat/PKG-SPKG_Tools now it builded! Man, hard as hell. Thanks god I have some idea how to use the computer. Will share the file later if worked fine. It wouldve been much easier if someone provided the file but oh well
    12. ochentay4
      ochentay4
      Ok, redid everything thanks to the pic and builded right away. Will try later.
    13. Joonie
      Joonie
    14. Yafte
      Yafte
      CECH-2101A PS3 SLIM, the game is Metal Gear Solid (Spanish version, SLES-01734), and the cfw REBUG REX 4.84.2.

      CECHP01 PS3 FAT, same game and cfw.
    15. ochentay4
      ochentay4
      I was talking about the patched firmware... I will upload it soon as it seems to have installed correctly. One thing, I still dont have luck with webMAN MOD v1.47.14, still says webman not ready after installed (at least shows the menu). I dont know what to do really as it worked fine with previous 4.82.2 rebug lite and webMAN MOD 1.47.09
    16. Joonie
      Joonie
      Not sure what's wrong with your system. it loads fine on my system, both PS1EMU and PS1_NETEMU..

      I have NTSC models like you do and running this "SLES-01734" just fine.

      Tested on CECH-E01 [NTSC/US]

      it's running at 1080p / 50hz (576p is available after the game's mounted due to COBRA's dynamic patching)

      upload_2019-4-3_18-50-15.png


      upload_2019-4-3_18-49-47.png


      upload_2019-4-3_18-49-5.png


      upload_2019-4-3_18-48-40.png


      upload_2019-4-3_18-47-51.png


      Try these couple of things

      1. do system setting reset

      upload_2019-4-3_18-54-20.png

      2. change XMB Operation mode via REBUG TOOLBOX to Retail from DEBUG (if number 1 doesn't work)

      upload_2019-4-3_18-55-24.png
      Last edited: Apr 3, 2019
      T.A.U likes this.
    17. Lambada
      Lambada
      The post title says 4.84.2 and the content says 4.82.4? o_O
    18. DeViL303
      DeViL303
      its like an anagram with numbers, a numbergram :)
    19. Lambada
      Lambada
      LOL

      Sent from my Redmi Note 5 using Tapatalk
    20. aldostools
      aldostools
      The emus also can be selected manually holding the shoulder buttons.
      L2 = ps1_emu / R2 = ps1_netemu / R1 = toggle the current selected emu

      This applies for PS1 games (all PS3 models) and PS2 games on PS3 models with B/C

      Also if the file name contains the tag [netemu] that emu will be used.

      SRC for the function pad_select_netemu()
      https://github.com/aldostools/webMAN-MOD/blob/master/include/vpad.h#L226
      Last edited: Apr 4, 2019
      T.A.U and citra mulia like this.

Share This Page