PS3 4.84 OFW Released - Beware do not update

Discussion in 'General PS3 Discussion' started by jcorrea, Feb 13, 2019.

By jcorrea on Feb 13, 2019 at 9:37 PM
  1. 251
    115
    97
    jcorrea

    jcorrea PSX-Place Supporter

    Joined:
    Sep 3, 2018
    Messages:
    251
    Likes Received:
    115
    Trophy Points:
    97
    Gender:
    Male
    Occupation:
    Developer
    Location:
    Curitiba/Brasil
    PlayStation 3 had an official firmware update released with the drop of system update 4.84. Below i provided a small chart for people on other firmwares and their hacks. Currently it unknown what prompted the update, could of been a simple maintenance update, which what appears to be the case on initial inspections. Could the update have something to do with PS Plus free games ending on the service? Very well could be but that is speculation at this point. PSX-Place will keep you updated of all the changes this update brings. The update has not patched the recent StoreHaxx release which is not something most will use as its simply an IDPS dumper currently (w/ other potentials possiable). Even on 4.83 and looking to exploit, you may want to wait to update until devs in this thread mainly @bguerville and @esc0rtd3w give the okay.

    Checkout this thread for FUTURE 4.84 releated released.
    -STLcardsWS​

    12-1-08-ps3-system-update.jpg

    • From PS3FWBot on twitter:
      "14/02/2019 03:10 CET: Sony pushed new PS3 FW 4.8400. Previous FW was 4.8300"

      • 4.82 HAN user's do not update
      • 4.83 and lower CFW user's do not update. (until a 4.84 CFW is released)
      • User waiting for 4.83 progress, do not update
      • Consoles that are not exploited but on 4.82 and lower do not update (If you want to exploit it)

     
    Last edited by a moderator: Mar 12, 2019

Comments

Discussion in 'General PS3 Discussion' started by jcorrea, Feb 13, 2019.

    1. bitsbubba
      bitsbubba
      It should
      jcorrea and diego89 like this.
    2. Spawn
      Spawn
      If $ony loves us that much, why don't they give us the dex pups to continue our venture.? ;)
      Last edited: Feb 14, 2019
    3. Bobby_Downgrades
      Bobby_Downgrades
      I would assume (although I cannot say for certain) that the spu_pkg_rvk_verifier.sprx would verify the packages in the patch pup as it handles the packages in the normal pup, the bd, multi card and vsh do not have proper checks on pkgs/tars on install. I was playing with it some time ago.
      If you patch syscon to accept both dex and cex signed spkgs at same time you can install say dex vsh 4.80 with 4.80 cex fw. Although some vsh spkgs have checks, if you can get the balance right you can install enough dex onto ofw to get something going (NOTE: files overwrite each other when same file is installed in different tar balls). If memory serves me correctly some spkgs that do not have check can be manipulated with custom signed files providing spkg is signed correctly for dex and other stipulations I mentioned are followed.
      If you (or anyone reading) is interested in flashing the syscon to accept both spkgs I can dig out my old notes and files.
      One thing I do remember for certain is you would be very surprised what you can get away with.
      T.A.U, lmn7, jcorrea and 2 others like this.
    4. Cypher_CG89
      Cypher_CG89
      I wouldn't mind taking a look at what can be done. If you could PM them or something that would be awesome.
      esc0rtd3w likes this.
    5. pipex55
      pipex55
      C'mon man... PS5 will be released and PS3 still receiving updates...
      RandomDude likes this.
    6. DeViL303
      DeViL303
      I do not think it will work anymore. The proxy trick only works if you are 1 version below latest, unless something has changed.
      diego89 likes this.
    7. oneohthree
      oneohthree
      Proxy trick DOES work (at least for the moment). I just tried it without issues.
      T.A.U, esc0rtd3w, DeViL303 and 2 others like this.
    8. diego89
      diego89
      Good hour for a wild offline activation method appears [emoji23]

      Enviado de meu Moto G Play usando o Tapatalk
    9. DeViL303
      DeViL303
      That's cool. Possibly only temporarily still working, not sure, as far as I can remember it only used to work if you were 1 version below latest. That might have changed with recent versions or I could have remembered wrong.
      diego89 likes this.
    10. oneohthree
      oneohthree
      I hope it remains like so. I could active the user, also installed HAN. There were no problems during the process and didn't have to do anything special to accomplish the task. I didn't even change ps3-updatelist.txt URL replacement.
      T.A.U, DeViL303 and diego89 like this.
    11. Cypher_CG89
      Cypher_CG89
      Only one person has clocked on to why this update came out.....and tbh people should have been expecting it as it was announced 1 year ago that this would happen......

      Today Free PS3 games have been dropped from PS Plus..... this update is to allow these people to keep using the games they have already downloaded without PS Plus, as normally you would have to keep your PS plus subscription to keep playing them.

      [email protected] deemed it unfair to keep this policy after the games were dropped from PS Plus and announced a YEAR ago that they would push some sort of update either on or near the time of dropping these games to allow people to continue using them, that may or may not include a scheduled maintenance update.

      Also Vita games have also been dropped been dropped from PS Plus and the manufacturing of PS Vita's is to cease this year as well.

      People were warned of this a year ago. So be prepared for another update if this is just about the PS3 Plus games in this update and not part of the scheduled maintenance update.

      EDIT: FFS... I cannot find the effing article that explained this fully..... only the one about the dropping the games from PS Plus, which is effing irritating as this one I have managed to find again is the one that made me go looking deeper into this in first place.

      So AFIAK now... you still need PS Plus to play games you already have downloaded. This is effing great this. I knew I should of bookmarked the page lol.

      But PS3 games dropped from PS Plus + FW update patch = not a
      coincidence
      Last edited: Feb 14, 2019
      T.A.U, esc0rtd3w and ISAK.M like this.
    12. esc0rtd3w
      esc0rtd3w
      I had that exact same thought. It should work, since there is not a silk_webkit.sprx included in 4.84 patch, but how to install the patch pup?

      We have already ported 4.84 offsets and verified exploit does still work by replacing silk_webkit.sprx from 4.82 on 4.84 OFW

      I was more thinking going right from 4.82 to 4.84, using patch would not even touch webkit files


      EDIT: now that i think about it, going from 4.82 to 4.84 from patch files wouldn't, or shouldn't work! :rolleyes:
      Last edited: Feb 14, 2019
      T.A.U, lmn7, sandungas and 2 others like this.
    13. Vishera
      Vishera
      I am still on REBUG 4.81,
      No reason to update for me :D
      I also removed the option to update online from the XMB,hehe.
    14. Bloodmoons366466
      Bloodmoons366466
      So im guessing this blocks 4.82 rebug dex from getting online nativly.We would need to get sen enabler to spoof 4.84 then or get a 4.83 dex cfw if thats even possible at the moment.
      T.A.U and bitsbubba like this.
    15. littlebalup
      littlebalup
      Here my flavour of a 4.84 "Dualboot" firmware : https://www.mediafire.com/file/p03t8u2ns2sliw0/DB_4.84_littlebalup.zip/file

      - Made out from OFW 4.84.
      - Patched isoldr and spu_pkg_rvk_verifier to disable ecdsa protections allowing to install CFW 4.84 and above over it.
      - Core OS patched files have the exact same size than the OFW.
      - Core OS file table is exactly the same than the OFW.
      - PUP size is exactly the same than the OFW.
      More stealth than it, its an OFW ;)

      Tested on both NAND (CECHC04) and NOR (CECH-2004B).

      Enjoy
      Kazama, afrv, Louis Garry and 13 others like this.
    16. NoTaBaDPiLoT
      NoTaBaDPiLoT
      Well Even if I wanted to update from 4.83 to 4.84 I cant cause my top speed is 20KB Per sec and I wish this ps3 didnt come installed with 4.83 D:
    17. Vishera
      Vishera
      Either a bad hard drive , old hard drive or an old SATA controller.
      The fat models have old SATA controllers
    18. lmn7
      lmn7
      I am not talking about modifying the pup, I meant spoofing fw version in dev_flash to allow the pup to install. Don't know how accurate the information is, but I read that the patch pups only install if you are on a suitable fw version. So 4.84 expects 4.83 update files to be installed, 4.85 expects 4.84 etc. That's the point of the fw version spoof. But this is interesting info.

      I don't think you would be able to go straight to 4.84 from 4.82 because of what I mentioned above, you would need to at least spoof to 4.83 first to even allow the patch pup to install. But I don't know how the PS3 verifies you're on a specific firmware version, I'm hoping it just checks version.txt/index.dat, if not there probably isn't a way to do it, unless it checks in memory, in which case we could patch vsh memory, I don't know.

      But yeah the logic behind doing the first step, replacing files in flash with 4.83, is to prevent compatibility issues. 4.84 patch pup would expect 4.83 files to be there, if they're not, it would most likely cause some issues, maybe even a soft brick, I really can't say.

      Only way to install the patch pup seems to be turning on automatic downloads (from what I've read? haven't tested), but more testing would need to be done to ascertain this process. Either way, something like this would most likely be possible, but is it worth it, I'm not sure, because the proxy server still works on 4.82, although I have a feeling it won't for much longer.
      T.A.U and esc0rtd3w like this.
    19. SiegHart93
      SiegHart93
      i wonder if rebug team make another cfw based in the new 4.84 ofw , that would be awesome :love struck:
    20. pinky
      pinky
      probably not until a dex is available.

Share This Page