PS3 ArtemisPS3 r5 by haxxxen - 4.81 Mamba / MambaAutoloader Support Added

Discussion in 'PS3 News' started by STLcardsWS, Jan 19, 2017.

By STLcardsWS on Jan 19, 2017 at 1:02 PM
  1. 8,682
    8,426
    1,022
    STLcardsWS

    STLcardsWS Administrator

    Joined:
    Sep 18, 2014
    Messages:
    8,682
    Likes Received:
    8,426
    Trophy Points:
    1,022
    An unofficial update to ArtemisPS3 for better 4.81 Custom Firmware Support & Fixes was recently released, the project originally ported to the PS3 by Dnawrkshp has seen other developer such as Aldostools and now haxxxen provide some unofficial support over the lifespan of the project that is a great Cheat System for PS# CFW user's in this update MAMBA users will be pleased to know 4.81 MAMBA (& MambaAutoloader) has been added to the system. Additional information about this update can be seen in the details and links provided.

    Title_Screen.png


    • ArtemisPS3
      An Open Source Playstation 3 Hacking System created under the Project Artemis initiative (http://www.gamehacking.org/artemis)​


      Changes to ArtemisPS3 r5 by haxxxen

      • Fixed constant write for pointer codes (type 6 codes). Pointer codes were only once written and you had to activate them everytime from ingame xmb with start button. now this is not needed anymore ;)
      • Fixed prx unload from gui and made proper detection for cobra and mamba.
      • Now you can unload artemis_ps3.sprx from artemis gui in main menu with square button, though you have to wait for the "press start to attach" popup. it will single beep if successfully unloaded, or double beep if not loaded at all. you will also get debug output
      • Changed the memory management comparing to his original source, which has improved stability. there are still cases, where games cannot handle artemis prx, but now it doesn't crash anymore, when you exit games.
      • Removed an unnecessary syscall (sys_ppu_process_yield). dunno if it also improves stability, but on my side everything works smooth now with artemis gui and prx
      • Added 4.81 mamba payload to artemis from mambaloader (mamba and mambaloader payload).

    • How To Use ArtemisPS3
      • Checkout this previous news thread by Aldostools with some additional details about usage: LINK

      Credits
      • Lazy Bastard - Project Founder
      • Berion - GUI Graphic Designer
      • Dnawrkshp - Creator of ArtemisPS3-GUI and ArtemisPS3-PRX
      • NzV - PS3MAPI (on which Artemis is dependant upon)
      • PS2Dragon - Artemis Logo

    Download: via github

    Source: psx-place.com (2)
     
    Last edited by a moderator: Nov 10, 2017
    citra mulia, DeViL303, Drag and 7 others like this.

Comments

Discussion in 'PS3 News' started by STLcardsWS, Jan 19, 2017.

    1. DeadManInblack
      DeadManInblack
      Awesome thanks for keeping this great bit of software updated :)

      Just wish there was a search or some kind of folder function.
    2. atreyu187
      atreyu187

      Amazing stuff @haxxxen I almost have no need for my CU3 dongle anymore. Still gonna keep it as they are hard to come by nowadays.
    3. psydefx
      psydefx
      great work @haxxxen. whats the attach combo now?
    4. Metalomeus
      Metalomeus
      Nice work @haxxxen !!!
      It´s nice to have support for 4.81....

      Thank you :eagerness:
    5. pp53
      pp53
      Good Work Haxxxen
      is it possible to ask to add a scroll cheats like on the PS2:
      R1 to scroll down for 5 games. R2 scrolls down following the letter A->B.
      L1, L2, respectively, up.
      sorry for my bad English
    6. MoJagot
      MoJagot
      Any luck to get this working on rebug 4.81.2? when I was 4.81.1 it worked perfectly but since I updated the firmware my game crashes a few minutes after the codes are attached.
      I'm currently using cobra mode on rebug 4.81.2 Rex with webman mod 1.45.10 full edition.
      Thanks
    7. haxxxen
      haxxxen
      i do not change the inner workings of artemis plugin, so it is still the same.

      can you try an older version of wMM and also the updated original one? some other user also had some problems with latest wMM on latest rebug running artemis.

      @bguerville
      i have noticed your answer in wMM thread, but somehow this really is wm related.
    8. bguerville
      bguerville
      I couldn't have guessed.
      So these problems only happen with wMM? Not multiman? Not webman?
      If so it's probably memory related...
    9. haxxxen
      haxxxen
      it was in case of the other user. i even have tried same game with same conditions (except same ps3 model) and had no freezing issue. so result was, wMM wasn't working for him, but multiman and even vanilla webman.
    10. bguerville
      bguerville
      But multiman & vanilla webman... what.. ? They worked for him?
      And you couldn't reproduce it with the same game & wMM?

      Hmm... So really there is no certainty at all regarding the precise source of this user's issue...?
    11. haxxxen
      haxxxen
      that was another user, but yes, there was no obvious evidence for the actual problem.
    12. MoJagot
      MoJagot
      I'll try that tomorrow, rebug 4.81.2 comes with webman mod 1.45.09 built in so is that the lowest version I can install or can I go lower?
      Thanks
    13. bguerville
      bguerville
      It depends if you are using cex or dex.
      4.81 CEX CFW support was added in wMM 1.45.02 so that is the lowest version you can test in CEX.
      If you use DEX mode however 1.45.03 would be the lowest possible version.
      If ever there was a memory issue due to wMM, you may want to test 1.45.02 or 03 because in later builds significant changes were made that had an impact on memory management.
      You may also want to test deank's webman to be sure that the issue comes only from using webMAN-MOD.

      Please report your results as for now your problem cannot be reproduced & it is unsure if & how webMAN-MOD is responsible for it.
      Last edited: Jan 24, 2017
    14. MoJagot
      MoJagot
      Do you have or know where I can get a copy of wMM 1.45.04? the updater pkg has been removed from github
    15. bguerville
      bguerville
    16. MoJagot
      MoJagot
      Thanks dude
      I had an old version of artemisps3 r5 4.80 by aldostools and I tried installing that with current webMAN-MOD and everything seems to be working now.
      Very weird but at least artemis is working
      Thanks for all the help guys!
    17. bguerville
      bguerville
      That's OK. Am glad it works.

      @haxxxen
      What do you think this means?
      Further wMM tests have not been done but if ArtemisPS3 4.80 by Aldo works....
    18. Zoilus
      Zoilus
      Im on rebug 4.81.02 with wMM 1.46.01 full version installed. With this Artemis r5 I kept having issues until I disabled wMM in the toolbox, and did full reboot. Cobra is always active, no need to install Mamba

      after that, I load the game with Multiman 4.81.02, then start Artemis r5 , pick my codes, afterwards press X on the "start" in the main menu, and I hear the one beep, I then put a ps3 game disc in the drive (although I don't think this is needed I did anyway) after that I launch the game

      haven't had any issues since

      Even if I loaded the games with Multiman as long as webman was active , I would still get freezing and or soft bricking. .once it was off in the toolbox, no more problems!
    19. bguerville
      bguerville
      Would you mind trying to use Cobra's boot_plugins.txt to load webMAN-MOD from /dev_hdd0 instead of the Rebug way.
      Make sure webman is disabled in the Toolbox & simply copy the webftp_server.sprx to /dev_hdd0 & edit boot_plugins.txt to add /dev_hdd0/webftp_server.sprx...
      Reboot & test if you still get issues with Artemis when wMM is loaded...

Share This Page