PS3 ArtemisPS3 r5 by haxxxen - 4.81 Mamba / MambaAutoloader Support Added

Discussion in 'PS3 News' started by STLcardsWS, Jan 19, 2017.

By STLcardsWS on Jan 19, 2017 at 1:02 PM
  1. 8,723

    STLcardsWS Administrator

    Sep 18, 2014
    Likes Received:
    Trophy Points:
    An unofficial update to ArtemisPS3 for better 4.81 Custom Firmware Support & Fixes was recently released, the project originally ported to the PS3 by Dnawrkshp has seen other developer such as Aldostools and now haxxxen provide some unofficial support over the lifespan of the project that is a great Cheat System for PS# CFW user's in this update MAMBA users will be pleased to know 4.81 MAMBA (& MambaAutoloader) has been added to the system. Additional information about this update can be seen in the details and links provided.


    • ArtemisPS3
      An Open Source Playstation 3 Hacking System created under the Project Artemis initiative (​

      Changes to ArtemisPS3 r5 by haxxxen

      • Fixed constant write for pointer codes (type 6 codes). Pointer codes were only once written and you had to activate them everytime from ingame xmb with start button. now this is not needed anymore ;)
      • Fixed prx unload from gui and made proper detection for cobra and mamba.
      • Now you can unload artemis_ps3.sprx from artemis gui in main menu with square button, though you have to wait for the "press start to attach" popup. it will single beep if successfully unloaded, or double beep if not loaded at all. you will also get debug output
      • Changed the memory management comparing to his original source, which has improved stability. there are still cases, where games cannot handle artemis prx, but now it doesn't crash anymore, when you exit games.
      • Removed an unnecessary syscall (sys_ppu_process_yield). dunno if it also improves stability, but on my side everything works smooth now with artemis gui and prx
      • Added 4.81 mamba payload to artemis from mambaloader (mamba and mambaloader payload).

    • How To Use ArtemisPS3
      • Checkout this previous news thread by Aldostools with some additional details about usage: LINK

      • Lazy Bastard - Project Founder
      • Berion - GUI Graphic Designer
      • Dnawrkshp - Creator of ArtemisPS3-GUI and ArtemisPS3-PRX
      • NzV - PS3MAPI (on which Artemis is dependant upon)
      • PS2Dragon - Artemis Logo

    Download: via github

    Source: (2)
    Last edited by a moderator: Nov 10, 2017
    citra mulia, DeViL303, Drag and 7 others like this.


Discussion in 'PS3 News' started by STLcardsWS, Jan 19, 2017.

    1. Zoilus
      wait are you talking about taking webftp_server.sprx and copying it to dev_hdd0 root, then write it in to the txt... (and deleting the command already there for webftp_server.sprx which has it launching from the plugins folder, although it isn't there)

      would I have to do anything to wMM or is that sprx, wM and wMM all together...kinda?
      Last edited: Feb 14, 2017
    2. Phil
      I get freezes every time I use this now on Wembman 1.46.02 rebug 4.81.2. Has defo worked previously on the same firmware. Any ideas guys
    3. kozarovv
      Try with older webman MOD, if same revision of Artemis worked on the same firmware, then problem can be webman MOD. Or memory usage of webman MOD.
    4. bguerville
      As you must know there are 2 ways to load webman in Rebug, although in theory there are 2 more if you add Mamba & prx loader....

      1. The standard Rebug way by using the Rebug Toolbox. When you disable webman, it simply renames the webftp_server.sprx located in /dev_flash/vsh/module so the file cannot be found & loaded.
      2. The standard Cobra way, using boot_plugins.txt as you would in any Cobra CFW.

      What I suggested was to disable webman in the Rebug Toolbox, copy your webftp_server.sprx to /dev_hdd0 & add /dev_hdd0/webftp_server.sprx to boot_plugins.txt.
      Those are thé only steps required.
      Once done, test & report....

      Btw any invalid path or path to non existing files found in the boot_plugins.txt will be ignored by Cobra.
      Last edited: Feb 19, 2017
    5. Phil
      Working fine with older Wembman. Thanks. There must be a conflict or some sort with the latest builds maybe
      RandQalan likes this.
    6. MoJagot
      Out of curiosity what version are you using?
      And have you tried using it with the latest webMAN-MOD 1.47 or sman?
    7. gold
      the download link is broken
    8. bguerville
      It is broken because Dropbox changed the format of its links some days ago. Expect all Dropbox links to give you similar problems.

      In the meantime, the source is here:

      However it's a hard to compile for most users as you need to install Visual Studio + PS3 SDK (under s#ny license!) + psl1ght + psl1ght extension for VS.

      Be patient, I am sure another member will post a link to the latest pkg for you. If not, I will eventually recompile the project for you.
    9. sergio_prado
    10. cyber-spwn
      Nice work on fixed freeze game when exit to xmb @haxxxen, the attached cheat also working properly :encouragement::encouragement:.
      Facing new issue system get freeze when returning to game after saved game.
      Test run on rebug 4.81.2 with cobra mode enable
    11. haxxxen
      I have made a small update to artemis prx. I have added now the ability to disable specific codes at button press and I am now introducing a new codetype 5.

      for this to work you have to add a codetype 5 for the specific code you want to disable. this codetype looks like the original except it has the original value instead of cheat value and the number 5 as prefix.

      note: for now it only works with codetype 0 and it will disable all given codetype 5 codes at once (still no idea how to solve this, like with usercheat)

      to find the original values you have to search eboot.elf or if it is the case and there are AoB codes in the existing .ncl files you can get the original value from these ones.

      for example this is how the .ncl file for the game Neverdead (BLES01303 1.00) could look:
      Infinite Ammo + Bottomless Clip
      0 0076CC30 60000000
      Infinite Ammo Off
      5 0076CC30 D1A30004
      Infinite Ammo On/Off
      0 0076CC30 60000000
      5 0076CC30 D1A30004
      now to get the original value from AoB code another example with the game Neverdead. in .ncl file you will find:
      Infinite Ammo + Bottomless Clip
      0 0076CC30 60000000
      AoB Infinite Ammo + Bottomless Clip
      B 00010000 04000000
      B D1A300044E8000202C2400007C0802A6 600000004E8000202C2400007C0802A6
      you have to use the address given for the cheat code, so here it is:
      to get the original valule, you have to look at the AoB code:
      this will be the final cheat value and:
      is the original value that gets replaced. so in this example:
      will be replaced with:
      so now you can make the disabler with the help of the premade .ncl file.

      final code
      5 0076CC30 D1A30004

      when you are in game and already codes written with START-button, you can now disable the specific codes with L3 button from ingame xmb.

      this is test pkg for now and as said it only works for codetype 0 disablers. i cannot upload the changed code to github atm, but i will do this asap.
      Last edited: Jul 8, 2017
    12. HaZe-CFW
      help me because I did cheats for a game then after 10 mins it kicked me out and says connect a controller and wont do anything and I'm stuck on it plz help
    13. bguerville
      If the system gave you a black screen asking for you to plug in a controller, it means that the system got corrupted. Dodgy patches, a problem with an application or a memory conflict can have that effect of course. NetcheatPS3 is probably responsible for what happened but we cannot confirm it's the case or tell you exactly what happened, it's impossible without the appropriate data & possible investigation.

      From there, you have 2 possibilities:
      1. If the console refuses to restart to XMB you may have to reinstall the CFW. It takes 5mn & you will not lose your data.

      2. If the console restarts to XMB after the error then you should not need to do anything specific.
    14. HaZe-CFW
      kk thanks for helping me I really appreciate it. so how do I reinstall CFW
    15. bguerville
      It depends whether or nor you are stuck with the black screen on boot or not.
      If you can still load the XMB on boot, get the PUP file corresponding to your CFW then install it with the XMB Settings/System Update via storage device feature with a fat32 USB key (not a hdd), the usual way...
      The path to the CFW PUP file on the usb key should be all in caps letter like this:
      Last edited: Aug 4, 2017
    16. HaZe-CFW
      I'm stuck on a screen that says 'The system software cannot be run correctly. Press the PS button to try to restart the system. If the system cannot be restarted, you must reinstall the system software. Connect storage media that contains update data of version 2.70 or later, and then press the START and SELECT buttons at the same time. For information on how to obtain update data, refer to the SIE Web site for your region.
    17. bguerville
      In this case, you must prepare the USB key with the required PUP file as I described previously then follow the on-screen instructions. The Start+Select combo will begin the reinstall process.
    18. HaZe-CFW
      my controller wont connect what should I do
    19. bguerville
      Your controller will connect via USB. Use a cable until the cfw is reinstalled.
    20. HaZe-CFW
      I plug it in using a cable press the ps button and nothing happens

Share This Page