PS3 ArtemisPS3 r5 by haxxxen - 4.81 Mamba / MambaAutoloader Support Added

Discussion in 'PS3 News' started by STLcardsWS, Jan 19, 2017.

By STLcardsWS on Jan 19, 2017 at 1:02 PM
  1. 8,869
    8,829
    1,172
    STLcardsWS

    STLcardsWS Administrator

    Joined:
    Sep 18, 2014
    Messages:
    8,869
    Likes Received:
    8,829
    Trophy Points:
    1,172
    An unofficial update to ArtemisPS3 for better 4.81 Custom Firmware Support & Fixes was recently released, the project originally ported to the PS3 by Dnawrkshp has seen other developer such as Aldostools and now haxxxen provide some unofficial support over the lifespan of the project that is a great Cheat System for PS# CFW user's in this update MAMBA users will be pleased to know 4.81 MAMBA (& MambaAutoloader) has been added to the system. Additional information about this update can be seen in the details and links provided.

    Title_Screen.png


    • ArtemisPS3
      An Open Source Playstation 3 Hacking System created under the Project Artemis initiative (http://www.gamehacking.org/artemis)​


      Changes to ArtemisPS3 r5 by haxxxen

      • Fixed constant write for pointer codes (type 6 codes). Pointer codes were only once written and you had to activate them everytime from ingame xmb with start button. now this is not needed anymore ;)
      • Fixed prx unload from gui and made proper detection for cobra and mamba.
      • Now you can unload artemis_ps3.sprx from artemis gui in main menu with square button, though you have to wait for the "press start to attach" popup. it will single beep if successfully unloaded, or double beep if not loaded at all. you will also get debug output
      • Changed the memory management comparing to his original source, which has improved stability. there are still cases, where games cannot handle artemis prx, but now it doesn't crash anymore, when you exit games.
      • Removed an unnecessary syscall (sys_ppu_process_yield). dunno if it also improves stability, but on my side everything works smooth now with artemis gui and prx
      • Added 4.81 mamba payload to artemis from mambaloader (mamba and mambaloader payload).

    • How To Use ArtemisPS3
      • Checkout this previous news thread by Aldostools with some additional details about usage: LINK

      Credits
      • Lazy Bastard - Project Founder
      • Berion - GUI Graphic Designer
      • Dnawrkshp - Creator of ArtemisPS3-GUI and ArtemisPS3-PRX
      • NzV - PS3MAPI (on which Artemis is dependant upon)
      • PS2Dragon - Artemis Logo

    Download: via github

    Source: psx-place.com (2)
     
    Last edited by a moderator: Nov 10, 2017
    citra mulia, DeViL303, Drag and 7 others like this.

Comments

Discussion in 'PS3 News' started by STLcardsWS, Jan 19, 2017.

    1. bguerville
      bguerville
      Hmmm.. That is not right...
      If nothing happens it means the gamepad does not get powered.
      Try using another gamepad? another usb cable? another USB socket on the PS3?
    2. HaZe-CFW
      HaZe-CFW
      I switch sockets like to plug usb and cable and every time I put usb on the right and cable left the cable don't work
    3. HaZe-CFW
      HaZe-CFW
      I got it working NOW!!! THANK YOU SO MUCH BRO!!
    4. bguerville
      bguerville
      Am glad you got it sorted.
      For info, if ever one of the USB ports does not work anymore, if your ps3 is a phat model, you could simply swap the USB board with a replacement board coming from a dead console. On slim models, it might be sufficient to change the USB connector, unlike on phat models it's not a USB board per se because there's no USB hub chip on it as it's integrated into the Southbridge on the motherboard.


      If you look for one, you will find ylod consoles of your own model for 10 bucks for replacement parts + a set of idps/psid for spoofing.
    5. Spawn
      Spawn
      Dropbox link is dead?
    6. bguerville
      bguerville
      Spawn and kozarovv like this.
    7. Spawn
      Spawn
      Thank you. Unfortunately GitHub doesn't show any downloads, only readme and source files. :(

      Nevermind, found it by swapping browser. :)
    8. kozarovv
      kozarovv
      bguerville and Spawn like this.
    9. bguerville
    10. Spawn
      Spawn
      Is there a way to add cheats? If yes, where do I find them?
      Missing Borderlands cheats and several others that exist is, for me, wrong region.. :(
    11. spawnkiller56
      spawnkiller56
      is there a way to change how to attach. caws I would like to change to R3+L3+R2+L2 or some thing like that caws some games you cant attach to by using start like AC Rogue. if there is please tell me how. THANK YOU
    12. haxxxen
      haxxxen
      it could be changed to any button or combo, though I don't know why you are having problems with START button to attach to process. I personally have tried AC Rogue with cheats and Artemis and there was no problem for me attaching. you have to press the button sometimes a few times till it gets acknowledged.
    13. spawnkiller56
      spawnkiller56
      could you tell me how to change it caws I've got 6 games that has the same problem thank you
    14. haxxxen
      haxxxen
      @spawnkiller56
      would you mind to try the attached version of artemis_ps3.sprx. it still has the old buttons to attach, but I have changed the pad recognition.

      if it still does not work for you, I will make a new one with the custom button combo. it's just I don't want to change artemis that much and stay as original as it can be. the new button combo has to be changed in the source itself and has to recompiled, so no other way to include your custom combo.
    15. spawnkiller56
      spawnkiller56
      it still doesn't work I've tried pressing molty time,holding,be for game starts,in option,right whenit says to press start and still nothing. I try on 3 dif games that did the same and still had the same problem
    16. haxxxen
      haxxxen
      do you press PS button first to launch ingame xmb? only then press START button to attach artemis to game process

      btw, I would wait to attach and write codes until the game has loaded up to main start screen. I have encountered a few games, where some sysutils couldn't be loaded when attaching to early in loading process
    17. Metalomeus
      Metalomeus
      When i do that what @haxxxen said it kicks me into Recovery but Console is restarting fine.
    18. haxxxen
      haxxxen
      that can
      that can happen because of too low memory and depends on games. best compatibility with artemis running is using DEX and systemsoftware mode from my experience. last game that happened to me was L.A. Noire where I cannot run it in Release Mode and using artemis plugin

      it seems with some games, when artemis plugin is running the trophy plugin cannot be loaded in release mode
      Metalomeus likes this.
    19. Metalomeus
      Metalomeus
      Thx for clarifing this behaviour. Never thought of switching to DEX but i have Rebug 4.82 installed so i will give it a go !
    20. spawnkiller56
      spawnkiller56
      I've gone all the way till I am in the game. I've notest when start is the main function of the game wether to load game then load save then paws it is impausble to attach in those instinsis oh and sorry for my por spelling

Share This Page