PS2 FORTUNA FMCB Launcher by VTSTech

Discussion in 'PS2 Homebrew' started by VTSTech, Dec 27, 2019.

By VTSTech on Dec 27, 2019 at 10:33 AM
  1. 333
    425
    97
    VTSTech

    VTSTech Developer

    Joined:
    Apr 8, 2019
    Messages:
    333
    Likes Received:
    425
    Trophy Points:
    97
    Gender:
    Male
    Home Page:
    In the PS2 Community developer @VTSTech has been sharing a few new tools and utilities and the developer recently release the FORTUNA FMCB LANUNCHER (SCPH-9XXXX Models w/ 2.30 bios), currently residing at version 0.2 the tool is a great asset to the recent breakthrough of the Fortuna Project, which a new ps2 exploit by developer @krat0s (from PS2-Home.com). With this utility by VTSTech you can "quickly launch FMCB or BOOT2.ELF from either Memory Card" as VTSTech details below for full info surrounding this recently released tool:
    -STLcardsWS

    774ae88a9f1ee6e99bc769342e5b9704.png

    • FORTUNA FMCB Launcher (BOOT.ELF Replacement)
      This tool will quickly launch FMCB or BOOT2.ELF from either Memory Card.
      Intended for use on SCPH-9XXXX PS2 w\ 2.30 BIOS

      The logic flows as follows:
      If FMCB Exists-> Run FMCB from MC0 if present, Then MC1 if present

      If BOOT2.ELF Exists (And FMCB not present) -> Run BOOT2 from MC0 if present, Then MC1 if present
      If any condition in that order presents a path to execution. It will take the first one.

      Demo 1 (no FMCB)
      Demo 2 (FMCB)
      GitHub: https://github.com/Veritas83/PS2_FORTUNA_FMCB_Launcher

      Changelog:
      v0.2
      Code cleanup
      No longer loading Pad Manager
      No longer Initializing DVD
      Removed all delays
      No longer in Beta
      Now includes Source Code, Packed/Unpacked BOOT.ELF
      v0.1-beta2
      Added missing mc1 BOOT2.ELF detection
      Made a '0 delay/no sleep()' build available.
      v0.1-beta1
      First public release
      Checks for FMCB on either MC.
      Checks for BOOT2.ELF in /FORTUNA/ on either MC
      Boots FMCB if it is present.
      Otherwise boots BOOT2.ELF
      Includes packed/unpacked ELF

      Credits:
      Uses OSDInit.c/h & libcdvd_add.c/h from 'OSD Initialization Libraries' by SP193
      Compiled with current PS2SDK as of Nov 2019
      Packed with PS2-Packer v1.1.1-unofficial-09ac9c6 by Nicolas "Pixel" Noble
     

    Attached Files:

    Last edited by a moderator: Jan 12, 2020
    Johnnie, jeka26, rocknard and 7 others like this.

Comments

Discussion in 'PS2 Homebrew' started by VTSTech, Dec 27, 2019.

    1. Fuso
      Fuso
      I've tried to run FMCB with this launcher on 90004 date code 9C, but without success. It loads something and then goes back to the Browser. I've also tried to replace BOOT.ELF with ESR.ELF (renamed to BOOT.ELF) and it runs ESR directly without a problem.
      HWNJ likes this.
    2. Fuso
      Fuso
      So ESR is not working properly also. If you load first uLaunchELF and the ESR it's working. After that if you put the PS2 to stand by or reset it and load directly ESR as BOOT.ELF it's working again. But if you unplug the power cable and after that plug it again and try to load ESR as BOOT.ELF it get stuck on pink screen.
    3. jolek
      jolek
      You have tried Fortuna Rev 1 or 2 with this launcher (v0.2)?

      Did you at least get the message that FMCB was found on any memory card?
    4. Fuso
      Fuso
      I'm using rev 2. It flashes so fast and I can't see what was found or loaded from the memory card. FMCB was pre-installed on my PS2 50004 with Multi-Install. I did not try to install FMCB from the PS2 90004.
    5. jolek
      jolek
      Are you sure that the problem with ESR is not related to the quality of a disc?
      Most of a time when disc stuck at ping screen, PS2 have trouble with reading it.
    6. Fuso
      Fuso
      No, it happens with every single disc. As soon as I load ulaunchelf the ESR starts working until next unplugging from the power outlet. Even If I put ESR as BOOT2.ELF it still stuck at pink screen.
      jolek likes this.
    7. VTSTech
      VTSTech
      beta2 still had a delay in it so you can read what's happening.

      in 0.2 it seemed to be working everywhere so i removed all delays

      Also in 0.2 i stopped initializing the DVD, Maybe ESR expects the DVD Init to already be done?

      Try beta2, see if behavior changes.
    8. sp193
      sp193
      I think the wLaunchELF versions will load the dummy DVD Player-flagged KELF, to unlock DVD Video Disc reading.

      Since Fortuna is an exploit for the OSDSYS program, DVD Video Disc reading is disabled by default.
      krHACKen and Fuso like this.
    9. Fuso
      Fuso
      With "beta2" it's the same, stuck at pink screen. I also tried with the "beta2" a memory card with multi-installed FMCB from my other PS2. It says that is launching FMCB from MC1 and then goes back to the Browser with no FMCB loaded.

      edit: Now I've tried to install FMCB from the 90004 console, it says "Launching FMCB" and again goes back to the Browser without FMCB loaded.

      edit2: Watched some Brazilian gyu's youtube video and downloaded his FMCB + FORTUNA archive, installed and copied his FORTUNA folder and everything is working now, it even loads the FMCB installation from my 50004 PS2. It seems that his BOOT.ELF is HWC-OSDSYS_Launcher which I've tried yesterday but I've got only black screen, I don't know maybe I messed up something. Still... I don't understand why VTSTech's ELF doesn't load FMCB.
      Last edited: Jan 13, 2020
      HWNJ likes this.
    10. TnA
      TnA
      I would try to format the MC with MCAv2 and redo the installation of these things... (or simply try another MC, but I would format it anyway.)

      Maybe the Launcher (either @VTSTech's or @HWNJ's) got written to a location, where there was one or two bad clusters!
    11. Versatile
      Versatile
      Is this a way to use fmcb on 9xxxx models not compatible with fmcb? If not what is its purpose?
    12. Macuserj93
      Macuserj93
      I also have problems with this tool. I can load uLaunchelf with FORTUNA and no issues, but, when I try the FMCB launcher v0.2, I've got this:

      FORTUNA rev2 detected on Memory Card2!
      FMCB detected on Memory Card 1!
      Launching FMCB...

      But I also have the problem that goes directly to the browser. I'm using FMCB 1.966.

      When I load uLaunchelf, I run OSDYS.elf from the MISC folder, and boots FMCB with no issues.

      Any ideas why FMCB is not launching from this tool?? :apologetic: I don't know what I'm doing wrong.
      HWNJ and jolek like this.
    13. HWNJ
      HWNJ
      If a cluster is damaged, perform a FMCB v1.9+ Multi-Region (not cross linked) install and the remove the main kelf for your version (usually mc0:/B_EXEC-SYSTEM/osdmain.elf). Also, use my OSDSYS Launcher if you have BIOS v2.30+
    14. TnA
      TnA
      I have no problems with the MC. I was replying to someone before my post! ;)

      Glad to see you!
      Still no mobile internet (or internet at home or close, where you don't pay per hour or so).
    15. HWNJ
      HWNJ
      I am still paying per hours. I came here (to the cybercafé) today to download some drivers and to upload an update to an application of mine here at PSX-Place.
      Sadly, the mods at PS2-Home seems to have Cuba banned (or the ONLY Firefox version installed in EVERY cybercafé in the country *seriously, all the cybercafés here uses the same system and apps*), so I will only post it here on PSX-Place :p
      This is the only browser available on EVERY Cuba's cybercafé, so, or you allow it, or you will have a big amount of users without access to your forum.
      [​IMG]
      Code:
      Record #: 530247
      Time: Sat, 08 Feb 2020 08:19:19 am PST
      Host / ISP: 181.225.231.186
      Geohost: 181.225.231.186.--.O1.0.nohostname
      IP Address: 181.225.231.186
      Post:
      Query:
      Stripped Query:
      Referer:
      User Agent: Mozilla/5.0 (Windows NT 6.1; rv:54.0) Gecko/20100101 Firefox/54.0
      Reconstructed URL: http:// www.ps2-home.com /forum/app.php/portal
      
      Glad to see you too!!
      Last edited: Feb 8, 2020
      TnA likes this.
    16. HWNJ
      HWNJ
      That's because @VTSTech did not tested his own application on real hardware and with "real hardware" I mean a PS2 with BIOS v2.30+
      https://www.psx-place.com/threads/hwcs-osdsys-launcher-v1-1.28132/
    17. HWNJ
      HWNJ
      You should rework this section a little bit:
      Code:
      OSDInitSystemPaths();
      SYSEXEC = OSDGetSystemExecFolder();
      strncpy(SYSEXEC,OSDGetSystemExecFolder(),13);
      strncat(SYSEXEC,"/osdmain.elf",12);
      
      I will release the code for my OSDSYS Launcher soon, so you might want to take a look.
      Also, it seems that Fortuna rev2 is kinda buggy and every ELF launched after it will cause some system functions to work faulty. You might want to add some debug printing to your app to understand what I mean.

      Edit: typofix
      Last edited: Feb 8, 2020

Share This Page