PS3 Official Firmware 4.81 Exploit - Software Downgrader & More Incoming! Could SuperSlim be hacked?

Discussion in 'PS3 News' started by STLcardsWS, Nov 9, 2017.

By STLcardsWS on Nov 9, 2017 at 6:45 PM
  1. 9,300
    9,589
    1,172
    STLcardsWS

    STLcardsWS Administrator

    Joined:
    Sep 18, 2014
    Messages:
    9,300
    Likes Received:
    9,589
    Trophy Points:
    1,172
    It was nearly 7 years ago since we have seen a PS3 Official Firmware Exploited (3.55 being the last), which predates many PS3 models and thus why those later Slim & SuperSlim models could never install Custom Firmware (CFW) and/or Downgrade. However that could all change as a team of three have been developing a new project (4.81 OFW Exploit) called PS3Xploit. The "Unhackable PS3 models" will be a term of the past, but the exploits not quite there yet but the possibility of a HENkaku (vita) style hack is very plausible. Currently the exploit has allowed for access to enable Flash dumps on all consoles, Then Write access to Flash, unhackables (25xx +) will not be able to write but all previous PS3 will so that means Goodbye Hardware Flashers and Hello Software Downgradrs. The team is consisting of psx-place's very own @bguerville, @esc0rtd3w and W form the team behind PS3Xploit.

    The theory behind the project started off when bguerville was looking through some of the webkit source code (for unrelated research) and stumbled on a discovery and a discussion here on the psx-place forums was formed with theories on how the PS3 could be attacked with his findings. As time passed the team formed and an idea became a full-fledged project in development, A request came to temporary remove the said discussion as the idea spawned a project with alot of potential. Sadly this is not ready for release quite yet (but soon), while we know it is working there is additional development needed to make this complete. The team has a goal of 2018 (first Q1) target for the release of the exploit.

    PS3 SuperSlim.jpg


    Recently team member esc0rtd3w announced the tentative release date on another forum and it seemed some were so grateful they decided to intrude and breach his MEGA account and leak what they thought was the exploit / key component but was only a small puzzle piece of the entire thing and quite useless itself . While the good news it did not harm the project or discourage the development team behind Ps3Xploit. However esc0rtd3w did lose some personal files and also the community lost the huge collection of NoPSN Apps for the PS3. But don't cancel those subscription service's just yet, as esc0rtd3w is in the process of re-uploading the collection, you can follow the progress here .


    Also, I have been personally told by the team that some of the details being reported elsewhere are not 100% accurate, but rest assured we have first-hand information about this upcoming exploit and we will set the record straight and keep you flowing with the facts as they become available. bguerville has provided us with some details about this release and also tells us about what they plan to release first and that is coming in the next 24 hours in the form of a IDPS Dumper for 4.81 (All PS3 Models). (UPDATE >> Released)

    Additional details via @bguerville
    (NOTICE - Please Read ALL TABS contains IMPORTANT Details about the project !!! )

    • I started investigating the ps3 webkit about 6/7 months, but at the time, it was only to gather information, I had no idea I would eventually be the one working on it!

      End of August, I gave the information I had to esc0rtd3w & expected he would work on it alone. However, he knew nothing about webkit exploitation & he started to collaborate with W. By hijacking webkit, we inherit its privileges which means we are root & we get access to lv2 syscalls. However the ps3 OS is protected by NX (No eXecute is the bsd/linux equivalent of DEP on Windows), no address randomisation though. Executing our own payload is made impossible by NX but we can still execute code despite NX using ROP (Return Oriented Programming).


      The principle is simple, select snippets from the system code (snippets like these are called gadgets) & assemble them so execution jumps from one gadget to the next until the task we planned is done. It requires providing values/parameters & offsetting to each gadget instruction as well...


      First week of September, I joined their effort & 2 weeks later we had ROP execution.
      From that moment, I have been doing all the ROP development work alone while the other 2 helped with testing & researching (and debugging for esc0rtd3w).


      Right now I have 2 ROP chains ready, one for idps dumping & the other for flash memory dumping.

      The next part of the job is to modify the flash dumper into a flash writer.
      When that is done & released, ps3 hardware flashers will have become mostly obsolete.

      FYI, the idps dumper should work on any nor/nand model of ps3. Same goes for the flash memory dumper.

      It was tested ok on superslim.

      Once the ROP work above is finished , there is much more to be done & hopefully more releases to come...

      Stay tuned.....


    • The Current Status

      For now the main project we are working on will not jailbreak all consoles.

      It will enable flash dumps from all consoles but flash write only to all consoles up to 25xx so consoles that are are not cfw compatible will not really benefit just yet, except for dumping flash & idps but not for JB.


      For those with cfw compatible consoles on ofw, once flash is overwritten with a db ofw copy, a user can reboot then install the cfw of their choice. Hardware flashers being then obsolete.. You could also overwrite the flash memory in more recent consoles but that would result in a brick due to metldr2.

      It's only after that flash management project is done, in hopefully March that we will begin working on exploiting lv2. If we get the results we wish, we should be able to make a TaiHEN type of hack for all consoles including superslims.


      Once lv2 is exploited, I am not sure yet how far I will take it, whether I will also try to take on lv1.. Or leave it for someone else to build on by releasing a fully commented & dev friendly version... We will see how things go, ......


      However, even without lv1, direct access to lv2 functions using the right parameters would allow us to run homebrews (except those needing lv1 peek/poke) & backups without problems along with many other things.

    • I figured i would add this (tab) to add some news and thread related to this project, that has arisen after this article.​

    Stay tuned to psx-place.com as this story develops, we have the inside scoop on all the details as they flow. This is a huge breakthrough for the PS3 Community and will only progress from here on out!!!

    UPDATE : IDPS DUMPER HAS BEEN RELEASED> >> NEWS Coverage
    (Please Note - You should not update your PS3 firmware past 4.81 if a Software Update goes Live)



     
    Last edited: Nov 29, 2017

Comments

Discussion in 'PS3 News' started by STLcardsWS, Nov 9, 2017.

    1. pinky
      pinky
      here's the edat pkg builder:

      Code:
      http://www.mediafire.com/download/uby1vmyohyscsnq/MC00PKG.rar
      if you need to know how to use it, check out my creating a C00 license package tutorial. that link is taken from there. :).
      Last edited: Nov 19, 2017
      ed89 and esc0rtd3w like this.
    2. pinky
      pinky
      btw, I think TA (True Ancestor) can do this but with actual edat files instead of generic ones. this is assuming you need a pkg to begin with. I haven't looked into how to exploit a backup, so I'm just guessing really. TA can also make theme pkgs. I wrote a tutorial on creating them with make_package_npdrm.which is probably what TA is using. TA also has the ability to create theme packages. I wrote a tutorial on that as well, but directly through the make_package_npdrm. ;)
      Last edited: Nov 19, 2017
    3. Med27
      Med27
      Ok i wait exploit good luck thinks
    4. Med27
      Med27
      I tried pes18 and fifa18 with file licdat and programme true ancestor but error 80060001, i think wait exploit, think for all your explication
    5. MimounEH
      MimounEH
      ES: Hola,tengo una PS3 SuperSlim en 4.81 me aconsejáis actualizar o esperar hasta 2018.
      EN:Hi guys,I have one ps3 SuperSlim in 4.81 you advise me to update or to wait until 2018.
      Muchas Gracias de antemano! Thanks you!
    6. sandungas
      sandungas
      They have advised that is better to stay in the lowest fiirmware posible because that way there are more chances to find other new exploits that could unlock more features

      Han avisado que es mejor mantenerse en el firmware mas bajo posible porque de esa forma hay mas opciones de encontrar otros nuevos exploits que podrian desbloquear mas funciones
      MimounEH, Yugonibblit and DeViL303 like this.
    7. bguerville
      bguerville
      Having 4.81 or 4.82 will make no difference to future exploitation from what we have seen so far...
      No apparent changes have been made to the system except some newly added BD certificates to play movies. lv0/lv1/lv2 remain the same & vsh also.
      However, unless you watch new BD movies or use the PSN regularly, there is little point in updating to 4.82.
      esc0rtd3w likes this.
    8. esc0rtd3w
      esc0rtd3w
      Last edited: Nov 23, 2017
      bitsbubba, MixeryMaxe, habib and 7 others like this.
    9. Med27
      Med27
      esc0rtd3w likes this.
    10. esc0rtd3w
      esc0rtd3w
      that is to be discussed still. these domains were purchased and setup as a placeholder. we will most likely at least host the zip files there for static links to be had.

      depending on how everyone involved feels about it, we may or may not host the actual running exploit on the domains
      Amaan Khan likes this.
    11. Amaan Khan
      Amaan Khan
      Hey I have question can i update my Ps3 to 4.82 ofw now
      esc0rtd3w likes this.
    12. esc0rtd3w
      esc0rtd3w
      @Amaan Khan if CFW compatible YES 100%!! :D

      if 25xx Late Slim (3.60 minver), Slim 3000 series, or SuperSlim 4000 series then probably, but not certain yet. The exploit and tools currently do work on them, but maybe $ony stuck an easter egg in there lol :-p
      ed89 and Amaan Khan like this.
    13. Amaan Khan
      Amaan Khan
      Nope Superslim CECH 4208A

      Missing GTA online very much :)
      Last edited: Nov 23, 2017
      ed89 and esc0rtd3w like this.
    14. ed89
      ed89
      thanks @w and @habib from ps3exploit team too forgot to mention i did not know you are envolved too but thanks to https://ps3xploit.com/ i know it now.
      Great!
    15. lord3490
      lord3490
      kadorna2, esc0rtd3w and Amaan Khan like this.
    16. maniek6666
      maniek6666
      @ed89
      Forgot to add thanks to "esc0rtd3w"
      :D

      On my part also thanks to the developers of this project :)
      esc0rtd3w likes this.
    17. ed89
      ed89
      dont worry ;) mentioned @esc0rtd3w and @bguerville personally already in this news too
      maniek6666 and esc0rtd3w like this.
    18. Med27
      Med27
      If iunderstand the zip file software downgrad Will be annonced in ps3xploit.com?
    19. DeViL303
      DeViL303
      No it will be announced here first.
      esc0rtd3w likes this.
    20. esc0rtd3w
      esc0rtd3w
      @Med27 yes all Official News will be reported here first :D

      more than likely the ps3xploit site will be a file host or just a placeholder so scammers cannot trick people by using that name :eek:

      if all involved are ok with other uses, then we will pursue other avenues with it
      Flashed and ed89 like this.

Share This Page