PS3 Old Homebrew won't work on 4.82 Rebug: How to make it compatible?

Discussion in 'General PS3 Discussion' started by gamba66, Aug 4, 2019.

  1. 2
    0
    55
    gamba66

    gamba66 Member

    Joined:
    Dec 30, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    55
    Hello

    I am trying to run Hexen and Heretic on my Playstation 3 Fat (CECHA01) and when I try to start the homebrew after installing it (no problems there) I get an error 8001017.

    Here it is: https://www.brewology.com/downloads/download.php?id=12337&mcid=4

    I suspect the homebrew is made for older custom firmwares and needs to be updated or patched to work on 4.82.

    Anyone can help me out with that? I have been searching for solutions for an hour and I am about to give up but I absolutely love these older games and really want them to work.

    Thanks very much in advance
     
  2. 14
    4
    7
    CoMeBaCk

    CoMeBaCk Forum Noob

    Joined:
    May 10, 2019
    Messages:
    14
    Likes Received:
    4
    Trophy Points:
    7
    Gender:
    Male
    Então, isso é possível e só se você tiver o código do homebrew e também saber programar o lol você não deveria tê-lo. Se você quiser emular jogos antigos, use Retroach e emula vários consoles.

    : sfl brasil:
     
    Last edited: Aug 27, 2019
  3. 11,921
    4,768
    497
    pinky

    pinky Bitsiboo's Other Half Developer

    Joined:
    Mar 8, 2015
    Messages:
    11,921
    Likes Received:
    4,768
    Trophy Points:
    497
    Gender:
    Male
    Location:
    The Great Gig in the Sky
    you can find out what firmware that's on by looking at the PARAM.SFO or the EBOOT.BIN (in scetool).
     
  4. 11,921
    4,768
    497
    pinky

    pinky Bitsiboo's Other Half Developer

    Joined:
    Mar 8, 2015
    Messages:
    11,921
    Likes Received:
    4,768
    Trophy Points:
    497
    Gender:
    Male
    Location:
    The Great Gig in the Sky
    I think there may be something wrong with that EBOOT.BIN. scetool and ps3tools can't read its info.
     
  5. 8,929
    9,000
    1,172
    STLcardsWS

    STLcardsWS Administrator

    Joined:
    Sep 18, 2014
    Messages:
    8,929
    Likes Received:
    9,000
    Trophy Points:
    1,172
    try to resign (there is a variety of tools and methods,) one way True Ancestor PKG Repacker (v2.45) and follow the onscreen instructions of unpacking the pkg (option 3) and then the fast package option (option 1) with Resign toggled ON.("ON" by default), )
     
  6. 11,921
    4,768
    497
    pinky

    pinky Bitsiboo's Other Half Developer

    Joined:
    Mar 8, 2015
    Messages:
    11,921
    Likes Received:
    4,768
    Trophy Points:
    497
    Gender:
    Male
    Location:
    The Great Gig in the Sky
    neither eboot can be read. and, decrypting to elf results in an error. that would explain that error you're getting. I checked my setup with one of my pkgs (tales of graces, the game), and it reads that EBOOT.BIN just fine.

    edit: I can get the content id, which displays the other information, but there are errors.
     
  7. 2
    0
    55
    gamba66

    gamba66 Member

    Joined:
    Dec 30, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    55
    Thank you guys so much

    Yes I have tried every tool mentioned here but unsucessfully unfortunately

    I guess it just doesnt work or the encryption is too old
     
  8. 11,921
    4,768
    497
    pinky

    pinky Bitsiboo's Other Half Developer

    Joined:
    Mar 8, 2015
    Messages:
    11,921
    Likes Received:
    4,768
    Trophy Points:
    497
    Gender:
    Male
    Location:
    The Great Gig in the Sky
    it seems like something is wrong with the way it was encrypted. the content id says that one of those homebrews is from 3.40.
     

Share This Page