PS3 doesn’t recognise USB pendrive anymore

Discussion in 'General PS3 Discussion' started by Andry90120, Apr 6, 2020.

  1. 30
    6
    32
    Andry90120

    Andry90120 Member

    Joined:
    Mar 6, 2018
    Messages:
    30
    Likes Received:
    6
    Trophy Points:
    32
    Gender:
    Male
    Hello guys! As the title suggest, my PS3 suddenly stopped recognise my USB pendrive without a reason.
    A few days ago I formatted my USB pendrive (I always do a complete format, and not the fast one. And always in FAT32) And from that day, my PS3 stopped to recognise it.
    I tried to reformat a few times, even in exFAT, but nothing, my console still refuses to read it.
    If it can be useful: My PS3 it’s a 3004B 4.85 HFW with HEN installed, I always used that USB pendrive with that console (I also installed HAN with that pendrive, when HEN wasn’t even a thing)
    The strange thing that my backup PS3 (2504B 4.82 REBUG D-REX) my PS4 and my PC recognise it without problem.
    The right USB port (I also tried with the left one) works just fine: I tested it with others USB pendrives and all of them were recognised, I don’t know why the console refuses to read the one that I ever used.
     

Share This Page