PS3 PS3 ISO TOOLS v2.0 by Rudi Rastelli

Discussion in 'PS3 News' started by STLcardsWS, Nov 27, 2014.

By STLcardsWS on Nov 27, 2014 at 5:44 PM
  1. 9,674
    10,319
    1,672
    STLcardsWS

    STLcardsWS Administrator

    Joined:
    Sep 18, 2014
    Messages:
    9,674
    Likes Received:
    10,319
    Trophy Points:
    1,672
    PS3 ISO Tools by PlayStation 3 developer Rudi Rastelli has been updated to v2.0, with plenty of enchantments and changes contained in this update. Instead of using Estwald's "makeps3iso" utility, the developer has instead opted to use "genps3iso_v2.5" , the reason for the change is to give ODE compatibility, This update also contains some changes in Game [break]dd[/break] Patching, and various other changes as seen in the log below. Also be sure to checkout the updated README file that contains plenty of Tips and additional notes about this very useful Utility from Rudi Rastelli. The readme is included with the download and can also be seen in our forums via this link with additional PS3 ISO Tools Info.



    PS3 ISO Tools.PNG


     

    Attached Files:

Comments

Discussion in 'PS3 News' started by STLcardsWS, Nov 27, 2014.

    1. Dillsta
      Dillsta
      Thanks for the awesome update. Unfortunately I can't get this version or any version of your PS3ISO tools to work when creating ISO's.

      It always crashes after I choose the directory to save the ISO's to. Is there any dependencies i could be missing?


      I've tried the following:
      • Batch converting
      • Converting one game at a time
      • Converting different games
      • multiple versions
      • different workstations
      • running as administrator

      The tools work by themselves and most of the other tools work, it just always crashes when I try to convert to an ISO :(
    2. Fuzion9
      Fuzion9
      No Problems here, tested & working fine :)
    3. Rudi Rastelli
      Rudi Rastelli
      Pls Try:
      - Run it as admin
      - Don't have game folder open in explorer or somewhere else
      - May be your virus scanner blocks something
      - Run it in one of the different compatiblity-modes

      Does it work, when you un-check the patch option ?... Maybe there are some dependencies @RipCord's patch tools have, which i'm not aware of.
      Even if me and my testers had no problems with that i'll ask him about that.

      Does it freeze directly after selecting the save path for ISOs without showing the progressbar-window ?

      Edit:
      1. @RipCord told me that none of his resigners need special '*.dll'
      2. I've found out 'make_npdata.exe' needs 'msvcr120.dll', which might be already installed on most windows systems, but may be it's missing on yours. Same with 'genps3iso_v2.5.exe' which needs 'msvcr90.dll'. Try google these 2 DLL's and add them to the 'Tools'-subdirectory of PS3 ISO TOOLS(...or, if this doesn't work to main directory).
      Pls let me know if this solves your problem so i can add the DLL's in next release.

      Regards
      Rudi
      Last edited: Nov 29, 2014
    4. masa3108
      masa3108
      Hy ! Rudi .... many thx for this brilliant job ! All works fine in this Release right now !!


      best wishes
      Masa
    5. binavik
      binavik
      I keep getting an unexpected end of archive error. I've tried downloading with different browsers on different computers also tried extracting with winrar and 7zip but still have the same problems.
    6. Badboy
    7. balwind
      balwind
      DLL seems to be required

      To [MENTION=108]Rudi Rastelli[/MENTION]


      Hi i created an account just to say thank you and to let your know your tip helps get your tool working again finally

      I also just wanna say i too have always had your tool just crash when trying to create an iso ever since i formatted hdd. I thought it was because of the new versions (since above 1.6x i think) since older version b4 i formatted worked.

      I didnt put much thought in it as i would just run makeps3iso manually in cmd and then use yr tool to extract sfo which works just fine.

      Anyways i download both dlls that you said would help and put them in the tools folder , to my surprise i'm able to create iso now just fine.

      I cant speak for others but in my case, those dll are a must as i tested it by put them into older version of your tools and they all work now. i I am using win8.1 btw.

      Thank you

      EDIT : P.S I notice size differences between iso create by 1.98B and 2.0 . 2.0 Log file always shows WARNING with few MB differences between Folder and Iso
      | SIZE(MB) | SIZE(MB) | DIFF(MB) |FILES/FOLDERS|FILES/FOLDERS| STATUS |
      | | [Folder] | [ISO] | | [JB-Format]| [ISO-Format]| |
      2.0 log >>Motorcycle Club | 1236.45 | 1239.19 | 2.74 | 394/65 | 394/81 | WARNING |
      1.98B log >>Motorcycle Club | 1236.45 | 1237.11 | 0.66 | 394/65 | 394/66 | WARNING |

      Is this normal and should be expected ? . Should i stay with 1.98B since i dont use ODE ?

      Sorry for all those question. Thank you for your time.
      Last edited by a moderator: Dec 7, 2014
    8. STLcardsWS
      STLcardsWS
      It's on your end. Just tried the zippyshare link and the mirror here at PSX-Place and both downloaded an extracted fine

      Perhaps try with a download manager. such as IDM (internet download manager) (its a paid app but does have a free trial)
    9. STLcardsWS
      STLcardsWS
      Welcome to the forum hope you stick around and not just coming here for one post :) ..

      Thanks for the tips with the dll's
    10. balwind
      balwind
      Im just a forum lurker by nature as i have nothing to contribute, only reason i posted in this instance was coz i figured someone else might have same issues and a feedback would help em since the original poster didnt replied back to rudi.

      :)
    11. Rudi Rastelli
      Rudi Rastelli
      I'm already aware of this problem... it's caused by either "7zip" not being able to get the correct number of folders inside of some ISOs created by "genps3iso". But ISO itself is ok, because if you extract the ISO it's 100% the game-folder.
      I've already searched for a freeware alternative to "7zip" or newer versions without this problem... but i can't find any. Now i think about completely remove the folder check to circumvent this nasty problem.

      As CFW user u can do a little trick to use "makeps3iso" even with PS3 ISO TOOLS v2.0:
      Just rename "makeps3iso.exe" to "genps3iso_v2.5.exe" and copy it over to the "Tools"-directory of PS3 ISO TOOLS v2.0 replacing the existing "genps3iso_v2.5.exe"

      Regards
      Rudi
    12. Rudi Rastelli
      Rudi Rastelli
      Here u go: DOWNLOAD the missing DLLs and extract them to the "Tools"-subdirectory of PS3 ISO TOOLS V2.0.
      I'll add them in next release anyway.

      Regards
      Rudi
    13. STLcardsWS
      STLcardsWS
    14. Rudi Rastelli
      Rudi Rastelli
      UPDATE - PS3 ISO TOOLS V2.1

      Code:
      PS3 ISO TOOLS
        
        V2.1 - Changelog
       
      ********************** ENGLISH *********************** 
        - Bug fix: "Patch ISO"-function now really does a forced patching(range 4.20 to 4.66)
        - "Patch ISO"-function will be disabled for CFW below 4.20
        - Added recursive directory scan for "Create ISO(s)"-function (batch mode)
        - Added saving of all used options to config file upon program exit
        - Added option for CFW-users to select program which creates the ISO ("makeps3iso", "genps3iso")
        - No more "thumbs.db" in created ISO
        - Fixed wrong warnings in log-file
        - A missing "PS3_DISC.SFB" will only be added if you set up PS3-System as ODE(for better "stealth")
      
      DOWNLOAD
      MIRROR

      EDIT: Forgot to mention in changelog that i'v also added a few DLLs which where missing in V2.0

      Regards
      Rudi
      Last edited: Dec 17, 2014
    15. STLcardsWS
      STLcardsWS
      Download Link is not working for me (Zippy usually works well for me)
    16. Rudi Rastelli
      Rudi Rastelli
      Zippy works 4 me ... but i've also added a mirror
    17. digisoft
      digisoft
      Little problem

      Hi Rudi

      I`m found bug with option create iso with patch to 3.55 firmware.
      When some files is patched in windows show text "Creating backup zip files" and application hangs.
      Creating iso without patching working ok.
      Check 2.0 version and this is same situation.
      Checked on Windows XP and Windows 7.

      Please check this.

      Best regards
      Tom
    18. Prvt
      Prvt
      I have made some ISO with this tool and with multiman I get this error: multiman: THE SELECTED DISC IMAGE IS NOT COMPLIANT ps3 iso and with webman it says something about an error loading the game...

      I'm using arch noBD CFW and also happens to me with Ferrox NoBD, I have to use this firmware because my PS3 mainboard DBdrirve connection port is fried.

      any help will be appreciated.
    19. Snowfuckingwhite
      Snowfuckingwhite
      I've got the same problem. First it happened while using the program out of the zip file but fixed it by just extracting it and it worked until now. Now I wanted to create an ISO file but it happened again. I've tried every compatiblity mode, running as administrator, nothing worked wich is really strange because it worked fine half an hour ago and I didn't change anything it just freezes right after the "GENERATING ISO" pops up

Share This Page