PS4 Psxitarch Linux version 2.0 -A Linux distro for the PS4 by PSXITA Team

Discussion in 'PS4 Homebrew' started by STLcardsWS, Jan 31, 2019.

By STLcardsWS on Jan 31, 2019 at 9:10 PM
  1. 9,402

    STLcardsWS Administrator

    Sep 18, 2014
    Likes Received:
    Trophy Points:
    The Italian group of developer's known as Team PSXITA (formerly PS3ITA) has released v2 of Psxitarch Linux (A distro for the PS4). In version 1.0 the team crafted a very good release for the PS4, bundled with a number of goodies to enjoy on Linux like RetroArch (linux) and other emulators such as mupen64plus that came equipped with hardware acceleration and various other multimedia applications. Now version 2.0 has been released with alot of new improvements and enhancements for this distro based on "Arch Linux". Various utilities have been replaced with better options and even some new features like mounting and accessing Read and Write privileges to the PS4 internal HDD (PS4 FAT CUH-10xxx and CUH-11xxx models only for this feature currently). Also a Dolphin Emulator has been added :) the full list of changes in v2.0 can be seen in the Google Translation provided below, along with full details & Installation notes of this release.


    • Psxitarch Linux v2: a distro for PS4
      More than 8 months have passed since the launch of Psxitarch Linux, in the meantime many steps forward have been made and it seems that time is finally ripe for the release of a new version ..

      But first .. we would like to thank Marcan with all my heart for bringing linux on PS4 and 2 guys with whom we "worked", collaborated and shared our passion for linux, much of what you will find in psxitarch is also the result of their work. Who I am?

      Eeply : just to mention a few things in his curriculum: D, it is thanks to him if today we have the audio working through hdmi, support for ps4 slim, ps4 pro (including hardware acceleration), a better performing GPU thanks to activation of all CUs and the Clock setting ..​

      Masterzorag : "The Master Of Linux: D", when we had some doubts it was enough to ask him, the first to understand how to make those damned drivers amdgpu .. xD For those who are interested also keeps on his repo the drivers to get the acceleration 3D hardware on Fedora.​

      Without them all this would not have been possible .. Bring some love to these guys!​

      Let's move on to the distro ..

      • Psxitarch now uses the new and better performing Amdgpu open-source drivers for 2D / 3D hardware acceleration, which also makes it possible to use Vulkan (RADV) drivers
      • Kernel 4.14.93.
      • New linux loader that dumps the eap key, the edid, activates all CUs and adjusts the GPU clock.
      • Audio working via HDMI.
      • A fix for WIFI / BT has been added, despite this, the wifi and / or bluetooth on some PS4 may still not work or give problems.
      • Added an option in the System menu that allows you to mount and access to read and write to the internal HD of the PS4. ( For the time being it only works on the PS4 FAT CUH-10xxx and CUH-11xxx ).
      • Added a repository for pacman that will be updated regularly with new versions of the graphics drivers and more ..
      • After installing a new program it should no longer be necessary to manually refresh the menu.
      • Removed the login screen, the login will be done automatically.
      • Psxitarch now caches only the pkg currently installed in the distro.
      • Added Dolphin-emu.
      • Added Lutris
      • Added Mvp.
      • Added Acestream and a simple guide where you can enter the address of the stream you want to view
      • Added Gparted
      • Replaced the Wicd network manager with Network Manager
      • Replaced the ePSXe emulator with PCSXR
      • Replaced Midori with Firefox
      • Replaced Xnoise with VLC
      • It is possible through an option to change the keyboard layout between IT, US, ES, DE, FR
      • Other..

    • Schermata-del-2018-05-04-17-54-04-1000x563.png

      The installation is identical to the previous version, DO NOT use other bzimage, initramfs or linux loader! Take only those linked on this page!

      ATTENTION: the device you will use for the installation will be completely formatted, all the data will be deleted!

      IMPORTANT: for the moment the payload of the linux loader provided here is valid only for those on the 5.05 fw. Weather permitting we will add those for the other fw.​

      • A USB device of at least 12GB (better if 3.0 and better still if ssd)
      • Keyboard.
      • Mouse (if you do not have a mouse you can connect the dualshock 4 and use the touchpad as a mouse but it is not the best comfort).
      • A usb hub.
      • initramfs.cpio.gz: Download! md5: 7c38ca9c4eaff335ef52cef398ab1278
      • bzImage md5: Download! md5: 20fe8941f2238b35822ea61939f2393d
      • psxitarch.tar.xz Download! md5: 8058d928b9a3f9532d55535e166789f7
      1. Format the usb device in FAT32 (NOT EXFAT!), If the installer does not recognize the usb device use this program to format it: Download!
      2. Copy the bzImage, intramfs.cpio.gz and psxitarch.tar.xz files to the root of your usb device.
      3. Connect the usb device to the ps4.
      4. Connect mouse and keyboard
      5. Open the web browser and visit this page to start the payload linux loader (the page can be stored in the cache if you want), for those who want to use the bin can take it from here: Download ! md5: d5e698431b577bb83638a06cdc0eaf33
      6. After a few seconds the ps4 should reboot, wait until the word rescueshell appears
      7. Write exec to start the installation of psxitarch linux
      8. Wait, you should see a long list of files that are copied to 'usb, at the end (after about 25/30 minutes) the distro should start automatically. If it does not start, type exec
      9. Enjoy.
      The distro does not require you to enter your username and password but you will need them in case you would like to get root permissions:
      • username: psxita
      • password: changeit

      The default payload that you find at sets the Vram to 2GB, if you want to set it to 3GB use this payload to start linux: if you want to set it to 1GB:
      You can use the payload you prefer at any time but during the installation of psxitarch you NEVER use the vram3 payload.​

      NOTE: RAM and VRAM are a single block, so more vrams assigned and less RAM. Do your accounts.​


      • The distro should be compatible with all models of ps4 but some monitors and TV with strange resolutions could give problems and do not display anything on the screen, if you have the chance try another tv.
      • The graphics acceleration on ps4 pro is not yet fully exploited.
      • The internal hd is now only detected on the CUH-10xxx and CUH-11xxx models.
      • Vulkan RADV drivers are not yet stable (which will certainly improve with time) in some emulators / games could give problems or have worse performances of the opengl, while in other better ones (see dolphin-emu).
      • The wifi and bluetooth could in some cases crash (disappear), in case you restart the PS4, if it still does not work disable the network and run linux using the cache. NOTE: although the fix on some versions of ps4 the wifi and / or the BT may not work, unfortunately we have not yet found a solution valid for all consoles.
      • In rare cases, the USB devices (mouse, keyboard, ..) may not be detected, in case you restart the console
      • It may happen that after installation some items in the menu are missing, to correct the problem go to "Jwm Config" and select "Refresh Menu".


      We want to thank the people who have and continue to contribute to the development of Linux on PS4 (hoping not to forget anyone)
      Valentinbreiz , shuffle2 , flatz , CelesteBlue , Vultra

      The testers, who have endured for all these days, thanks for the patience guys;)
      Shim , antonwantstosleep , glitch, Astromatik, Anekcahap

      And all the guys on the discord channel Official Playstation 4 Scene

      THANK YOU!!

    Last edited: Feb 24, 2019
    disyoko, Rommy667, jolek and 3 others like this.


Discussion in 'PS4 Homebrew' started by STLcardsWS, Jan 31, 2019.

    1. Donb1985
      I have been trying for months to get this working on my ps4. It is model #:CUH-2115A. Was hoping this would solve my issue as i don't like asking for help but this is getting annoying, and i apologize in advance if this is not where i'm supposed to post issues. As i said i dont usually need to ask for help but this ones got me puzzled. It seems to load it but all i get is a solid white light on ps4 and have to hold power button for like 10 seconds to get it to shut down. It doesn't come back up wanting to scan my drive, boots like nothing ever happened. Have tried on 3 different tvs and have tried 5 different flash drives. Any advice would be appreciated. I have loaded the mira kernel logger for diagnostic purposes but im not seeing the issue.

      Here is the kernel log
      Kernel base = ffffffffccd7c000
      Direct map base = ffff8cad00000000
      pmap_protect patch successful (found at 0xffffffffcd05f0ca)
      pmap_protect(pmap, 0xffffffffcd8d8000, 0xffffffffcd8e0000, 7)
      Testing global variable access (write protection)...
      Kernel interface initialized
      Installing sys_kexec to system call #153
      kexec_init() successful
      PS4 Linux Loader for 4.05
      kernel base is:0xffffffffccd7c000
      uaddr is:0x00000002009e0000
      sys_kexec invoked
      sys_kexec(0x889130020, 6033872, 0x889700020, 4081343, "panic=0 clocksource=tsc console=tty0 console=ttyS0,115200n8 console=uart8250,mmio32,0xd0340000 consoleblank=0 net.ifnames=0 drm.debug=0 amdgpu.dpm=0 drm_kms_helper.edid_firmware=edid/my_edid.bin")
      firmware_extract: Extract lib/firmware/radeon/liverpool_pfp.bin
      Copying PFP firmware
      NOP handler at 0xff0
      firmware_extract: Extract lib/firmware/radeon/liverpool_me.bin
      Copying ME firmware
      firmware_extract: Extract lib/firmware/radeon/liverpool_ce.bin
      Copying CE firmware
      NOP handler at 0x7f0
      firmware_extract: Extract lib/firmware/radeon/liverpool_mec.bin
      Copying MEC firmware
      NOP handler at 0xff0
      firmware_extract: Extract lib/firmware/radeon/liverpool_mec2.bin
      Copying MEC2 firmware
      NOP handler at 0xff0
      firmware_extract: Extract lib/firmware/radeon/liverpool_rlc.bin
      Copying RLC firmware
      firmware_extract: Extract lib/firmware/radeon/liverpool_sdma.bin
      Copying SDMA firmware
      firmware_extract: Extract lib/firmware/radeon/liverpool_sdma1.bin
      Copying SDMA1 firmware
      kexec parameters:
      Kernel image size: 6033872 bytes
      Initramfs size: 4176491 bytes (4081343 from user)
      Kernel command line: panic=0 clocksource=tsc console=tty0 console=ttyS0,115200n8 console=uart8250,mmio32,0xd0340000 consoleblank=0 net.ifnames=0 drm.debug=0 amdgpu.dpm=0 drm_kms_helper.edid_firmware=edid/my_edid.bin
      Kernel image buffer: 0xffff8cad3c800000
      Initramfs buffer: 0xffff8cad21800000
      kernel_hook_install(0xffffffffcd8dbed5, 0xffffffffccdc0020)
      Using 64bit absolute jump
      kexec successfully armed. Please shut down the system.
      [KERNEL] dmem_handle_vmspace_exited pid: 65, ptype=2, 0xffff8cad3c176580->pt_loaded is TRUE
      [KERNEL] dmem_handle_vmspace_exited map #0 0xffff8cad3c1767d8
      [KERNEL] dmem_handle_vmspace_exited map #1 0xffff8cad3c176580
      [KERNEL] dmem_handle_vmspace_exited pid: 65, app_maps_count[2], 2 -> 1
      [KERNEL] dmem_handle_vmspace_exited pid: 64, ptype=2, 0xffff8cad3c1767d8->pt_loaded is TRUE (ajmContextCleanup) - Codec Opus CELT Encoder was not properly unregistered.
      [KERNEL] dmem_handle_vmspace_exited map #0 0xffff8cad3c1767d8 (ajmContextCleanup) - Codec CELP8 Decoder was not properly unregistered. (ajmContextCleanup) - Codec MPEG4 AAC Encoder was not properly unregistered. (ajmContextCleanup) - Codec CELP8 Encoder was not properly unregistered. (ajmContextCleanup) - Codec CELP(16) Decoder was not properly unregistered.
      [KE]sceCameraDevKill::2775 ERROR: sceCameraProcConfigStop 0x802e0006 i=0 handle=257 pid=43 (ajmContextCleanup) - More codecs were not properly unregistered... (ajmContextCleanup) - Instance 16389 was not properly destroyed. (ajmContextCleanup) - Codec MP3 Decoder was not properly unregistered. (ajmContextCleanup) - Instance 114689 was not properly destroyed. (ajmContextCleanup) - Codec ATRAC9 Decoder was not properly unregistered. (ajmContextCleanup) - Codec AC3 Encoder was not properly unregistered. (ajmContextCleanup) - Instance 163842 was not properly destroyed. (ajmContextCleanup) - Codec DTS Encoder was not properly unregistered. (ajmContextCleanup) - Codec Opus CELT Decoder was not properly unregistered.
      [KERNEL] dmem_handle_vmspace_exited pid: 64, app_maps_count[2], 1 -> 0
      <118>[SceSysCore mini] forcibly unmount 1 nullfses
      <118>[SceSysCore mini] forcibly unmount /mnt/usb0
      <118>[SceSysCore mini] sceKernelPollEventFlag(reboot_flag): failed 80020010
      <118>[SceSysCore mini] call reboot(4000)
      [REGMGR] 000006 ...
      [REGMGR] ( 198.082 sec) 010006 ...
      [REGMGR] ( 0.011465 sec) 010007 ...
      [REGMGR] 000108 ...
      Waiting (max 60 seconds) for system process `SceVnlru' to stop...done
      Waiting (max 60 seconds) for system process `SceBufdaemon2' to stop...SD Manual Tuning done. MaxPassWindowSize=23, TunePoint=11 CORE_CTRL=0x58408b
      Waiting (max 60 seconds) for system process `SceBufdaemon1' to stop...done
      Waiting (max 60 seconds) for system process `SceBufdaemon0' to stop...done
      Waiting (max 60 seconds) for system process `SceSyncer' to stop...
      Syncing disks, vnodes remaining...0 0 sched_sync: flush softdep (iter=2)
      sched_sync: flush softdep (iter=1)
      All buffers synced.
      Uptime: 3m24s
      icc post sync:Thermal alert LED off.
      Thanks in advance for any help or suggestions.
    2. grayfox
      with this system can i run all ps3 games or some of them
    3. monker
    4. kozarovv
      Are you using dedicated psxitarch v2 linux loader?
      monker likes this.
    5. monker
      I was using the Epley loader via Project X esp I will try the dedicated loader today. Thanks.
    6. kozarovv
      Probably that was the issue. Ita loader set different clocks, etc.
      monker likes this.
    7. monker
      Thank you working very well now.
      kozarovv likes this.
    8. LuanTeles
      i'm trying to install it, pendrive all set, when i hit linux loader it reboots and black screen forever
    9. kozarovv
      Ps4 model?
    10. LuanTeles
      PS4 Pro.

      Using a Sandisk 32GB usb stick
      A wireless mouse and Keyboard.

      First i thought it is not recognizing the Usb due to have formated in Windows,
      So i downlaoded guiformat.exe and format to fat32.

      Still same thing

      When the loader reboots the console, the usb stick brinks for a few seconds, and ps4 light up the solid blue bar, and blinking white bar and no signal on tv
    11. LuanTeles
      Maybe the cause is this

      • The distro should be compatible with all models of ps4 but some monitors and TV with strange resolutions could give problems and do not display anything on the screen, if you have the chance try another tv.
      I write exec without seeing anything, now the usb is having some activity going on
    12. kozarovv
      STLcardsWS and DeViL303 like this.
    13. kozarovv
    14. Chreech
      How can i use a secondary usb drive in psxitarch linux? I have formatted a usb drive in fat 32 but it is not showing anywhere except in gparted. How can i browse files from secondary usb drive?
    15. LuanTeles
      Last edited: Feb 18, 2019
      DeViL303 and kozarovv like this.
    16. LuanTeles
      The problem is my tv, i got black screen on my main tv, using another it works
    17. uplayacc213
      Hey guis...
      You all remember the SteamOS story..?
      weeeeeeel, i whas just wonering if the os can be modified to run on the 4th gen :grin:
    18. Rommy667
      Having never used Linux before i gota say this is awesome had dreamcast emu up and running in no time @ all,best homebrew on ps4 for sure :)
    19. aceballzdeep
      just hav a some quick questions @kozarovv

      1.ps4 pros 3d hardware acceleration works? but only to the OG ps4s capablities as of now

      2.completely formats device for install - whats the best method to backup saves, settings and trophies etc, the normal backup method in system settings? or file manager/ftp copy saves/trophy files - EDIT FOR ?2 the device used for install gets formatted, the usb stick correct? i reread the installation steps im under the impression that i wont need to backup saves, trophies etc. can someone plz confirm

      3. future version updates - will version updates always hav to b installed this way? (not installable thro arch)
      Last edited: Mar 30, 2019

Share This Page