PS Vita / Ps TV ref00d (plugin) Released - Run Games / Apps that require a higher FW from your own

Discussion in 'THE FEED (Submit/View News)' started by Zwei, Jan 13, 2019.

By Zwei on Jan 13, 2019 at 12:12 PM
  1. 425
    130
    72
    Zwei

    Zwei Member

    Joined:
    Mar 21, 2015
    Messages:
    425
    Likes Received:
    130
    Trophy Points:
    72
    Following the big news from Team Molecule several weeks ago and effectively opening the system wide open, it was only a matter of time before we would start to see other developer's start putting the finding to use and we have seen the FAPS Team (team members listed below) have recently released a new (taiHEN) plugin called ref00d, this plugin is a big deal, as it will allows users/devs to use content that would otherwise require a higher firmware to be played/executed on a lower firmware for your exploited PS Vita or PlayStation TV. Typically not an easy task to reach but thanks to Team Molecule's research and the FAPS Team we now have a ready to use simple plugin solution to remove those firmware restrictions, see additional details about this plugin release in the release notes provided below by the development team.
    -STLcardsWS

    DwSbY4BWoAEiiGz.jpg
    ref00d

    • FAPS Team
      • the French - @CelesteBlue123
      • the American - @dots_tb
      • the 【Princess of Sleeping】 - @PoSsvkey
      • With @juliosueiras and TheRadziu - @AluProductions

      What it does:

      • It allows you to run modules such as games or system apps that require a FW different from your own. This includes thing such as 3.69 games or 3.51 apps.

      How to use:

      1. Add ref00d.skprx path to your taihen config.txt or use Autoplugin to install it.
        Note for devs: The release version does not work with plugin loader and must be used in taihen config.txt
      2. Make sure that reF00D is installed AFTER NoNpDRM in this config.txt.
      3. Put keys.bin file into ur0:/tai/keys.bin. (https://www.mediafire.com/download/t5obgaa3naatr9m)
      4. Reboot. Enjoy !

      NOTE
      : rePatch module loading will take priority over reF00D.​


    • Special thanks:

      • Team Molecule for feeding the p00r.
      • To Silica for his mental illness (actually caring about PSM) which made us realize the headers weren't always in order.
      • To motoharu, aerosoul, TheFloW, xerpi, St4rk, Mathieulh, zecoxao for having reversed a part of the PSVita and made useful tools.
      • To sys for being sys

      Testing team:

      • amadeus
      • Samilop Iter
      • Thibobo
      • Yoti
      • Waterflame
      • Z3R0

    Download & Source Code: github.com/dots-tb/reF00D/releases
     
    Last edited by a moderator: Jan 13, 2019
    jolek, T.A.U, Naked_Snake1995 and 2 others like this.

Comments

Discussion in 'THE FEED (Submit/View News)' started by Zwei, Jan 13, 2019.

    1. BasilouR
      BasilouR
      The French are in strength x)
      (My country oWo)
    2. Fuzion9
      Fuzion9
      Nice work. Many thanks
    3. Marvin Freeman
    4. Naked_Snake1995
      Naked_Snake1995
      Nice work, props to the developers, and just in time for Catherine - Full Body! Cant wait till it arrives, securing both copies!
      569.png
    5. TONY-T
      TONY-T
      Great plugin, Thanks!
    6. Naked_Snake1995
      Naked_Snake1995
      $ony just dropped the 2019 Mix Tape, the 3.70 Software Update for the PSVITA, as 3.69 wasn't enough pain! [emoji848]

      Your thoughts lads? I know THE FLOW its gonna be pissed, as it only slows down his 3.69 Exploit Chain.

      $ony just won't let it die!

      Sent from my G8341 using Tapatalk
      bitsbubba likes this.
    7. bitsbubba
      bitsbubba
      for the handheld that they pretty much abandoned it seems like an overkill
    8. Naked_Snake1995
      Naked_Snake1995
      I am sure Sony did it for two main reasons, to halt THE FLOWs 3.69 Exploit Chain, and perhaps because of February 14th Release of Catherine - Full Body in Japan, two main reasons that comes to my mind.

      Remember the Vita in the West, like you correctly mention it, its pretty much dead, but in Japan still gets games and has a decent stable audience.

      Sent from my G8341 using Tapatalk
      bitsbubba likes this.
    9. xXTribusXtremeXx
      xXTribusXtremeXx
      umm... i just updated to 3.70, i hope i havent screwed up
    10. Naked_Snake1995
      Naked_Snake1995
      Ok, so THE FLOW recently stated that his new Exploit chain will be compatible with 3.70, and work its progressing with no halts ;)

      For the lads whom updated to 3.70, this its some great news, ETA its still set in 2019, release date remains unknown, stay tuned for updates!
    11. Berion
      Berion
      I'm not sure if I understand. This plugin allow me to run i.e 3.65 games on fw i.e 3.60 without decrypting and resigning them?
    12. Naked_Snake1995
      Naked_Snake1995
      This plugin allows to run titles with firmwares above 3.69+ (firmwares that are above H-Encore reach), meaning you dont need to apply patches to the specific firmware.

      Remember back in 3.55 PS3 days when you had to resign the EBOOT.PBP to get a higher firmware title to work on a 3.55 Console, this its almost the same thing, but unlike resigning, this plugin bypasses the Firmware Restriction on a lower-firmware.

      Ive tested Catherine-Full Body (Demo), since the game only comes at Feb 14th, the demo requires 3.69 as the base firmware, running on a PCH-1004 with 3.65 Enso, with reFOOD plugin, no halts or corruptions, gets the job done.
    13. TONY-T
      TONY-T
      I cant seem to get it to work. Ive tested a game that requires 3.61. (Some Zombie game) and it keeps saying I need to update in order for it to work.
    14. TONY-T
      TONY-T
      [​IMG]
      Can someone tell me if this is correct??
    15. Berion
      Berion
      @Naked_Snake1995 In readme, there is no any limitation mentioned so I ask about my specific case which at least in theory should works with i.e 3.60 and game needed 3.69 just like i.e fw 3.65 with game which needs 3.69. Anyway, it just simple question as I don't have anything which demand 3.61 or newer so I cannot check this myself.

      @TONY-T Depend on what You have in "config.txt". Judging by screenshot above, place is ok, files are ok.
    16. TONY-T
      TONY-T
      What do i need in config.txt??
    17. Berion
      Berion
      Have You read readme file? You need add this plugin to the list under KERNEL section.

      This is example of my configuration:
      Code:
      # For kernel plugins, you must reboot for changes to take place.
      # henkaku.skprx is hard-coded to load and is not listed under KERNEL
      # main is a special titleid for SceShell
      # NPXS10015 & NPXS10016 is for modifying the version string in settings widget
      
      *KERNEL
      # ur0:tai/unmount.skprx
      ur0:tai/storagemgr.skprx
      ux0:app/PSPEMUCFW/sce_module/adrenaline_kernel.skprx
      # ur0:tai/reF00D.skprx
      # ur0:tai/nonpdrm.skprx
      # ur0:tai/nopsmdrm.skprx
      # ur0:tai/dsmotion.skprx
      # ur0:tai/psvgamesd.skprx
      
      *main
      ur0:tai/henkaku.suprx
      ur0:tai/pngshot.suprx
      
      *NPXS10015
      ur0:tai/henkaku.suprx
      
      *NPXS10016
      ur0:tai/henkaku.suprx
      
      # "Uncharted: Golden Abbyss" PCSA-00029
      # "Uncharted: Golden Abbyss" PCSA-22103
      # "Uncharted: Golden Abbyss" PCSF-00001
      *PCSF00001
      ur0:tai/dsmotion.suprx
      ur0:tai/fakecamera.suprx
      
      # "Rayman Legends" PCSB-00360
      # "Rayman Legends" PCSB-00726
      *PCSB00726
      ur0:tai/dsmotion.suprx
      
      # "Little Big Planet" PCSA-00017
      # "Little Big Planet" PCSA-22018
      # "Little Big Planet" PCSF-00021
      *PCSF00021
      ur0:tai/dsmotion.suprx
      
      Lines with hash are ignored so in example above, reF00D is ignoring and will not work.

      Keep line breaks in unix style. It will be the best if You edit it by build-in VitaShell text editor.

Share This Page