PlayStation News RetroArch 1.3.6+ beta release for PlayStation3 and PS Vita HENkaku!

Discussion in 'General PlayStation News' started by kozarovv, Aug 3, 2016.

By kozarovv on Aug 3, 2016 at 10:03 AM
  1. 7,538
    5,605
    872
    kozarovv

    kozarovv Super Moderator

    Joined:
    Nov 8, 2014
    Messages:
    7,538
    Likes Received:
    5,605
    Trophy Points:
    872
    Home Page:
    RetroArch developers announced that beta release for PS3 and PS Vita/PSTV is here:
    Today we are releasing a beta version of RetroArch 1.3.6+ (latest snapshot, release candidate for 1.3.7) for the Playstation3 and PS Vita. Be sure to thank frangarcj for the latter since he went through the trouble of making sure we could make the jump from Rejuvenate to HENKaku in swift order.

    unnamed.png

    • PlayStation Vita/PS TV

      How to install:


      1. Extract the contents of this 7zip archive to a folder somewhere on your PC. This will extract a bunch of vpk files to your harddrive.
      2. On the PS Vita/PS TV, make sure the HENkaku exploit has already been installed. Go to the bubble ‘molecularShell’ and start it. Once inside the filebrowser, press ‘Select’ to start the FTP server. Write down the FTP server address you see here.
      3. Go back to your desktop PC, start up an FTP client, and input the IP address and port that was displayed on your PS Vita/PS TV. Transfer the vpk files to some place on either ur0: (internal storage) or ux0: (this being your Memory Card).
      4. On the PS Vita/PS TV, press circle to go back. Then once back inside the filebrowser, go to the directory where you extracted the vpk files. Install the cores you want.
      5. Exit the ‘molecularShell’ program. You should now be back inside the home screen. From here,
      RetroArch bubbles should start appearing in the menu. You can now use RetroArch.​

      How to install ROMs:

      1. The same way you installed RetroArch. Start ‘molecularShell’, go through the previous section’s steps 2 and 3 again, but this time transfer roms over instead. Then load them from RetroArch.
      IMG_0198.jpg NXEngine/Cave Story running on RetroArch Vita.​

      State of the port:


      What works:
      * (Core-related) CatSFC / SNES. Works fine. Should run at fullspeed for most games (dip to 42fps on Yoshi’s Island intro screen (SuperFX2 game), seems to be fullspeed otherwise).
      * (Core-related) FB Alpha CPS1. Works fine. Fullspeed. Runs all games. Use an older FBA romset.
      * (Core-related) FB Alpha CPS2. Works fine. Fullspeed. Runs all the big CPS2 ROMs. Use an older FBA romset.
      * (Core-related) FB Alpha Neo Geo. Works fine. Fullspeed. Not all big ROMs will work right now though. KOF 96 could be loaded (about 23/24MB). Might have to play around with heap to be able to get bigger ROMs to load. For now expect same size limitations as the Wii port. Hopefully we can get past this soon.
      * (Core-related) FCEUmm. Works fine. Fullspeed.
      * (Core-related) Genesis Plus GX. Works fine. Fullspeed.
      * (Core-related) Mednafen Neo Geo Pocket Color. Works fine. Framerate at around 52/53fps. There might be a new Neo Geo Pocket Color core coming soon (not Mednafen NGP) which would run at fullspeed with no problems.
      * (Core-related) Handy / Lynx. Works fine. Fullspeed.
      * (Core-related) Mednafen Wonderswan. Works fine. Fullspeed.
      * (Core-related) Mednafen Virtual Boy. Works. Too slow (around 26fps). Corrupted pitch (likely due to 32bit color). Speedups/idle loop optimization hacks MIGHT bring this fullspeed later on.
      * (Core-related) NXEngine / Cave Story. Works fine. Fullspeed.​

      What doesn’t work:

      * ROMS have to be currently unzipped now (EXCEPT for the FB Alpha ROMs).
      * No core switching yet from inside RetroArch. For now, each core is a standalone program.
      * Add Content -> Download Content currently doesn’t work. If you do try it, you might have to restart.
      * History list doesn’t work yet.
      * Save states can be saved, but cannot be loaded yet. We need to figure out why.
      * Threading needs to be still implemented.
      * (Core-related) 2048 core. ‘Start content’ does not work yet like it should. Wait until we fix this.
      * (core-related) Prboom/Doom core. Crashes after loading a Doom WAD. Wait until we fix this.
      * (Core-related) Picodrive core. Crashes after loading a ROM. Wait until we fix this.
      * (Core-related) QuickNES core. Doesn’t load a ROM. Wait until we fix this.
      * (Core-related) Gambatte core. Doesn’t load a ROM. Wait until we fix this.
      * (Core-related) SNES9x Next core. Doesn’t load a ROM. Wait until we fix this. Will likely be too slow compared to CatSFC anyway, so not sure if worth it for Vita.
      * (Core-related) DOSBox core. Haven’t tried this yet. Likely too slow to be worthwhile
      .​

      Future plans:

      * More cores, fix remaining cores that are broken.
      * Try to get Cg runtime working so we can have Cg shaders running.
      * Try to get multiple gamepads working on PS TV.
      * More.

    • PlayStation3


      Thanks to PSGL, the PlayStation3 driver can use the XMB menu driver using the OpenGL rendering backend. The simplified ribbon should be running properly in the background too.

      The PlayStation 3 port is back after it was decommissioned for a long time.
      @Ezio should be uploading the CEX/DEX versions shortly, after which they will be posted on xbins as well.​

      What doesn’t work yet:

      This version can be considered a beta release. Here are the current issues:
      • You cannot scan for content as of right now. Instead, for now you should just load content directly from the filesystem.
      • To be able to use zipped ROMs on emulators like SNES9x and other similar emulators, always use ‘Open Archive As Folder’, then select the ROM you want to use. Don’t use ‘Load Archive With Core’ which won’t work for now.
      • If you go to ‘Information’ -> ‘Core Information’, it currently doesn’t show anything. Not a big deal for now but something we will want to fix later on regardless.
      • None of the ‘downloading’ features right now will work in the PS3 port. Our networking stack code for PS3 apparently requires some customizations still. If there are any PS3 devs who can help with this, by all means.
      maxresdefault.jpg
      The PS3 version now uses the XMB menu driver, a big step-up from the previous versions’ RGUI menu driver. The font driver we are currently using for PS3 is the default bitmap font, so it doesn’t look as good as it could be, but we are going to be moving over to more fancy font rendering shortly, possibly using stb_font or something similar.

    • A sneak peek at 1.3.7 features
      Since this is a current nightly snapshot release, PS3 and Vita users are able to get a sneak peek at some of the features that will be part of RetroArch 1.3.7 for the other platforms.
      • Improved error handling. When loading the wrong ROM into a core, most cores should be able to now gracefully exit instead of just quitting or crashing RetroArch.
      • Much more complete info message system. Press ‘Select’ on any entry and 99% of the time it should show you a handy help message explaining to you what each setting does. The ‘English’ language setting is currently the one that is most complete, for all other languages we need to wait until translators have finished adding all the help messages in their own language.


    Download Vita/PSTV: Official link
    Download PS3: Cex / Dex / ODE
    Source: Libretro
     
    Last edited: Aug 8, 2016
    glecon, sanusi, doctorwho05 and 7 others like this.

Comments

Discussion in 'General PlayStation News' started by kozarovv, Aug 3, 2016.

    1. Checcolino80
      Checcolino80
      retroarch is just a frontend, you can choose to use multiMAN with simplicity to load the roms using cores that can be found within retroArch, just change the options_default.ini file located in BLES80608
      Ezio likes this.
    2. STLcardsWS
      STLcardsWS
      Alot of the issues are core related and the front-end (unless changed in recent version) are packed with the core itself.

      Example: if you had RetroArch v1.0.0.2 installed and added some v0.9.8 cores as well When you would load those v0.9.8 cores you would have the front-end for v0.9.8. Now this could of changed in the recent versions as i have not mixed cores like that yet.

      So even if using multiMAN, your basically just using a front end over a front end essentailly because when you go into the options of the game (quick menu and beyond) your then using RetroArch. MultiMAN is just a launcher just from multiMAN in the same sense as RetroXMB from the XMB.

      Been such a long time for me booting roms in multiMAN, but last i messed with it, not all cores could be supported,
      bitsbubba likes this.
    3. JediKnight007
      JediKnight007
      Hate to bring this up, but could somebody upload this to a mobile-friendly mirror? Or at least recommend an Android browser capable of downloading from Mega? I've never been able to download anything from there, and I can confirm the following browsers DON'T work...

      Stock Android
      UC Browser
      UC Browser Mini
      Dolphin Browser HD
      Dolphin Browser Mini
      Firefox (even though the site "recommends" it!)
    4. kozarovv
      kozarovv
      In chrome or boat browser change mode/user agent to desktop pc. This should let you download.
      JediKnight007 likes this.
    5. Ezio
      Ezio
      bitsbubba and JediKnight007 like this.
    6. JediKnight007
      JediKnight007
      @kozarovv...

      Boat Browser wouldn't download it for me, and my phone is so old Chrome won't run on it. But thanks, anyway.

      @EnzioPS...
      Much obliged for the mirror, although both links you posted were for the same thing. Perhaps for the future, you could use the Sendspace site instead, or along with Mega - I know there is at least one other user here that also has problems with Mega. I rather not bug you every time typo release a RetroArch compile. But if it's too much of a hassle, I understand.

      By the way, how's the port of RetroArch to psl1ight coming along?
    7. JediKnight007
      JediKnight007
      @Enzio...

      Your compile didn't work for me - I got an error message (8001003C, I think). So I switched that EBOOT with the one from a earlier beta release, and then the PS3 crashed back to the XMB with no message. Then I switched to a core from the old installation, and RetroArch loaded fine. From experience, this means the EBOOT and the SELFs are signed wrong (for me). This isn't really an issue - I know how to resign EBOOT and SELF files. The problem is I don't have a PC, so I'll have to try to use the one at work, even though it's not in my department.

      Anyway, thank you for your contributions to the scene.
    8. atreyu187
      atreyu187
      The Vita and PSTV builds have seen some major improvements I suggest getting the latest builds if you haven't updated in a while. Over 18 cores ATM
      STLcardsWS, bitsbubba and DeViL303 like this.
    9. STLcardsWS
      STLcardsWS
      Are they all working cores? in previous builds all the included cores have not worked well. but i do see they have the XMB gui implemented.
    10. atreyu187
      atreyu187
      Haven't had time to test them all but the ones I did ran perfect.
      STLcardsWS and bitsbubba like this.
    11. Ezio
      Ezio
      @JediKnight007 Tag me properly otherwise i cannot notice it :P
      Sorry about the wrong link for snes9xnext fix, it's here https://www.sendspace.com/file/a0uofy
      Error message could come from broken tools i had just some days before than ps3 release and from cfw you're using
      Which cfw are you using? There's a fix for cfw dex ita around. I was trying to fix also the error with cfw 3.55 but the guy was testing it got ylod on his phat ps3. :(
      It's surely some flag missing on resigning stuff and i have idea what it could be but i didn't fix it on main repo of retroarch since i cannot anymore get feedback for cfw 3.55. :/
      Anyway i fixed all the ps3 compiles some weeks ago so it's enough easy to get a recent version for everyone. There i'm using a different way to resign and pack the cex build, so it could already work for you and for others. Tbh i was waiting that the guy which manages the buildbot for libretro put up the nightlies for ps3, but it's requiring more time than what it was planned.
      I guess it would be worth a new ps3 release to test the stuff fixed on the main repo... (also the savestate for snes9xnext is fixed on the main repo since some weeks).

      About psl1ght port, the binaries for cores and and eboot could be compilable with psl1ght, but the rsgsx library isn't mature enough to support retroarch, we could use the official psgl and see if it works with psl1ght. I'll try to implement it in next months, just to not lose all good stuff done by @Zar but i'm a bit busy to do it just now.
      Last edited: Aug 26, 2016
    12. kozarovv
      kozarovv
      18? I think is 35 cores already, but not all of them working probably for now.

      Can you tell me what firmware you are using?
    13. kadorna2
      kadorna2
      finally an update that isn't completely b0rked. i tried nes, snes and final burn alpha cores, these work okay. turbo button support for nes works well, that's all i need.

      one thing i can't quite comprehend is WHY the team doesn't label the buttons under button config properly for each system retroarch is ported to, ABXY is nice but it's confusing as hell.

      input config based on a per core basis is broken, too
      bitsbubba and kozarovv like this.
    14. JediKnight007
      JediKnight007
      3.41 OFW + TI-84+ (yeah, I know, it's a long story I've told before).

      If I had a PC I wouldn't have even said anything, I know how to use scetool/hex editor/make_self_wc.

      @Enzio

      Sorry about that tag, I used your name from the RetroArch boards.
      kozarovv likes this.
    15. kozarovv
      kozarovv
      ... I really don't know what to answer here :D You are one of that Jedi Knights that traveling thru time tunnel with Stephen Hawking playing on Retroarch Reicast core using TI-84+ in Ecco II: Sentinels of the Universe final version game. And using コナミコマンド to enable savestates.

      Marty McFly told me that is hard to debug that kind of hardware + software, anyway we will try when DeLorean finish horse race on first place. Btw. Emmett Brown say this can be too low speed on eboot decrypting.

      Seriously this make debuging little bit harder but I will try look into this. But my knowledge about 3.41 is poor.
      Oh and i almost forgot, soooorrry :banana: You asked for that by siting on that calculator. :)
      JediKnight007, DeViL303 and bitsbubba like this.
    16. bitsbubba
      bitsbubba
      3.41? Wow pretty guaranteed not to have any support there mostly everything is signed for 4.21+ nowadays. Not even 3.41 CFW @JediKnight007 is sporting a dongle. Wow just wow, maybe I should downgrade to 3.41 also as my iPod Video still has several payloads on it [emoji3]
      DeViL303 likes this.
    17. kozarovv
      kozarovv
      JediKnight007 and bitsbubba like this.
    18. bitsbubba
      bitsbubba
    19. kozarovv
      kozarovv
      Hope this will allow him to return to retro times.
      bitsbubba likes this.
    20. Ezio
      Ezio
      bitsbubba likes this.

Share This Page