Dismiss Notice

BEWARE of IMPOSTERS, posing as the PS3Xploit Members/Team:

  -PS3Xploit does NOT have a discord channel, some imposter are using one

  -If the info can't be found on ps3xploit.com or psx-place.com its fake

  -ZuKuTo / OFWModz is one of the fake names of these imposter's are using to represent the PS3xploit team.



PS3 Semi Brick 2002A Slim 3 beeps and flashing red

Discussion in 'PS3Xploit CFW Installer ( PS3 25XX Models & Lower)' started by vk2amv, Nov 9, 2018.

  1. 4

    vk2amv Forum Noob

    Nov 9, 2018
    Likes Received:
    Trophy Points:
    Hi all,

    I am after advice please.
    I apologise in advance for the long post, but I want to provide as much detail as I can up front.

    Firstly I have a PS3 Slim model 2002A, minimum firmware ver 2.70.
    I purchased it second hand last week so I am unfamiliar with its history.
    It came running firmware 4.81.

    I followed the steps here to exploit it

    Now I have run into a problem.
    It is semi bricked.
    Meaning on power up sometimes it boots and runs fine, and sometimes it just beeps 3 times and then flashes red and turns off, and sometimes (Rarely) it stays powered up with green LED however no picture. (I read that a yellow in between the beeps and going to flashing red is bad, however I am not seeing any yellow at any point)

    Now I only played around with it a minimal amount before I decided to Jailbreak it (Powered on and done both cold and warm reboots a dozen times or so total in testing and OFW firmware update to 4.82)
    However I didn't have any power on issues BEFORE the exploit was done.

    But now it only successfully powers on once every 20 times or so.
    One thing that does seem to work, and is very weird, following advice from a YouTube video if I pull the power plug after a failed boot, and then hold the power button for 30 seconds or more, it seems to boot reliably on the next attempt.
    Done this a few times now, something I never expected would make a difference seems to let it boot.

    Now I will run through my steps on exactly what I did.

    Started with it running 4.81 OFW when I received it.
    Factory reset PS3 settings and format internal storage.
    Firmware update to 4.82 OFW.
    Run firmware update to 4.82 OFW a SECOND TIME as per the instructions.
    Proceed with the exploit to HDD as per the instructions, eg save file to HDD, run exploit, patch flash.
    Save flash dump to HDD, then copy to USB drive.
    Check flash dump using PyPS3checker as per the instructions.
    Flash dump check comes back all OK with NO errors or warnings.

    This is where I rebooted the PS3 as the instructions, and I had my first failed boot with the 3 beeps and red flashing.

    I just pulled the power cord and tried again and it booted fine and I didn't think more at the time.

    Downloaded REBUG REX 4.82.2.
    Check MD5 of REBUG download with MD5Summer.
    I installed REBUG REX 4.82.2 by putting it on USB drive and running firmware update.
    Reboot back into REBUG successfully and install REBUG tools to make sure everything is working.
    Install MultiMAN.

    And that is as far as I have gotten.
    I powered off the PS3 at that point to move some cables around and then I encountered the boot problems on power up.
    Most times when I press the power button about 2 seconds later I get 3 beeps and then flashing red.
    And every now and then it will boot on its own, and once it has booted it appears to run fine.

    I am looking at the XMB as I type this message so I have disabled power save and am now posting this thread for help.

    I cannot rule out the PS3 having an existing hardware problem when I bought it.
    However I did power it up a dozen or so times BEFORE I tried any exploit and everything seemed to work fine with no power up problems.

    The problems only seemed to start immediately after I ran the exploit.
    However PyPS3checker reckons my dump was fine.

    I am attaching my dump check log file for verification that shows OK across the board.

    However even though the dump check says it is ok, I am wondering is there is still something weird there.

    I am thinking I would like to try returning it to 4.82 OFW and see if that helps the power on problems just in case something went weird with the NOR patch.

    Can I just take the 4.82 OFW update, and run it using software update from inside REBUG to return everything back to stock OFW and start from scratch again?

    I have it semi bricked now, but I can at least get it to boot sometimes so I don't think I have backed myself into a corner yet.

    As I said above it could turn out there is not a software problem at all and it is just an annoying coincidence that the boot problems are actually hardware related and a piece of hardware decided to go weird at the same time as when I ran the exploit.
    But I am leaning at this stage that something is weird with the NOR patch as it seemed perfectly fine before I ran the exploit.

    Either way I don't want to make any moves that will make the situation worse and turn a semi brick into a permanent brick so I want to be very sure of any courses of action to take before I take any such course of action.

    For now I have the PS3 powered on and sitting in REBUG on the XMB screen, and I plan not to power it off or do anything at all to it until I hear back some advice in this thread.

    Any advice on how best to proceed would be muchly appreciated thank you.

    PyPS3checker v0.9.x. Check log.
    Checked file : E:\PyPS3checker\dump.hex
    ******* Getting flash type *******
      Flash type : NOR
      Reversed : NO
    ******* Getting SKU identification datas *******
      idps = 0x09
      metldr0 = 0xE890
      metldr1 = 0x0E85
      bootldr0 = 0x2F13
      bootldr1 = 0x2F13
      bootldrsize = 0x2F170
      Matching SKU : OK
       CECH-20xx (DYN-001)
       Minimum version 2.70
    ******* Getting SDK versions *******
      ROS0 : 482.000
      ROS1 : 482.000
    ******* Checking first_region_header *******
    001.01   First Region Header 0x00 Filled Area 0 : OK
    001.02   First Region Header Magic : OK
    001.03   First Region Header 0x00 Filled Area 1 : OK
    ******* Checking flash_format *******
    002.01   Flash Format String : OK
    002.02   Flash Format Version : OK
    002.03   Flash Format 0xFF Filled Area : OK
    ******* Checking flash_region_table *******
    003.01   Flash Region Table Header : OK
    003.02   asecure_loader Offset - Length : OK
    003.03   asecure_loader Name : OK
    003.04   eEID Offset - Length : OK
    003.05   eEID Name : OK
    003.06   cISD Offset - Length : OK
    003.07   cISD Name : OK
    003.08   cCSD Offset - Length : OK
    003.09   cCSD Name : OK
    003.10   trvk_prg0 Offset - Length : OK
    003.11   trvk_prg0 Name : OK
    003.12   trvk_prg1 Offset - Length : OK
    003.13   trvk_prg1 Name : OK
    003.14   trvk_pkg0 Offset - Length : OK
    003.15   trvk_pkg0 Name : OK
    003.16   trvk_pkg1 Offset - Length : OK
    003.17   trvk_pkg1 Name : OK
    003.18   ros0 Offset - Length : OK
    003.19   ros0 Name : OK
    003.20   ros1 Offset - Length : OK
    003.21   ros1 Name : OK
    003.22   cvtrm Offset - Length : OK
    003.23   cvtrm Name : OK
    003.24   Flash Region Table 0x00 Filled Area : OK
    ******* Checking asure_loader_region *******
    004.01   asecure_loader Header : OK
    004.02   metldr Offset : OK
    004.03   metldr Length : OK
    004.04   metldr Name : OK
    004.05   metldr RevKey : OK
    004.06   metldr Binary Size : OK
    004.07   metldr Statistics : OK
    004.08   asecure_loader 0x00 Filled Area : OK
    ******* Checking eEID_region *******
    005.01   eEID Header : OK
    005.02   EID0 Offset - Length : OK
    005.03   EID1 Offset - Length : OK
    005.04   EID2 Offset - Length : OK
    005.05   EID3 Offset - Length : OK
    005.06   EID4 Offset - Length : OK
    005.07   EID5 Offset - Length : OK
    005.08   EID0 IDPS0 : OK
    005.09   EID0 IDPS1 : OK
    005.10   EID0 Static : OK
    005.11   EID2 BlockSize/Padding : OK
    005.12   EID3 Static0 : OK
    005.13   EID3 Static1 : OK
    005.14   EID3 Static2 : OK
    005.15   EID5 IDPS0 : OK
    005.16   EID5 IDPS1 : OK
    005.17   EID5 Static : OK
    005.18   eEID Region 0xFF Filled Area : OK
    005.19   eEID Statistics0 : OK
    005.20   eEID Statistics1 : OK
    ******* Checking cISD_region *******
    006.01   cISD Header : OK
    006.02   cISD0 Offset - Length : OK
    006.03   cISD1 Offset - Length : OK
    006.04   cISD2 Offset - Length : OK
    006.05   cISD0 0xFF Filled Area : OK
    006.06   cISD1 IDLog Header : OK
    006.07   cISD1 Semistatic 1 : OK
    006.08   cISD1 Semistatic 2 : OK
    006.09   cISD1 0xFF Filled Area 0 : OK
    006.10   cISD1 Static : OK
    006.11   cISD1 Semistatic 3 : OK
    006.12   cISD1 0xFF Filled Area 1 : OK
    006.13   cISD1 Statistics : OK
    006.14   cISD2 : OK
    006.15   cISD 0xFF Filled Area : OK
    ******* Checking cCSD_region *******
    007.01   cCSD Header : OK
    007.02   cCSD Entry Table : OK
    007.03   cCSD 0xFF Filled Area : OK
    ******* Checking Revokation_region *******
    008.01   trvk_prg0 SCE : OK
    008.02   trvk_prg0 Hash : OK
      Size = 0x2E0
      MD5 = E537DE954DCF25D4DE961DF44549BAF7
      Version = 3.50 (from PUP)
    008.02   trvk_prg0 0xFF filled area : OK
    008.03   trvk_prg1 SCE : OK
    008.04   trvk_prg1 Hash : OK
      Size = 0x2E0
      MD5 = E537DE954DCF25D4DE961DF44549BAF7
      Version = 3.50 (from PUP)
    008.04   trvk_prg1 0xFF filled area : OK
    008.05   trvk_pkg0 SCE : OK
    008.06   trvk_pkg0 0xFF filled area : OK
    008.07   trvk_pkg1 SCE : OK
    008.08   trvk_pkg1 0xFF filled area : OK
    ******* Checking CoreOS_region *******
    009.01   ROS0 Header : OK
    009.02   ROS0 Hash : OK
      Size = 0x6FFFE0
      MD5 = 4674CA6C38D45171F45C48191528E36F
      Version = 4.82 CEX Patched (PS3Xploit v2.0)
    009.03   ROS0 unused 0xFF Filled Area : OK
    009.04   ROS1 Header : OK
    009.05   ROS1 Hash : OK
      Size = 0x6FFFE0
      MD5 = 4674CA6C38D45171F45C48191528E36F
      Version = 4.82 CEX Patched (PS3Xploit v2.0)
    009.06   ROS1 unused 0xFF Filled Area : OK
    ******* Checking cvtrm_region *******
    010.01   Pre cvtrm 0xFF Filled Area : OK
    010.02   cvtrm0 Header : OK
    010.03   cvtrm0 0xFF Filled Area : OK
    010.04   vtrm0 Magic : OK
    010.05   vtrm0 Reserved Entries : OK
    010.07   cvtrm1 Header : OK
    010.08   cvtrm1 0xFF Filled Area : OK
    010.09   vtrm1 Magic : OK
    010.10   vtrm1 Reserved Entries : OK
    ******* Checking Second_Region_Header *******
    011.01   Second Region Header 0x00 Filled Area 0 : OK
    011.02   Second Region Header Magic : OK
    011.03   Second Region Header Count : OK
    011.04   Second Region Header 0x00 Filled Area 1 : OK
    011.05   Second Region Unknown Block 0 : OK
    011.06   Second Region Header 0x00 Filled Area 2 : OK
    011.07   Second Region Unknown Block 1 : OK
    011.08   Second Region Header 0x00 Filled Area 3 : OK
    ******* Checking Unreferenced_Area *******
    012.01   unreferenced area 0xFF Filled : OK
    ******* Checking CELL_EXTNOR_AREA_Region *******
    013.01   CELL_EXTNOR_AREA Header : OK
    013.02   CELL_EXTNOR_AREA 0x00 Filled Area 0 : OK
    013.03   CELL_EXTNOR_AREA 0x00 Filled Area 1 : OK
    013.04   CELL_EXTNOR_AREA 0x00 Filled Area 2 : OK
    013.05   CELL_EXTNOR_AREA 0x00 Filled Area 3 : OK
    013.06   CELL_EXTNOR_AREA 0xFF Filled Area 0 : OK
    013.07   CELL_EXTNOR_AREA 0x00 Filled Area 5 : OK
    013.08   CELL_EXTNOR_AREA 0x00 Filled Area 6 : OK
    013.09   CELL_EXTNOR_AREA 0xFF Filled Area 1 : OK
    ******* Checking bootldr_region *******
    014.01   bootldr0 : OK
    014.02   bootldr1 : OK
    014.03   bootldr Rev key : OK
    014.04   bootldr Statistics : OK
    014.05   bootldr 0xFF Filled Area : OK
    ******* Checking datamatches *******
    bootldr size : OK
    per console nonce : OK
    metldr size : OK
    vtrm0 : OK
    vtrm1 : OK
    ******* Checking repetitions *******
    Header Magic0 Repetitions : OK
    Header Magic1 Repetitions : OK
    asecure_loader Repetitions : OK
    eEID Repetitions : OK
    cISD Repetitions : OK
    cCSD Repetitions : OK
    trvk_prg0 Repetitions : OK
    trvk_prg1 Repetitions : OK
    trvk_pkg0 Repetitions : OK
    trvk_pkg1 Repetitions : OK
    ros0 Repetitions : OK
    ros1 Repetitions : OK
    cvtrm Repetitions : OK
    ******* Additional information *******
    MAC address : redacted
    CID : redacted
    eCID : redacted
    board_id (part of console S/N) : redacted
    kiban_id (board barcode) : redacted
    ******* Checks completed *******
    Total number of checks = 156
    Number of dangers = 0
    Number of warnings = 0
    All checks done in 5.28 seconds.
    Checks of late CECH-25xxx, CECH-3xxxx and CECH-4xxxx consoles dumps still under development! It could return both false positive and false negative results. Please, send me your checklog.txt via my github repository (https://github.com/littlebalup/PyPS3tools/issues) or by mail at [email protected] It will help me a lot to improve checks ;)
  2. 4

    vk2amv Forum Noob

    Nov 9, 2018
    Likes Received:
    Trophy Points:
    Well to add more information to this one.

    I took the gamble and flashed the PS3 back to 4.82 OFW. (Ran it twice)

    That solved the booting issue.
    With OFW it boots 100% reliably.
    I will try to re-jailbreak later.

    But I realised a different problem.
    For some reason the HDMI output is missing the colour Blue.

    Only Red and Yellow colours are displaying.
    Took me a while to realises to now as I was only looking at text and thought it was the theme.
    I tried different HDMI cable, also different TV, and just to compare got another PS3 Slim (3000 Series) and put it in place and it works fine showing proper colours.

    Also as far as I can tell the onboard Ethernet port is dead.
    Wi-Fi works fine though.

    I am starting to think this PS3 is a bit of a sick puppy.

    Any ideas?
  3. 4

    vk2amv Forum Noob

    Nov 9, 2018
    Likes Received:
    Trophy Points:
    Replying to my own thread again but I wanted to provide some closure on this one for anyone looking in the future.

    I did some playing around in OFW for a few hours and the PS3 behaved itself, powering on every time.
    I also did some gaming in Infamous to kill some time haha.

    Anyway I tested the Ethernet port again that was previously NOT working when I had REBUG running and it is working fine with OFW so no hardware fault there.

    However I am completely convinced the HDMI port has a hardware fault, still no blue colour from the HDMI signal no matter what I tried.
    I grabbed an old PS2 Composite cable and I have full colours, so I am pretty much certain the HDMI output has a fault.

    I have ordered a Component cable from Fleabay and I will use that to get around the HDMI colour problem as Component is basically same picture quality as HDMI anyway.

    Anyway after making sure the PS3 itself was fine under OFW I had another go at getting it to CFW.

    I followed all the same steps as before and this time everything is working.

    I am now convinced even though the firmware dump tested fine last time there was still something not quite right with the patch.

    This second time around I am not getting a single boot failure unlike last time I did the firmware patch.
    I loaded REBUG without a problem and also this time around the Ethernet port is working fine, whereas last time I could not get the Ethernet port to work.

    So that is 2 problems I had last time I don't have on my second attempt, the boot problems and the Ethernet port.

    Must have just been something slightly weird how the patch went last time, that did not happen this time and everything went correctly on the second attempt it looks like.

    Anyway I think that is this problem solved, I am still not sure of the original reason I had the problems when the first dump tested fine, but I seem to have it sorted now.
  4. 3,663

    sandungas Moderator Developer

    Dec 31, 2014
    Likes Received:
    Trophy Points:
    Babylon 20xxE series
    I thik you should try to replace the hdd, a big amount of the firmware files are installed in it for PS3 with NOR flash like yours, so if the hdd is damaged it can do weird things
    I think is a coincidence because you installed a firmware inmediatlly before the exploit... so it looks like the exploit could be causing the problems, but i think it was the new firmware files installed in hdd

    For the HDMI signal missing blue... i dont know the HDMi connector pinout or even if there is a pin for blue, but i would check the connector. First externally (to see if there is some pin bent or broken inside), and then internally (to see if there is some solder broken)
    The way to see if the solders are broken is by connecting a cable and moving the cable up and down forcing it a bit (but doing it carefully)... if there is some pin with a broken solder you will see how the pin moves
    As far i remember when looking at the connector solders from inside (after opening the PS3) there is only a few solders visible though :/

    Another thing you should consider when there are intermitent booting problems (sometimes boots and sometimes doesnt) is the power supply btw

    I think everything you did was well made, so the exploiting and cfw installation was fine
  5. 2

    dyalibya Member

    May 17, 2015
    Likes Received:
    Trophy Points:
    > Meaning on power up sometimes it boots and runs fine, and sometimes it just beeps 3 times and then flashes red and turns off, and sometimes (Rarely) it stays powered up with green LED however no picture.

    In my experience, this is a hardware issue that you would have run into even if you didn't try the exploit

    did you test the PS3 thoroughly after you bought it ? check to see if it's been opened ...... if it has been opened then the machine had a YLOD at some point and the previous owner did a makeshift repair and sold it
  6. 4

    vk2amv Forum Noob

    Nov 9, 2018
    Likes Received:
    Trophy Points:
    I would have thought that at first too.
    But I have since 100% confirmed it was a software issue with the initial exploit not taking properly for some reason.

    Aside from the previously mentioned HDMI issue (Which I haave worked around by using component out instead) the PS3 has been 100% reliable for a few weeks now after I went back to OFW then re-ran the exploit from the beginning.

    Just something really wierd with the exploit not working quite right the first time even though the firmware dump checked out.
    Anyway at the end of the day I am a happy camper now happily running Rebug 4.82.
  7. 7,837

    bguerville Moderator

    Feb 25, 2015
    Likes Received:
    Trophy Points:
    I see nothing to link the Flash Writer 2.0 patch directly to the problems you described in OP, whether the patch was successfully applied (it was, according to OP, no errors no warnings) or not.
    It could be a coincidence or the result of some other operation performed during the same session prior to rebooting leading a specific & rare alignent of circumstances with a crash situation down the line.
    We will never know unfortunately because to really find out what happened you would need to be able to reproduce the problem.

    Any patching issue ends up with a failed dump validation & a brick if you reboot while a successful patch allows you to reboot without issues using modded CoreOS files. In short, after applying a patch, you are either able to reboot or not. There is no middle ground situation which can be easily fixed without hardware flasher if you know what I mean.

    What you did when you held the power switch down for 30s is a manual reset. Having to use manual reset can happen sometimes with any ofw console, for instance if the console freezes during a game & cannot be restarted. Am not sure why this happens though, never researched it because it's quite rare, I must have used this manual reset only twice in over 10 years.
    Last edited: Nov 25, 2018

Share This Page