PS2 uLaunchElf 4.43a ( 2-TeraByte Edition ) file/partition/hdd manager

Discussion in 'PS2 News' started by UniqueUserName, Sep 13, 2016.

By UniqueUserName on Sep 13, 2016 at 11:29 AM
  1. 1,258

    UniqueUserName R.I.P.

    Jun 19, 2016
    Likes Received:
    Trophy Points:
    New England, USA
    Home Page:
    The 1-TeraByte HDD limitation, which had plagued the PS2, has finally been resolved
    (The best PS2 news youve heard in years has just arrived)

    This will be invaluable when 1TB internal drives disappear from store shelves
    Which is closer to becoming a reality than you might think.
    Download available at the bottom of this page... Enjoy
    I know we will all eventually need this ;) -Thank You SP193

    SP193 has done it again! Bringing to you uLE-2TB

    uLaunchElf 4.43a ( 2-TeraByte Edition ) file/partition/hdd manager...
    (Allows proper/reliable formatting, and correct size/value reading/feedback)

    - For 2TB Internal Hard Drives -​

    • ===== Notes from the Beta Tester ( spiderman ) =====
      All tests completed/accomplished with the following:

      • 1. This version of uLaunchElf ( uLE - 2TB )

      • 2. Genuine Official Sony Network Adaptor

      • 3. IDE-to-SATA Adapter...
        (very quick and simple mod for PHAT/Fatty/Chubby PS2's only)
        ....... You can find it HERE .......

      • 4. 2TB Seagate 2.5" (laptop) SATA Internal Harddisk Drive...
        (with the converter I am using, there is no room for a full size Internal HDD)

      • 5. USB-to-SATA-Converter...
        (to connect the drive to PC for installing games, removing the drive from the ps2 each time)

      • 6. OPL 0.9.3 (with all the options = VMC, GSM, etc.)

      • 7. HdlDumpGUI v1.5...
        (For installing games, it was the same as with ANY other hard drive)

      • 8. Free Memory Card Boot (FMCB) newest version available


      • I've used the uLE-2TB.elf (specifically uLE's HDDmanager/FileBrowser features)...
        (mainly to Format the Hard Drive, Create Partitions, and Copy/Paste files)

      • Correct Values are now displayed in uLE = Total Size and Free Space look right

      • +OPL partition created successfully

      • ALL partitions created successfully

      • I now have more than 1 TB of games installed ( 484 games )

      • ALL Games work as they should in OPL

      • ALL Virtual Memory Cards (VMC) work as they should in OPL

      • Simple Media System (SMS) works as it should...
        (However, the initial loading times seem to have increased)

      • HdlDumpGUI readings/feedback of TRUE User-Useable space...
        ( 1863GB Total / 1104.38GB Used / 758.63GB Available )

    • spiderman:

      "The main problem was formatting the hard drive initially (before this version).
      I tried WinHIIP and Free Hard Drive Boot (FHDB) with no success.
      uLE didn't work, and gave incorrect values for the HDD size.
      SP193 developed a uLE version that worked."​

      "This site has helped me tremendously, and I will gladly help anybody I can.
      I was delighted to help out any way that I could, although really I deserve little of the credit, as it was SP193 that worked on the program, and I was merely a tester."​

    • 0901161413.jpg

    • 0903161516a.jpg

    • SP193:
      (for developing, and providing us with, this much needed future-proofing resource)​

      (Beta Testing, Glitch Reporting, Feedback, Images, and this articles Main Source of information)​

      Other uLE Maintainers/Contributors of Note:
      (who may not have taken part in this version, but deserve an honorable mention nonetheless)
      AKuHAK, krHACKen, dlanor, E P, Mirakichi,
      Polo35, radad, Drakonite, sincro, kthu, Slam-Tilt, chip, pixel, Hermes,
      and many others in the PS2Dev community

    NOTE: this version is not for you unless you have a 2TB InternalHDD in your PS2.
    If you do not have a 2TB internal drive, you should still be using uLE wip7 or uLE_kHn.

    ....... uLaunchElf 4.43a ( 2-TB edition ) .......

    MANY EMAILs AND PMs from spiderman​
    Last edited by a moderator: Oct 22, 2016
    Impaler, Algol, Joel16 and 2 others like this.


Discussion in 'PS2 News' started by UniqueUserName, Sep 13, 2016.

    1. Berion
      SP193, You are the one of the few peoples which keep PS2 scene alive. Thanks!

      Just curious: is this version fixed PSX Memory Card reading from uLE WIP7? Have user rw access to system partitions?
      atreyu187 and UniqueUserName like this.
    2. STLcardsWS
      Where is the source link?
    3. UniqueUserName
    4. bigbossu
      Wow can't believe uLe still alive and kicking... how many years has been since the first time I meet it in this same site (I mean psx-scene).
      Oh... great memories.
      Joel16 and UniqueUserName like this.
    5. LEO33
      BUG REPORT: I cannot paste after copying a file from memory card (mc folder) to USB (mass folder), though copying from USB to memory card works. After failure, an empty folder is created in place where the copied file should have been. This also happens after cutting & pasting, in the source folder (in this case, in the memory card), which also fails. Check the screenshot. The name of the newly created problematic folder in this example is FCEUltra.cnf, which normally should have been the pasted file itself. :apologetic:


      Of course that this does not happen with the older versions (AKuHAK's uLE wip7 and uLE_kHn versions). So for the time being, reverting to the older versions.
      UniqueUserName and kozarovv like this.
    6. UniqueUserName
      Im sorry to hear that you are having issues with this version...
      Please note it says "2-TB edition"...
      It was ONLY modified to format and partition 2TB HDDs and nothing more...
      You should still be using the older versions if you are NOT using a 2TB internal hard drive (which I assume you are not since you only mentioned copying with USBmass).
      Thank you for the feedback :)

      Once again, for anyone else reading this, this version is not for you unless you have a 2TB InternalHDD in your PS2.
      If you do not have a 2TB internal drive, you should still be using uLE wip7 or uLE_kHn.
      LEO33 likes this.
    7. Berion
      Or "original" Unofficial LaunchELF v4.42d. ;) There is also another fork of LaunchELF, named LBfN as I remember correctly (but whole in Japan language).
      UniqueUserName likes this.
    8. UniqueUserName
      Correct... uLE 4.42d is even still included in official FMCB/FHDB releases as it is still considered the most stable version... but it requires a memory card from what I recall, so it isnt feasible with a pure HDD setup.

      Myself, I use wip7 for almost everything I do, and honestly I havent even tried this new 2TB version, as I dont have any 2TB drives that will fit in my PS2 (with the setup I have).

      I have used LBfN as well, and there are English-translated versions of that too, but I still recommend uLE to everyone, as it is the most intuitive (easiest to use and understand).
      Berion likes this.
    9. pinky
      I don't use an hdd for my ps2 backups. I use discs. however, I updated anyway. how does it look? I think the pink is perfect:

    10. UniqueUserName
      It may not work as you hope pinkstuff... this version is not for you... as you do not use a 2TB InternalHDD which is the only purpose for using this version. ;)
    11. peke
      Hi, I´m having issues trying to format a 2tb Hdd. I have a sata Network adapter (I bought on DX), and a 2tb WD green. Using ulaunch 4.43a it freezes on hdd manager when trying to acces to format. Reading hdd information.....been there for a lot of time, I already formated using 4.40. But have no succes with 4.43a, any help would be appreciated!
    12. sp193
      Unfortunately, not all compatible adaptors were truly compatible replacements for the SONY original. So changes to the ATA Driver module sometimes resulted in incompatibilities.

      Also, this build was originally meant as a prototype. You could try using a newer build, but I do have this feeling that it would not help you. wLaunchELF thread:
      Berion, DeViL303 and kozarovv like this.
    13. peke
      Thanks for the quick reply, it was working great with a 1tb wd sata hdd, but my attemp to use a 2tb hdd fail yesterday, been all day trying, I will give it a try again and see

      It´s strange that with version 4.40 of ulaunch I can format the 2tb hdd with no problem (I complete the format) but cannot on 4.43 witch freeze on loading hdd modules!

      My only Issue I think it´s to format the 2tb drive, I think that after that The adaptor will work!
      Last edited by a moderator: May 28, 2017
    14. sp193
      v4.40 is older, before I made this change on 15/04/2013. The change caused some clones to malfunction because they expected a value of 0x86 instead of 0x06 to be written.

      If that was the case, then you should notice that you can't do anything (cannot access, cannot format etc) with your SATA network adaptor and a new version of LaunchELF, regardless of the HDD used.
    15. peke
      with 4.40 I can format the 2tb hdd (witch gives me a -1880 size aprox). with 4.43a can´t even access to hd manager (it freeze). now I´m using a 1tb hdd that works perfect, If I could only format the 2tb HDD with 4.43a I think It would work.
    16. sp193
      So you can access your 1TB HDD with uLaunchELF v4.43a (2017)?
    17. peke

      I didn´t check that, I will, But with 4.40 I can use it normaly, format a drive and navigate. If I could format the 2tb hdd fine I think It work, is there a pc soft for formatting the 2tb hdd just like 4.43a? or a version that don´t hang up on hdd module?
    18. peke
      With 4.43a i can navigate (didn't try to copy anything) But when i load the hdd modules it freeze. That do not happen on 4.40
    19. sp193
      HDD modules are loaded for HDD access. So if you can really access the HDD to view the partitions via the hdd0 device, they are fine.

      If new LaunchELF versions are indeed able to correctly access the 1TB HDD properly... it may be just something on your 2TB disk. Like perhaps a bad format. So you could try to zero-fill (erase) the HDD with your manufacturer's tool before trying to format the HDD with the late v4.43a build again.

Share This Page