PS3 [Update] Apollo Save Tool v1.0.2 released

Discussion in 'PS3 Homebrew' started by bucanero, Feb 7, 2020.

By bucanero on Feb 7, 2020 at 2:49 PM
  1. 370
    643
    147
    bucanero

    bucanero Developer

    Joined:
    Jun 29, 2019
    Messages:
    370
    Likes Received:
    643
    Trophy Points:
    147
    Gender:
    Male
    Location:
    Argentina
    Home Page:
    Update v1.0.2 Released
    Original Introduction: PS3 development has been seeing an upkick lately and developer @bucanero has been one of the developer playing a part. The developer has recently updated Artemis with new support and also released PKGi (PS3) but now the developer shares a great utility that involves PS3 Game Saves called Apollo, built utilizing the Artemis GUI this homebrew capable of running on CFW and PS3HEN will allow you to Patch & Resign your Game Saves / Download Game Saves / Unlock Game Saves all from the convenience of your PS3 console and not PC tools are required. Below you can see the release thread from the developer himself: So i'll let @bucanero take it from here with another great release:
    -STLcardsWS

    screenshot_main.png
    It's summer, you're between jobs (a.k.a. unemployed), so what do you do with that amount of free time? You make "Apollo", a new homebrew app for the PS3! :D

    • you might wonder... why is it called Apollo?
      Apollo was the twin brother of Artemis, goddess of the hunt. Since this project was born using the Artemis-GUI codebase, I decided to respect that heritage by calling it Apollo.

      So, without further ado, let's present Apollo:

      Apollo Save Tool is an application to manage save-game files on the PlayStation 3.
      The apollo-ps3 homebrew app allows to download, unlock, patch and resign save-game files directly on your PS3.


      Features:
      • Easy to use: no crypto-key configuration or advanced setup needed.
      • Standalone: no computer required, everything happens on the PS3.
      • Save files listing: quick access to all the save files on USB and the internal PS3 HDD (+ file details)
      • Save SFO unlocking: allows the user to remove the copy-lock flag, enabling transfer of Copying Prohibited save files.
      • Save files patching: supports Bruteforce Save Data and Game Genie cheat patches to enhance your save-game.
      • Save PFD resigning: allows the user to resign save files made by other users and consoles.
      • Save downloading: access to an Online Database of save-game files to download straight to your PlayStation.
      • Automatic settings: auto-detection of PSID and Account-ID settings.

    • v1.0.2

      Added

      • Re-added resign/cheat options to HDD/USB
      • Added decrypt file option
      • Updated UI with custom font

      Fixed

      • Fixed game listing issue (when name has a \n)
      • Fixed custom CRC calculation bug (BSD patches)


      v1.0.0

      Added

      • Bruteforce Save Data cheat patch support
      • Changed save-game encryption/decryption method
      • Splash screen logo


      v0.9.0

      Added

      • Game Genie cheat patch support
      • Updated UI
      • Added Remove Console ID patch
      • Added Licenses backup to .Zip (/dev_hdd0/home/000000XX/exdata/)
      • Added bulk save-game copy to USB
      • Added Trophies backup to USB
      • Added owner.txt support to override auto-detected settings
      • Improved auto-update check/download
      Fixed

      • Solved issue when copying save-games from HDD to USB
      • Solved freeze bug when using Clear local cache
      • UI: Fixed improper titles and messages


      v0.6.5

      Added
      • Export save-game to .Zip file
      • Copy save-game to USB
      • New Settings option to clear local cache
      • New Settings option to update application data

      Fixed
      • Fixed patch when removing Account ID
      • Use internal PS3 fonts to fix issues with extended characters


      v0.5.1

      Hot fix release.

      Fixed

      • Fix unzip issue when unpacking online save files



      v0.5.0


      First public release.
      Added

      • Save file listing (+ details)
      • Save file SFO unlocking (remove lock flag)
      • Save file PFD resigning
      • Save file download from Online Database
      • Automatic detection of PSID/Account-ID settings

    • Using the application is simple and straight-forward:
      • Move UP/DOWN to select the save-game file you want to patch, and press :but x: . The patch screen will show the available fixes for the file. Select the patches and click Apply.
      • To see the item's details, press :but tri: . It will open the context menu on the screen. Press :but cir: to return to the list.
      • To reload the list, press :but square: .
      • Press left (L1/L2) or right trigger buttons (R1/R2) to move pages up or down.


    • No special setup is needed. Just download the latest apollo-ps3.pkg package and install it on your PlayStation 3. On first run, the application will detect and setup the required user settings.


    • screenshot_main.png screenshot_patches.png screenshot_savelist.png screenshot_settings.png screenshot_about.png screenshot_details.png


    • Credits


    See the full project's README for more information: https://apollo.psdev.tk/
    feel free to share you comments and ideas! :cool2:


    Download link: https://github.com/bucanero/apollo-ps3/releases/latest
    As usual, full source code is available on GitHub :)
     
    Last edited by a moderator: Mar 28, 2020 at 8:49 PM

Comments

Discussion in 'PS3 Homebrew' started by bucanero, Feb 7, 2020.

    1. bucanero
      bucanero
      as a general rule, you shouldn't remove the console-id (psid) or account-id when you're resigning a save you want to use.
      So if you have a save on USB, click only on "resign" without applying any other change or patch. Then copy to HDD from the XMB.

      have you tried with the older version 0.6.5 ? you get the same issue?
    2. Java Brasil ps3
      Java Brasil ps3


      The old version is going to have the option of removing the id in saves from the HD, because only the USB that is appearing is an excuse. I'm Brazilian and I don't know English. I'm here with Google.
    3. bucanero
      bucanero
      I don't understand your message. :confused3:
      in the previous version you have the option to resign on USB and also on HDD, so you could try it and see the results.
    4. Berion
      Berion
      Algol and DeViL303 like this.
    5. psdavx
      psdavx
      After removing the copy protection of savedata stored in USB, it cannot be copied back to the ps3, the screen prompts that the data is corrupted
      Last edited: Mar 9, 2020
      Java Brasil ps3 and Algol like this.
    6. Algol
      Algol
      @bucanero : C'est excellent ce que tu viens de nous créer mais j'ai une proposition d'amélioration à formuler.

      Pourrais-tu lors des sauvegardes sur USB vérifier s'il n'existe pas plusieurs comptes (cessions) sur le DD interne de la PS3 et éviter que toutes les SAVEs ne soient mises ensembles dans le même répertoire par les différents propriétaires.
      Par exemple, créer un dossier comportant le numéro de cession et le nom exact du propriétaire qui fait cette sauvegarde (mon cas étant : "00000001-Allan" par exemple), tout ceci étant dans le dossier "PS3/Savedata" que tu as créé via "Apollo v0.9.0".
      Ce n'est qu'une amélioration possible.

      Très cordialement. Algol "le papy".


      In English via Google :

      Could you during backups on USB check if there are not several accounts (transfers) on the internal DD of the PS3 and prevent all the SAVEs from being put together in the same directory by the different owners.
      For example, create a folder with the transfer number and the exact name of the owner who makes this backup (my case being: "00000001-Allan" for example), all of this being in the "PS3/Savedata" folder that you created via "Apollo v0.9.0".
      It is only a possible improvement.

      TIA
    7. bucanero
      bucanero
      have you tried with the older version 0.6.5 ? you get the same issue?
      if you could try it , let me know the results.

      edit: I was able to reproduce the bug. I'll release a quick bug fix soon (probably tomorrow)

      if you need to recover the "corrupt" save, install the v0.6.5 and resign the save. (the older version doesn't have the resign bug)
      Last edited: Mar 10, 2020
    8. bucanero
      bucanero
      sandungas, Algol and DeViL303 like this.
    9. psdavx
      psdavx
      Tried version 0.6.5, without the problem,I will wait for the new version to be released,thanks!
      bucanero likes this.
    10. ashura
      ashura
      hello guys i hope that you arehaving an excellent day, i wanted to let you know that on the new version the option for removing copy protection was removed i do not know why, it is because that that this one was really useful at the moment of reasign saves procedures, thanks in advance
    11. bucanero
      bucanero
      Due to a change in the encryption/decryption methods, the "remove copy protection" option was moved to the "USB saves" list.
      You can still unlock saves, but you need to copy the save to USB first. (wait for v0.9.1 because the resigning on USB has a bug.)

      I might re-add the "unlock copy" to the HDD saves using the new encrypt methods later.
      Louis Garry likes this.
    12. bucanero
      bucanero
    13. ashura
      ashura
      Thank you very much bucanero i will give it a try once i get to home because i am trying to change region to a savedata which is resident evil zero to biohazard zero which is the japanese version of the game what it worked for me was the following:

      I did first the region change into rayman legends savedata thru bruteforce savedata tool without reasign my changed region savedata then i used apollo and then managed to reasign the new region savedata and then copy it to my PS3 HDD and then it worked for me, i am trying to do the same experiment with resident evil zero jeje lets see what happens then
      DeViL303 and Algol like this.
    14. SoJustMe
      SoJustMe
      great update .. Thanks..

      after the new release i was able to update from ps3.

      it looks nice But the white font is small and not good for the background.

      i would like to see Features for this great app like :

      1- coby the Save file for different users -but it needs to be rebuild data if there was no old save file on that user- . so trigger a rebuild data after finish or after close the app maybe !
      2- Zip/Unzip file more options ( i can still use multiman to Unzip), but need to select a Zip file and it does Unzipe to Savedata folder by itself.

      just to be clear:
      -copying from Save data utility does not require to rebuild data.

      -replace an old save file does not require to rebuild data ( the new save file that replace the old file works fine)

      -if i copy save file to new user through multiman or file manager , the game and Save Utility don't recognize the new save file on the new user.
    15. ashura
      ashura
      hello guys i have good news jeje i changed sucessfully the save region and i managed to get it loaded sucessfully so what i did was:

      - use bruteforce savedata tool to change the region of the game that i want to use the savedata ( no reasign to any user just use the default one of the original savedata)

      - once is done, copy the usb savedata( the one with the modified savedata region) to usb

      - then open apollo and reasign savedata from usb and there you go, you need just to copy and ready to play, thanks once again bucanero for this useful tool that you make it real, have a nice day guys
      bucanero and SoJustMe like this.
    16. Louis Garry
      Louis Garry
      bucanero, codone and ashura like this.
    17. codone
      codone
      Funny timing on my part here... I tried the 0.9.0 version just today, on a Sly Cooper 2 saved game -- it has Copy Protection. I had moved a save to my other PS3 in the past with Brute Force app on the PC. Well, I tried this, and got the "Corrupt" error when trying to copy from USB back to the other PS3. What a coincidence that you just released the fix TODAY! lol... I tried 0.9.1 and it now works perfectly! Thanks so much for doing this app! Makes it a lot easier than having to use a PC to FTP the save from the ps3, and use Brute Force.... The app is nicely done too! PS -- I didn't see a way to update the app from 0.9.0 to 0.9.1 from within the app itself.
      Louis Garry and bucanero like this.
    18. bucanero
      bucanero
      are you referring to the text on the main screen (above the jar icons) or the text on the savegame lists, cheats and options? I added a darker alpha background to improve the readability of the item lists and options. I guess I can make it even more darker.

      About the size, I guess it depends on the screen too... I'm testing it on a Samsung 49' LED and it doesn't look small, I tried to keep it similar to the text size in the XMB.

      good to know you were able to change regions. Probably not the most urgent update right now, but if I implement the on-screen keyboard on Apollo, I could add an option for the user to enter a new "TITLE ID" and create a savegame duplicate.

      I did some changes on the auto-update feature to support https downloads, but I tested it and should be working... :ambivalence: just to be sure, check on the "Settings" page if the "auto-update check" option is enabled.
      If anyone else is having the same issue or can confirm the auto-update worked (from 0.9.0 to 0.9.1) that would be helpful too.
      Rmtxpir likes this.
    19. codone
      codone
      I was on 0.9.0, and under settings I had auto-update enabled (had a dot in the circle). I manually clicked an option like "update data files" (or something like that). It grabbed a ZIP (?) file and extracted a bunch of savedata files, perhaps cheat info? Anyways, it updated the files, but, not the app itself (to 0.9.1). I tried twice... and quit the app, and restarted, and it was still showing 0.9.0 on About. I then read the forums here, downloaded the new 0.9.1 pkg, installed that, and of course it updated. So, just trying to give you a little extra info on my situation where it didn't appear to update for me. Perhaps I am missing something obvious to get it to update the main app?
      bucanero likes this.
    20. bucanero
      bucanero
      thanks for the feedback, I'll dig into the auto-update to see if something got broken with the recent changes.

      When things work as expected, if you open the Apollo app and there's a new version, you should get a notification screen "there's a new version, do you want to download?", and if you click "yes" the app downloads the latest .pkg to /dev_hdd0/packages/ .

      btw, as you said, the "update data files" only updates the cheat files, not the app. The update .pkg should have been downloaded with the "auto-update check" option, but something happened there.
      Algol likes this.

Share This Page