PS3 [UPDATE] IDPS Dumper (PS3 NAND / NOR ) - 4.81/4.82 OFW Compatible by Team PS3Xploit

Discussion in 'PS3 News' started by STLcardsWS, Nov 11, 2017.

By STLcardsWS on Nov 11, 2017 at 10:41 AM
  1. 8,727
    8,522
    1,047
    STLcardsWS

    STLcardsWS Administrator

    Joined:
    Sep 18, 2014
    Messages:
    8,727
    Likes Received:
    8,522
    Trophy Points:
    1,047
    {UPDATE v0.2.3 Released(See tab)}
    Following the official announcement of the PS3Xploit news (4.81 OFW Exploit), the devs behind the project have fulfilled the promises of releasing the IDPS Dumper for OFW 4.81/4.82 as this release is ready for the public. Now there is many more things being worked surrounding the overall project but this IDPS Dumper works on all models of the PS3 (NOR and NAND, note 12 GB EMMC will be supported soon in an updated release) and no reason not to release this tool. Since PS3 firmware 4.70 Sony had blocked flatz IDPS extracting tool (IDPS Stealer) and there has not been a known way to obtain the IDPS on OFW (4.70 +) consoles , but now this tool can now obtain your PS3's ID, which can have various uses, the tool has been confirmed to work on SuperSlim models by the team. . If you have not read the previous details about the PS3Xploit project, then checkout this official thread to get the firsthand information about this ambitious PS3 project.


    capture_0.2.3.jpg
    (UPDATE v0.2.3)


    • UPDATE v0.2.3- IDPS Dumper for 4.82 OFW
      • Added 4.82 Support
      • Removed all extra requirements like JQuery..
      • Removed the need for string relocations to improve the initial memory search process & overall trigger times.

    • UPDATE v0.2.3- IDPS Dumper for 4.81 OFW

      • Removed all extra requirements like JQuery..
      • Removed the need for string relocations to improve the initial memory search process & overall trigger times.



    • UPDATE v0.2.1a- IDPS Dumper for 4.81 OFW

      we have some more exciting news to bring you!! :cheerful:

      We have been working very hard to bring eMMC support for the newest SuperSlims CECH-40xxA, CECH-42xxA , CECH-43xxA and that has happened. :D

      The team would like to present a nice little update to the 4.81 IDPS Dumper now supporting eMMC hardware revision consoles!!

      Please report any issues you have while using this new version on any of the flash types, NAND, NOR, and eMMC.

      Thank You to all :cool:

      v0.2.1a
      • Added eMMC SuperSlim Support (CECH-40xxA, CECH-42xxA , CECH-43xxA)
      • Misc Tweaks To Exploit
      • Small typo on index.html pointed out by @Turranius - Fixed

      How to use this:
      *** MAKE SURE TO RUN AS ADMINISTRATOR ***
      install python to use server.py or another HTTP server of your choosing on both Windows and Linux!​

      On windows - Install any of these optional HTTP servers:

      On linux:
      • install python for your distribution using apt-get, yum, and similar commands.
      • make script executable using "chmod a+x server.py" or "chmod 775 server.py" or "chmod 777 server.py"
      • execute python script using "/usr/bin/python $exploitFolder/server.py" or "./server.py"

      Update
      on Android: (
      instructions from @No0bZiLLa)
      • I can confirm this does work if using an http server on Android. what i did was downloaded the zip (on my phone) and extracted it and then download something like Simple HTTP Server and point the server to the folder that contains index.html. once you do that just reload the server and make a note of what the ip:port is. then just go to ps3, type in ip:port (eg 192.168.2.7:12345) as specified in simple http server and then select the appropriate button for your system.


      Then run (for python):

      • On windows - windows.bat
      • On linux - linux.sh


      Usage Tips:

      1) Try using a LAN connection or a solid WiFi connection during exploitation. A weak signal can cause problems.
      2) If the exploit takes more than 5 minutes to work, reload page, browser, or restart console and try again.
      3) If you are using a LAN connection and experience network issues, make sure all cables to router are in working order.​



    • IDPS Dumper Release (v0.2 - After Leak Release)
      ok....the moment all of you have been waiting for......i assume :cheerful:
      • File: ps3_481_idps_dumper-PS3XPloit.zip
      • MD5 Hash: FFDA70AB2D1677886083F99185C54FE3
      • SHA-256 Hash: 852BDB301753C4F4A7E946188E850D3D325EEAA259B61AE2B5AE31320B2F292B

      enjoy this release from our team :victorious: we will be working hard to add eMMC support as soon as possible!!


      The documentation will be updated as time goes on. There is a readme.txt file included with basic setup and usage instructions.

      Please stay tuned for future tools and releases :D

      and once again, THANK YOU to everyone involved bringing this all together, without all of you, none of this would have happened!!!

      Additional details from @bguerville
      "The idps dumper will create a file on usb000 then beep 3 times & shutdown in all cases, even if flash memory read fails. emmc should not make a difference to this. You will get garbage in idps.bin in that case.

      Js errors with a black page message on ps3 should not happen. If ever it did, just report & in the meantime keep relaunching the exploit. Nobody has had this issue in dozens of tests though.

      And clearing cache or cookies is totally unnecessary with the exploit & the wk js interpreter. Between runs garbage collection will take care of cleaning up what is needed, the job it does is always sufficient".


    It's essential not to flood the browser memory with junk before running the exploit. The reason for this is that due to javascript core memory usage limitations we are scanning several times a small range of browser memory (a few Mb) to find some essential data in RAM, if the memory is flooded then the range to scan becomes much larger & the probabilities that our data is found in the smaller range decrease dramatically....

    So in short, never use the browser or set a homepage you cancel before running the exploit!
    If you need to, set the homepage to 'blank', close the browser then reopen it to start the idps dumper.

    Set-up Steps:
    1. Setup a small Web server on pc or smartphone. The Python http server is not required for most users, it was provided for developers. Since v0.2.3, all other extra requirements have been removed. Don't come to us for explanations about how to run a http server though. Google it.
    2. Extract the files in your http server root folder.
    3. Put a fat32 USB key in port closest to BD Drive (/dev_usb000).
    4. Open the ps3 browser & write the ip address of your server (and the port if not 80).
    5. Run until ps3 beeps & shutdown. The idps should be on your USB drive as idps.bin.
    - Downloads -
    • MD5 Hash: 3c2e1582f52e1002a12ad280f426d0c6
    • SHA-256 Hash: 1c49eabd64275171a60c90f0f06f503b7055f4ff863f87e7960d41464d127443
    • MD5 Hash: 71dd906e585bf470f84f9d4fb10c1f37
    • SHA-256 Hash: d4bffe2b7d08c1dda275590229f86903f1db487e9a78364d6a025c3734cd8f68
     

    Attached Files:

    Last edited: Nov 19, 2017

Comments

Discussion in 'PS3 News' started by STLcardsWS, Nov 11, 2017.

    1. amaandeep.nz
      amaandeep.nz
      You could try lol

      Sent from my SCL-L02 using Tapatalk
      bitcrush likes this.
    2. esc0rtd3w
      esc0rtd3w
      try the sdcard slot on phat also

      no, it is hard-coded for /dev_usb000/

      from my understanding, the phats also use the mmc or sdcard as alternate?!?

      my personal tests on an E01 phat works fine with USB Port 000, closest to the BluRay drive

      check as suggested by others already to make sure the flash drive is FAT32 formatted, and shows up on XMB.

      you may also have a bad USB port, physically (bent/broken pins), it happens all the time, i repair them :eek:

      maybe we can add support for other USB ports and memory devices in a later update.....
      Last edited: Nov 14, 2017
    3. amaandeep.nz
      amaandeep.nz
      Can u edit the .js file plz

      Sent from my SCL-L02 using Tapatalk
    4. bitcrush
      bitcrush
      I'm pretty sure the USB ports on the the super slim 43xx are numbered differently. I've ran the exploit successfully multiple times now and I'm getting nothing on both USB ports.
    5. esc0rtd3w
      esc0rtd3w
      don't think so man...i tested on a 4201A, a 2501A, and an E01...all same port

      maybe 43xx different...but i wouldn't think so
      amaandeep.nz likes this.
    6. Sakimotor
      Sakimotor
      Worked in 2 seconds today, gonna check my USB flash

      EDIT : Idps.bin dumped successfully, 4004C confirmed to work on OFW 4.81 !
      amaandeep.nz and esc0rtd3w like this.
    7. amaandeep.nz
      amaandeep.nz
      What firmware

      Sent from my SCL-L02 using Tapatalk
    8. DeViL303
      DeViL303
      As far as I know this will only work on 4.81.

      There was another firmware that has similar offsets so its possible it will work on that too? cant remember which but I remember that backup managers designed for that older CFW would work on 4.81 and some would detect 4.81 as that older CFW.
      esc0rtd3w likes this.
    9. Sakimotor
      Sakimotor
      Are you talking about the 4.70 ?
    10. DeViL303
      DeViL303
      Yeah that could be it, I am not sure if it will work on that, but if there is any other CFW it has a chance to then that would be it.
    11. bitcrush
      bitcrush
      update: i got a file now but for some reason it's empty. checked it with HxD... just full of zeroes

      update 2: got it now, i was choosing the wrong method. i thought 43xx use emmc, it's actually NOR. /facepalm
      Last edited: Nov 14, 2017
    12. ranjith
      ranjith
      what is the use of idps plzz help me
    13. Turranius
      Turranius
      Anyone else have problems getting this to work or is it just me? Tested on two different PS3 4.81 OFW systems. I once managed to get the file from one of them, but have not yet been able to replicate it on the same system or the other.

      Tested all different webservers I can think of. Should be a simple thing, but I can leave it on for an hour or restart every 5 minutes, it just does not find it again..

      I just want to know if its just me as I have run out of things to test / verify.
    14. bguerville
      bguerville
      It can't work on 4.82 until it is ported.
      vsh has changed a little so we have under a dozen offsets to check & modify if we need to.
      We can do that easily by extracting vsh.self from the pup.

      Luckily it seems this update does not really affect webkit, it was mostly compiled last August, not last week!
      Hopefully it will change nothing to the current situation...
      esc0rtd3w and DeViL303 like this.
    15. dasinking
      dasinking
      what a weird timing for that update then
    16. norflondonboi81
      norflondonboi81
      I have been trying to get this to work since yesterday on simple server android but get poc reloading and sometimes it finds usb ten back to poc its triving me nuts.i have slim cech 2xxx
    17. Turranius
      Turranius
      Infinite loops? Glad I'm not alone =(

      Edit:
      I'm not complaining to the developers, mind you. I've been given excellent help with troubleshooting but nothing have helped.
      Right now I'm in the process of setting up a physical webserver on an Intel NUC with a twisted ethernet cable to the PS3 so I can disregard my network being the problem
      Last edited: Nov 14, 2017
    18. Jaroslav_01
      Jaroslav_01
      esc0rtd3w , I hope you aren't going to work on 4.82 now, Just stay on 4.81 and when that is finished then you could work on 4.82.
      sandungas and esc0rtd3w like this.
    19. RIggola
      RIggola
      Hello, im pretty noob with ps3 tools and everything related (unfortunately my ps3 is 3004b and since i got it on 2014 i never used it because no JB) btw i got the IDPS but how i can open/verify it? thank you
    20. amaandeep.nz
      amaandeep.nz
      Would it be safe to update to 4.82

      Sent from my SCL-L02 using Tapatalk

Share This Page