PS3 (Update) PS3 HFW (Hybrid Firmware) 4.84.2 - PS3Xploit HAN & Flash Tools Restored for 4.84 OFW users

Discussion in 'PS3 Jailbreak CFW and PS3HEN' started by Joonie, Mar 21, 2019.

By Joonie on Mar 21, 2019 at 6:34 PM
  1. 3,084
    3,027
    372
    Joonie

    Joonie Developer

    Joined:
    Oct 15, 2014
    Messages:
    3,084
    Likes Received:
    3,027
    Trophy Points:
    372
    Location:
    Southwest US
    UPDATE2 (April 27 2019) nonCFW PS3 MODELS There is now a PS3 HEN that enables HOMEBREW !!!!!!!! >> See Link

    The new HEN requires this 4.84 Hybrid Firmware (HFW).


    UPDATE1: PS3Xploit 4.84 HFW Flash Writer + IDPS/Flash Dumpers Updated v2.0.1 - (Now install CFW from 4.84) See HERE for details


    Huge News as the PS3 exploit ladder has taken a step up into 4.84 rung, with a new approach to bring back PS3Xploit functionality on 4.84. With a Hybrid Firmware (NOT A CFW) that can be installed on ANY MODEL PS3 over any Official Firmware (OFW) version. .The only thing this modified firmware essentially does is bring back the patched webkit from OFW 4.82 that was an entry point for PS3Xploit, if you recall when 4.84 was released developers @bguerville and @esc0rtd3w stated the exploit was not actually patched but rather only the webkit entry used was removed in 4.83+ which rendered the actual exploit unreachable (not patched and could be restored). Now the webkit is back for 4.84 OFW thanks to this new clever magic that has allowed OFW user's to use and install this slightly modified Firmware.

    So, what does all this mean? Now it will be just like it was back in 4.82 before PS3Xploit was "patched"(some ps3xploit tools need updated still) you will be able to install a CFW (on a CFW compatible model) and for those unfortunate user's that does not have a CFW Compatible model (i.e. SuperSlim/late slims) you have will have access to the HAN exploit . So for new user's or ones that updated, here is your second chances thanks to the efforts of the members of PS3Xploit Team and to @Joonie (waved magic wand on files) and prepared this magically release, @habib (for valuable input on this project) and @esc0rtd3w (work in porting ps3xploit tools to 4.84)

    It has been an exciting month here at psx-place with so much progress on all fronts of the PS3 . the fuel of this project actually comes from a user simply igniting a spark with an idea as @Doge_Rules did with this thread truly making it a community effort. Updated - to version 4.84.2 (see details below)

    -STLcardsWS

    HFW_Joonie_ps3Xploit.jpg
    (Note: NOT ALL PS3Xploit tools are updated currently, Ps3Xploit team is currently working on updating those tools. Stay tuned.)

    • 4.84.2 HFW (Hybrid Firmware)
      Restores PS3Xploit Flasher/Tools & PS3Xploit HAN for 4.84 OFW user's

      Today, we proudly present the very first modified OFW that can be installed on all PS3 models. (NOTE: THIS IS NOT A FULL BLOWN CFW, HOWEVER IT Allows you to run the patched webkit exploit that's ported to 4.84)

      Yes, you didn't hear wrong, it can be installed over

      • ALL OFW versions on ALL PS3 models
        • ex) OFW 4.83, 4.84 , CECH-3XXX, CECH-4XXX and etc..

      We wanted this to be called "HHHFW" since it was Hybrid, Hack-able, HAN ready also inspired by @habib but let's call it HFW since this is Hybrid FW (Well you can call this MFW).

      The idea was reminded by some guy who didn't want to be annoying but actually ended up being helpful: @ psx-place.com

      Habib had this idea long time ago but the previous attempt was not successful due to lack of interest and preparation.

      As you all know, I recently started messing with my PS3 again and this idea was brought back.

      So then I went ahead and tried his magical idea.... after a few hours later... Boom!!, now we have HFW that works on all PS3 models (including 3K and 4K) that allows the previously patched exploit by using old webkit from 4.50 that's been used until 4.83. This method is rather hacky than technical, so I would like to leave this method under the radar for now until it gets patched out (this can easily be patched).

      What can you do with this HFW 4.84.1/2?
      1. You can use PSN since the FW is the latest.
      2. You can downgrade/Install CFW on your PS3 if your model is downgrade-able/hack-able (excluding CECH-3K and 4K)
      (The same capability as what you had for 4.82 OFW)
      3. You can use HAN and all the tools that worked up to 4.82 with this FW.
      4. You can always go back to the real OFW 4.84 if you wish.​

      To all scener's and developers
      • Please update the HAN toolbox or any xml that can support 4.84 if anyone's available.


      [​IMG]



      UPDATE 3-22-2019 - 4.84.2 Released
      HFW 4.84.2_PS3UPDAT.PUP
      • Bugfix : Fixed the installation issue with regions that use following languages
        English (UK), Turkish (Turkey), and Portugal (Brazil) , Thanks to @citra mulia to report the bug :)
      • upload_2019-3-22_0-1-23.png

    • 4.84_icon.jpg
      System Update displaying 4.84.1 HFW
      c3LQ54O.png

      PS3Xploit Tools running on 4.84 HFW
      upload_2019-3-21_9-15-20.png
      upload_2019-3-20_22-7-55.png

    • DO NOT UPDATE WHEN A NEW OFW FIRMWARE UPDATE IS RELEASED!!!

      -STLcardsWS

    • Here is a video tutorial by @MrMario2011



    Download link (MEGA) : HFW_4.84.2_PS3UPDAT.PUP
    MD5 :4247362b54fadd2e4d7c09007f720803

    UPDATE (3-24-19): PS3Xploit 4.84 HFW Flash Writer + IDPS/Flash Dumpers Updated v2.0.1 - (Now install CFW from 4.84) See HERE for details

    Additional Download/Resources
     
    Last edited by a moderator: May 19, 2019
    ed89, Kazama, Krush206 and 82 others like this.

Comments

Discussion in 'PS3 Jailbreak CFW and PS3HEN' started by Joonie, Mar 21, 2019.

    1. Cooltwou
      Cooltwou
      I did the Flash Writer it did everything correct and patched the NOR Flash Writer and gave me a dumb hex file and then I went to do the NOR Flasher V2.0.1 & it did the Initialize Exploiting but it never patched the NOR Flash Memory to USB and it looks like my PS3 has locked up while do the patch NOR Flash Memory and what do I need to do now [​IMG]
    2. Cooltwou
      Cooltwou
      I even left my PS3 running all night to patch the NOR Flash Memory and nothing happened and it looks like the system has froze and I have tried over and over again and the same thing every time it will exploit but will not patch the NOR Flash Memory to USB
    3. jolek
      jolek
      Did you verified dump.hex file with PS3DumpChecker?
      [​IMG]
      BTW It was step 2.


      [​IMG]
      Something is not right, patching usually takes less than 2-3 min, sometimes it with s***y pendrives it can extend to 10 min, but not all night.
      Last edited: Jul 19, 2019
    4. Cooltwou
      Cooltwou
      First of all I did check the dump file and it said ok like your picture showed but I am not understanding why every time I go to do the PS3 NOR Flash Memory it will exploit but when you click on patch to USB the bowser or the system freeze and cannot do anything but turn the system off
    5. jolek
      jolek
      Last thing than comes to my mind is to try different USB device.
      You plugged USB device into right USB port with flash_484.hex on the root of USB device?
      Clean all cookies in browser, set PS3 NOR Flasher v2.0.1 for HFW 4.84 as homepage, close it.
      Open it again.

      Also, have you got let say stable internet connection?
      You're using Wi-Fi or LAN?
    6. Cooltwou
      Cooltwou
      I am using WiFi because I tried to setup Ethernet connection and the IP address keeps timing out and I have to see if I have another USB because I let a friend borrow my other one and not brought it back to me yet
    7. jolek
      jolek
      While configuring LAN you've tried Easy or Custom settings method?
      If custom, what kind of setting you have chosen?
      Speed:
      1000BASE-T Full Duplex... Auto Detect.
      IP:
      Automatic, Manual, PPPoE.
      MTU:
      Do Not Use, Use.
      Proxy Server:
      Do not use, Use.
      UPnP:
      Enable, disable.

      If you've only tried Easy, try Custom.
    8. Cooltwou
      Cooltwou
      https://imgur.com/gallery/bORxEqb it says this here but when I plugged the USB back into my computer it just had the hex file I just used but no dump file so I don’t know what is going on and I changed to a different USB drive but it has lower memory then the other one I was using
    9. jolek
      jolek
      jcorrea likes this.
    10. Cooltwou
      Cooltwou
      When it said that it was successful I did eject the USB cable but there was no dump file on the USB just the hex file could it be because that USB is like 4GB
    11. jolek
      jolek
    12. Cooltwou
      Cooltwou
      I don’t understand that right there you talking about & you are talking about the Flash Writer or Flash Memory
    13. brainiack
      brainiack
      Ok so I had a ps3 slim that I tried this on and it worked great but then my ps3 hard drive crashed so i thought i had to reinstall the xploit so reinstalling the xploit over the already exploited fw bricked my ps3 now all it does is red light u press the power button it beeps once then shuts right off I was however able to get a dump.hex file from exploiting it the first time as well as a act and ldps file what do i need to restore the ps3 at this point or is it all lost? it was a cech 2xxxb if that helps Nor
    14. jolek
      jolek
      Now there are only 2 steps ahead having CFW.
      Dump Flash Memory after Successful flashing, verify it with PS3DumpChecker.

      If everything will be fine, reboot console & install CFW.
      Last edited: Jul 19, 2019
    15. Cooltwou
      Cooltwou
      I am not sure what is going on the PS3 Dump Checker gave an error message and said Filesize don’t match expected size from the configuration! Please dump check your image and configuration
    16. jolek
      jolek
      Size of "dump.hex" should be 16 MB (16 777 216 bytes).
      You can check that in file properties.
      Here is e.g. how it looks like with an another file, another size:
      [​IMG]

      If somehow you're unable to get this size, change USB device.
    17. Cooltwou
      Cooltwou
      Well I cannot even get the program to do anything and the USB drive didn’t work and I don’t have another USB drive right now because I let somebody borrow my other one and they haven’t got it back to me & should I try the PS3 dump again and see what it does now
    18. jolek
      jolek
      Check that USB device for errors:
      [​IMG]

      Delete old with wrong size "dump.hex" from it.
      Try it again do dump you flash memory on PS3.
    19. Cooltwou
      Cooltwou
    20. skygunner58203
      skygunner58203
      I'm having an issue with the second NOR dump. I flashed the 484 hex file, dumped it, ran it through the pyps3checker. Says Unable to determine flash type! Seems to be an invalid dump. I've ran the dump 3 times. The exploit runs fine, the dump works fine. Size of the file seems fine. What am I doing wrong here?

Share This Page