PS4 (Updated) RetroArch (unofficial PS4- R2) Now includes 37 libretro cores (Yabause / Mupen64 addded)

Discussion in 'PS4 Homebrew' started by STLcardsWS, Dec 27, 2019.

By STLcardsWS on Dec 27, 2019 at 6:32 PM
  1. 9,425
    9,896
    1,172
    STLcardsWS

    STLcardsWS Administrator

    Joined:
    Sep 18, 2014
    Messages:
    9,425
    Likes Received:
    9,896
    Trophy Points:
    1,172
    (Update R2 released) Developer @OsirisX is back with release 2 of the PS4 port of RetroArch , this unofficial port (based on v1.8.1 of the main project) now contains 37 libretro cores adding an additional 12 since the initial release, those cores include the arcade core FBA & also a Sega Saturn Yabause (curious how that compares to the standalone from znullptr), while N64 emulation still needs some work the parallel_64 core included in v1 has seen a new companion and n64 offering in the addition of the Mupen64 core. The new n64 core does offer some small speed improvements from parallei_64 and may still need some improvements to come in the future hopefully (please share your results/feedback below, which games are working for you?).. Also a bug other's and myself experienced has been addressed, the issue being (in r1) where we could not launch any content in other locations, such as in playlist has now been fixed in the r2 release. That is a welcomed bug to be squashed as now playslist/collections/favorites ect.. should work fine. The PS4 homebrew scene looks in alot better position then it did weeks ago. You have to really stop and look the PS4 now has 37 different things it can now run that was not possible a couple weeks ago. Stay tuned as this is port is sure to mature even more with time and likely become an official release sooner or later for the RetroArch project. The libretro team has already expressed support..


    (Original Article r1) RetroArch for the PS4 was in development around this time last year, if you recall. Various developer's such as frangarcj & bigboss were showing the initial progress and private builds of the port's early progress and then development seem to come to a slow-down without much news surrounding it. In the meantime the PS4 community followed the emergence of a new PS2 port of RetroArch as some ps2 homebrew can be played via emulation and in the 5.05 ps4 via a PS2 Classic convert, This gave a small taste of RetroArch emulation in a limited capacity on the PS4. A native PS4 port was and has been in high demand, now developer @OsirisX has answered the call and has delivered an unofficial release of RetroArch PS4 (v1.8.1-R1) to become the latest PS4 Homebrew. We have seen a few ps4 homebrew releases but this is huge news for the PS4 community, For those of you who may not know the developer. This person has been in the scene for a long time and has been responsible for various projects across platforms, some of our reader's may recall one project on the PS3 from this dev ( PS3xPAD (cfw plugin)..)

    The initial release of this port contains 25 libretro cores with more coming in future updates, the included cores ranging from experimental N64 emulation, MAME, PS1, DosBoX, NES, Genesis/Mega Drive, 32x and other libretro core's that will emulate many retro console now on your PS4!!!. For more information about this port checkout the release notes from the developer attached below, along with some extra bits of info we have added as well. Please share your experiences in the comments below. What is working and not working?

    retroarch_ps4_r1.png
    View tab marked Update below for R2 details

    • RetroArch PS4
      This is a native PS4 port of RetroArch. It is based off v1.8.1.
      Only a handful of cores are ported for now but more will come at a later date!


      ( Video's by @Grim Doe )

      You will need a jailbroken PS4 running 5.05 fw to install and use this port.​

      Ported cores list:

      • 2048_libretro.self - 2048 core
      • dosbox_libretro.self - DOSbox 0.74, MS-DOS Emulator
      • desmume2015_libretro.self - Nintendo DS [NDS]
      • fceumm_libretro.self - FCEUmm, Nintendo Entertainment System [NES]
      • gearboy_libretro.self - Gearboy, Game Boy [DMG + Color]
      • genesis_plus_gx_libretro.self - Genesis Plus GX, Sega Genesis/Mega Drive & Sega CD & Sega Master System
      • mame2000_libretro.self - MAME 0.37b5, Multiple Arcade Machine Emulator
      • mame2003_libretro.self - MAME 0.72, Multiple Arcade Machine Emulator
      • mame2003_plus_libretro.self - MAME 0.72+, Multiple Arcade Machine Emulator
      • mednafen_gba_libretro.self - MednaFen GBA, Game Boy Advance [GBA]
      • mednafen_lynx_libretro.self - MednaFen Lynx, Atari Lynx
      • mednafen_ngp_libretro.self - MednaFen NeoPop, Neo-Geo Pocket [Color]
      • mednafen_snes_libretro.self - MednaFen SNES, Super Nintendo [SNES]
      • mednafen_vb_libretro.self - MednaFen VB, Virtual Boy
      • mednafen_wswan_libretro.self - MednaFen WonderSwan, Bandai WonderSwan [+ Color]
      • mgba_libretro.self - mGBA, Game Boy Advance [GBA]
      • parallel_n64_libretro.self - Nintendo 64 (Experimental) [N64]
      • pcsx_rearmed_libretro.self - PCSX ReARMed, PlayStation 1 [PS1]
      • picodrive_libretro.self - PicoDrive, Sega Genesis/Mega Drive & Sega CD & Sega 32X
      • quicknes_libretro.self - QuickNES, Nintendo Entertainment System [NES]
      • snes9x2002_libretro.self - Snes9X 2002, Super Nintendo [SNES]
      • snes9x2005_libretro.self - Snes9x 2005, Super Nintendo [SNES]
      • snes9x2005_plus_libretro.self - Snes9x 2005 Plus, Super Nintendo [SNES]
      • snes9x2010_libretro.self - Snes9x 2010, Super Nintendo [SNES]
      • snes9x_libretro.self - Snes9x, Super Nintendo [SNES]
      • See UPDATE tab for cores added in the r2 update


    • UPDATE: r2 release:
      • Fixed launching games from playlists
      • Added more cores including mupen64plus (N64), yabause (Sega Saturn), etc. Check below for full list
      • Note: There is just small speed improvement with mupen64 compared with parallel.

      Newly added cores since r1:
      • desmume_libretro.self - Nintendo DS [NDS]
      • fbalpha2012_libretro.self - FB Alpha 2012 v0.2.97.29, Arcade Machine Emulator [Various]
      • fbalpha2012_cps1_libretro.self - FB Alpha 2012 CPS1 v0.2.97.28, Capcom Play System [CPS1]
      • fbalpha2012_cps2_libretro.self - FB Alpha 2012 CPS2 v0.2.97.28, Capcom Play System II [CPS2]
      • fbalpha2012_cps3_libretro.self - FB Alpha 2012 CPS3 v0.2.97.29, Capcom Play System II [CPS3]
      • fbalpha2012_neogeo_libretro.self - FB Alpha 2012 NeoGeo v0.2.97.29, SNK Neo-Geo AES/MVS
      • fmsx_libretro.self - fMSX, MSX 1/2 Emulator
      • mednafen_pcfx_libretro.self - Mednafen PC-FX, NEC PC-FX
      • mednafen_supergrafx_libretro.self - Mednafen SuperGrafx, NEC PC Engine SuperGrafx
      • mupen64plus_libretro.self - Nintendo 64 [N64]
      • mupen64plus_next_libretro.self - Nintendo 64 [N64]
      • yabause_libretro.self - Yabause, Sega Saturn

    • PS4_PRO_RETRO_ANGLE_2048x.png

      Release Notes (provided by port developer): (updated for R2)
      1. Games can either be loaded from hdd or usb.
      2. The RetroArch system folder is located in /data/retroarch/system. Any necessary bios files need to be placed there.
      3. There is a small bug where sometimes games won't load after closing it. If this happens, try re-loading the core and load the game again.
      4. N64 emulator seems to run fastest with rice gfx plugin. Use mupen64plus for best N64 emulation performance
      5. Shaders should be working. Try loading them from usb if you're experiencing issues and don't forget to press apply after loading.
      6. Launching games from playlists should now be working in r2.
      7. USE PS4 Hen 2.1.1+ "there are some required patches in later Hen versions that need to be applied." (quote 1)
      Source (code) will be pushed to main branch eventually but will be slow to ensure nothing breaks!​

      Additional Note's (provided by psx-place):
      1.Tip: How to toogle Menu while in gameplay. default is set to Touchscreen (push) + Option button or refereed to "Start + Select" in Setting>>Input>>Menu toggle Gamepad Combo where there is many options.
      2. Tip: Under the above option you can also switch X/O button behavior as well.
      Setting>>Input>>Menu Swap Ok & Cancel buttons
      3.Bug: Automatic Core detection/switching is not supported currently on this port.. You will have to manually switch your cores before launching roms. When you have a core loaded it will suggest it can play any rom as the detection is broken fixed in r2
      4. Bug: Launching Roms from playlist or history or basically any location other then manually finding the file will result in RetroArch just reloading and not launch the rom. fixed in R2
      5. Submitted Bug Report: (via @Vegeta ) - Shader's not working (see details) UPDATE (r2) See r2 revised dev Notes above regarding shaders
      6.) Tip: Forcing Analog controls: Settings>>Input>>>>User "X" binds>>>>User "X" Analog to digital type: Then you can choose left or right stick for dpad controls (note dpad controls will still work as well)


    • Video's Courtesy of @Grim Doe on a PS4 PRO using version "r1"



      R2 N64 & Saturn Test




      Additional "R2" Gameplay



    • PS4_PRO_RETRO_ANGLE_2048x.png
      Acknowledgments/Thanks (via @OsirisX)
      • Flatz for figuring out OpenGL on PS4
      • Frangarcj for the initial RetroArch PS4 port
      • Big Boss for liborbis

    Download:


    Release Thread @: gbatemp.net

    Recent PS4 Homebrew Releases:
     
    Last edited: Jan 7, 2020
    Pete_uk, LuanTeles, Grim Doe and 6 others like this.

Comments

Discussion in 'PS4 Homebrew' started by STLcardsWS, Dec 27, 2019.

    1. STLcardsWS
      STLcardsWS
      Thanks @OsirisX . Can't wait to try it out.. :)
      Last edited: Dec 27, 2019
      Grim Doe, jacobsson and DeViL303 like this.
    2. STLcardsWS
      STLcardsWS
      If these were all Standalone's we would be saying %%*&^@5 look at all this homebrew... This is huge for the PS4 ..

      "snes9x_libretro" core plays MSU-1 games (not tested on PS4 port yet)


      Last edited: Dec 27, 2019
      jacobsson likes this.
    3. Joat.None
      Joat.None
      Thanks! I hope in updates soon! :)
    4. jacobsson
    5. STLcardsWS
      STLcardsWS
      Testing content scanning right now.
      Also if you have (non-arcade) rom in zip format it does take much longer to scan those. As retroarch will unzip each one and then scan. Which the unzipping portion takes a long time.
      Edit: Content Scanned is working, but i do not think this port yet has automatic detetion of cores (but may need to download more assets from online updater, so it know which extension are for which system)
      Edit 2: Playlist have been made but roms are not launching just reloads, but i think the issue here is that it unzips and stores the file someplace but the playlist is looking for that and not the actually zip one. As i have no option to load archive like when its a zipped rom. Scanning unzipped roms (for non arcade) might be the simple user fix for now. but have not confirmed this yet..
      Edit 3: Seems launching a rom from anywhere give issues. UNLESS your are manually loading it from the file explorer. At least from what i have seen. Maybe someone else can confirm one way or another?

      Thumbnails are working and downloading fine.

      --merged post---

      Also has anyone had any trouble getting out of certain menu's unable to go back to main menu's on the XMB mode? Seems a few times when getting deep in a few menus there has been no way back. noticed this when going through my rom folders. Maybe a button press or combo i am missing. .. Anyone else have had that issue?

      I am still playing around with this but added a few notes in the OP notes tab

      Additional notes (provided by psx-place) added to main post
      ---post merged--

      SNES9x has some crackling sound?(snes9x_libretro) Other snes cores have not tried yet
      Last edited: Dec 28, 2019
      lotus78 likes this.
    6. STLcardsWS
      STLcardsWS
      N64 works but is slow, does speed up with the rice plugin suggestion in the notes.
      While in game you access the in game menu, by default it is holding touchpad and option button, Then from the quick menu goto core options and change the gfx to rice as mentioned in the notes. After toggling Restart retroarch from the restart retroarch option.

      Found a bug: Don't switch the UI to ozone. because you lose all controls..
      Does have a nice clean look though.

      Ok, i need to delete my Retroarch.cfg file
      edit: that did the trick.
      if anyone runs into that situation.
      /data/retroarch/retroarch.cfg file needs to be deleted. (will lose some settings you saved)
      Last edited: Dec 28, 2019
      atreyu187 likes this.
    7. lotus78
      lotus78
      @STLcardsWS
      Hi - I can confirm, that it was not possible to start a game from any list. (playlist, history or favorit)
      I tried a lot of things (other location for rom, manuell edit playlists) but nothing works.
      lotus78
      STLcardsWS likes this.
    8. STLcardsWS
      STLcardsWS
      Has anyone ran Virtual Boy Yet?

      It seems it was running at double the speed. But there was a setting in the Options that was set for faster speed, I did not recall changing it and wondering if this was set by default. If set by default that needs to be changed in a future update and listed as a bug

      Can anyone confirm if Virtual Boy games were running double speed out of the gate?
    9. Vegeta
      Vegeta
      Shaders not working here. Online updater doesn't extract the zip file but I copied the files from my RetroArch PC setup, glsl and cg folders.

      When trying to choose a shader, none show up.
      STLcardsWS likes this.
    10. STLcardsWS
      STLcardsWS
      I could not get shader's to work either. I did not transfer them yet from PC that was going to be my next move but seen you did. Might confirm that as well. Added your report to the Notes section. Thanks .. No doubt the feedback should help the devs
      Vegeta likes this.
    11. STLcardsWS
      STLcardsWS
      PCSX works well (excluding sound). (PS1 emu.)
      But not using BIOS files. just the emulated bios.
      (Crash bandicoot tested no sound)

      edit:
      (NFL bltiz 2001 has plenty of clear sound)
      So maybe a bios issue with crash bandicoot.

      Emulation is clean and speed is fine on either game w/ emulated bios

      Sahder support would be great though :)

      edit 2:
      Pico drive (32x emulation) works well as also.
      .
      Last edited: Dec 29, 2019
    12. Vegeta
      Vegeta
      I added the system folder for all the BIOS files etc but RetroArch on PS4 doesn't even seem to detect the folder as PCSX still states that no BIOS file is found.
    13. STLcardsWS
      STLcardsWS
      Some cores like the bios with the game and not the system folder,
      So worth a test.

      NeoPop needs bios i have them in both locations. but games were working on that. So bios is being detected i just do not from which location on that one :)

      FYI: retroarch docs i believe has the md5 checksums of bios files needed that is for sure worth looking at if you have issues. at least to rule it out if nothing else.
    14. ANGO
      ANGO
      ...same here.

      My configuration is not saved permanently. It is created new each time retroarch is started.
      It looks like the path /data/retroarch/xxx is being ignored.
      No bios,playlists, thumbnails are loaded. Also File Explorer find no roms on ps4 hd. Roms are only found on usb stick.

      (Ps4 Pro 5.05, Hen 1.7, tested wit retroarch rc1 and rc2)
      Last edited: Jan 4, 2020
    15. STLcardsWS
      STLcardsWS
      Articled updated
      @OsirisX has released R2 adding 12 new cores + bug fix for playlist launching of roms, see all details in first post of news thread
      jacobsson, Grim Doe and disyoko like this.
    16. Joat.None
      Joat.None
      Amazing! Keep making my jailbroken ps4 usefull!
      Great!
      I hope in new cores and good optimizations :)
    17. STLcardsWS
      STLcardsWS
      Core detection and the switching between the cores now works as it should.
      You can now play a game and load another game (for a different core) without having to close the game then go the long route of loading the new one with loading the core first and then the game. Just load the game and should provide you your options but there is some hit and miss here as you may get more options then it should be typically .zip roms cause this. Unzipped and native extensions will not run into these issues.
      Joat.None likes this.
    18. joeyj40
      joeyj40
      can some one please explain to me how i can get the second controller working on retroarch only the first controller works i tried games on snes cps1 cps2 mame pico drive any help would be appreciated thank u
      Last edited: Jan 11, 2020
    19. Grim Doe
      Grim Doe
      For BIOS in RetroArch,
      On the PS4 into RetroArch I go to: Setting/Directory/
      Set it to /data/retroarch/system
      and from there I place all of my (BIOS) in there.
      jacobsson and STLcardsWS like this.

Share This Page