Webman not showing games

Discussion in 'PS3 Jailbreak CFW and PS3HEN' started by S-E-G-A-G-E-S, Mar 31, 2019.

  1. 18
    3
    7
    S-E-G-A-G-E-S

    S-E-G-A-G-E-S Forum Noob

    Joined:
    Mar 9, 2019
    Messages:
    18
    Likes Received:
    3
    Trophy Points:
    7
    Gender:
    Male
    I have all my games as iso files in the folder ps3iso on an ntfs drive. Multiman and others all show the games on the drive but webman doesn't.

    It's listed on the files section of webman but none of the games are showing. I've used prep ntfs about a dozen times and still no luck.

    Also I have 2 ps2 isos which are showing without issue.

    Help
     
  2. 18
    3
    7
    S-E-G-A-G-E-S

    S-E-G-A-G-E-S Forum Noob

    Joined:
    Mar 9, 2019
    Messages:
    18
    Likes Received:
    3
    Trophy Points:
    7
    Gender:
    Male
  3. 3,084
    3,028
    372
    Joonie

    Joonie Developer

    Joined:
    Oct 15, 2014
    Messages:
    3,084
    Likes Received:
    3,028
    Trophy Points:
    372
    Location:
    Southwest US
    PrepNTFS is no longer required since some time ago (at least on the latest version of webMAN MOD) , you just need to refresh game list as well as html list.

    Try opening webMAN on your PC browser by typing your PC ip to see if yours games on NTFS partition have been listed or not.

    you would be able to see dev_ntfs if that's mounted.
     
    T.A.U likes this.
  4. 18
    3
    7
    S-E-G-A-G-E-S

    S-E-G-A-G-E-S Forum Noob

    Joined:
    Mar 9, 2019
    Messages:
    18
    Likes Received:
    3
    Trophy Points:
    7
    Gender:
    Male
    I've just done what you said and the drive is showing as dev_ntfs0 and it shows that i have 350gb free space which is correct. It shows the folder PS3ISO where all of my iso files are but none appear when i open the folder.
     
  5. 3,084
    3,028
    372
    Joonie

    Joonie Developer

    Joined:
    Oct 15, 2014
    Messages:
    3,084
    Likes Received:
    3,028
    Trophy Points:
    372
    Location:
    Southwest US
    Did you refresh game list (XML) and reboot?
     
  6. 18
    3
    7
    S-E-G-A-G-E-S

    S-E-G-A-G-E-S Forum Noob

    Joined:
    Mar 9, 2019
    Messages:
    18
    Likes Received:
    3
    Trophy Points:
    7
    Gender:
    Male
    yep tried that multiple times too, nothing shows
     
  7. 3,084
    3,028
    372
    Joonie

    Joonie Developer

    Joined:
    Oct 15, 2014
    Messages:
    3,084
    Likes Received:
    3,028
    Trophy Points:
    372
    Location:
    Southwest US
    Summoning @aldostools
     
  8. 3,153
    5,074
    522
    aldostools

    aldostools Developer Developer

    Joined:
    Oct 30, 2014
    Messages:
    3,153
    Likes Received:
    5,074
    Trophy Points:
    522
    Let's start from the beginning:

    First, check if your games stored in NTFS are using the correct format:
    1- The USB device must be formatted in NTFS (not extFAT) and the partition is NOT greater than 2 Terabytes (2TB).
    (If you NTFS has multiple partitions, the test will be more complex. In this case, use a different device with only one partition)

    - Set the drive to MBR (GPT partitioning isn't supported.)
    - Check that it's created as Logical (not Primary)
    - The recommended cluster size is 64KB​

    2- All the games stored in the NTFS device must be in ISO format.
    Games in folders format (aka JB format) are not supported on NTFS.

    3- The extension must be .iso or .ISO. Not .Iso, .iSo, .isO, etc.

    4- The folder name must be: /PS3ISO in the root of the USB device (formatted in NTFS)
    All letters in upper case and without spaces. Not /ps3iso, /PS3 ISO, /GAMES, /Games, etc.

    5- All the games in ISO (for PS3 games) must be inside /PS3ISO, without subfolders.

    6- Attach the USB drive to the port usb000 (the USB port that is nearest to the bluray drive).
    For the test, do not use USB hubs or different ports. Disconnect all the USB devices except the NTFS drive.

    For simplicity, let's concentrate only with the PS3 games and avoid the subfolders.
    You can try the sub-folders, the other games types and attach other USB devices once you get it working.​

    After you have checked that everything above is correct, let's continue with the program's part:

    1-Go to the Internet browser of your PS3 and go the address http://127.0.0.1/delete.ps3?uninstall
    This step will uninstall webMAN MOD and remove everything related to it, including the current settings.

    2-Download and install the webMAN_MOD_1.47.25_Updater.pkg from https://github.com/aldostools/webMAN-MOD/releases
    Do it again even if you already did it. Just to be sure that you're using the same version that I'll be checking.
    Also download and install prepNTFS_1.20.pkg

    3-Execute webMAN updater from XMB holding down the L1 button until the system reboots.
    This step will install the full version of webMAN MOD.

    4-Wait a few minutes until webMAN complete the scan of content and you see "Refresh XML: OK".
    Do not access the folder "webMAN Games" until the scan has completed.

    5-After you see the popup saying "Refresh XML: OK", open "webMAN Games" and check if your games are listed.

    At this point, everything should be working with the default settings.

    6-Go to http://127.0.0.1/setup.ps3, mark the option "Disable content scan on startup", press the SAVE button and reboot.

    At this point, the games previously found should remain listed in "webMAN Games".
    If so, congratulations your issue is solved!

    If not, let's check a few things:
    1-Open the Internet Browser of your PS3 and navigate to http://127.0.0.1/
    This is the file manager of webMAN. Check if it shows the device /dev_ntfs0

    - If it shows, navigate to it and check that the folder /PS3ISO and its content are visible in the file manager

    - If it doesn't show, it's possible that the internal prepNTFS isn't compatible with your NTFS device due some limitations of the ntfs library used in webMAN MOD. Try using prepNTFS as suggested in the next step.​

    2-Navigate to the path: /dev_hdd0/tmp/wmtmp
    Check that you have multiple files with the extension .ntfs[PS3ISO]
    There must be also some .SFO and .PNG files in that folder.

    - If it doesn't have these files, open /setup.ps3, click on "Scan for Content", uncheck /dev_ntfs and press SAVE button, return to XMB and execute prepNTFS 1.20. Wait until it returns to XMB, and repeat step 2 (check if the files are now in wmtmp).
    - If the content still don't show, proceed with the step 3 below.

    3-Go to http://127.0.0.1/setup.ps3, click on "Scan for content" and put a check mark on all the options of that section and press SAVE.
    View attachment 16024

    After you have saved the settings, return to XMB and re-scan the content pressing SELECT+L3.
    After you see the message "Refresh XML: OK", restart the console pressing L3+R2+CIRCLE

    4- If after all these steps you still don't see your games, use sMAN or multiMAN and summon deank ;) LOL






     
    Last edited: Jul 9, 2019
    disyoko, Coldheart2236, T.A.U and 3 others like this.
  9. 18
    3
    7
    S-E-G-A-G-E-S

    S-E-G-A-G-E-S Forum Noob

    Joined:
    Mar 9, 2019
    Messages:
    18
    Likes Received:
    3
    Trophy Points:
    7
    Gender:
    Male
    I followed everything and no luck. Followed the instructions carefully too. The drive shows up but when I click on the PS3ISO folder it's empty according to webman. The temp folder has sfo and png files but no ntfs[ps3iso] files

    Sent from my SM-G960F using Tapatalk
     
  10. 3,153
    5,074
    522
    aldostools

    aldostools Developer Developer

    Joined:
    Oct 30, 2014
    Messages:
    3,153
    Likes Received:
    5,074
    Trophy Points:
    522
    Try scanning your NTFS games using IRISMAN. It should create the .ntfs[PS3ISO] files if they don't exist in wmtmp.

    You can verify if they were created pressing SELECT+START to go to the file manager and navigating to /dev_hdd0/tmp/wmtmp

    This is my last bullet... if this doesn't work, you'll need to wait for the help of other users.
     
    T.A.U likes this.
  11. 18
    3
    7
    S-E-G-A-G-E-S

    S-E-G-A-G-E-S Forum Noob

    Joined:
    Mar 9, 2019
    Messages:
    18
    Likes Received:
    3
    Trophy Points:
    7
    Gender:
    Male
    I have already used irisman and all the games show up fine, I've tried multiman and that works and managunz and they all work fine except webman
     
  12. 3,153
    5,074
    522
    aldostools

    aldostools Developer Developer

    Joined:
    Oct 30, 2014
    Messages:
    3,153
    Likes Received:
    5,074
    Trophy Points:
    522
    Ok you used IRISMAN, but you didn't mention if you followed this step:
    "You can verify if they were created pressing SELECT+START to go to the file manager and navigating to /dev_hdd0/tmp/wmtmp"
     
  13. 18
    3
    7
    S-E-G-A-G-E-S

    S-E-G-A-G-E-S Forum Noob

    Joined:
    Mar 9, 2019
    Messages:
    18
    Likes Received:
    3
    Trophy Points:
    7
    Gender:
    Male
    I rescanned and the ntfs[ps3iso] files are there now but still nothing shows in webman.

    I'm stumped

    Sent from my SM-G960F using Tapatalk
     
  14. 3,153
    5,074
    522
    aldostools

    aldostools Developer Developer

    Joined:
    Oct 30, 2014
    Messages:
    3,153
    Likes Received:
    5,074
    Trophy Points:
    522
    If the .ntfs[PS3ISO] are there, try going to http://127.0.0.1/setup.ps3, open "Scan for Content", uncheck /dev_ntfs, press SAVE button, return to XMB and re-scan the content running prepNTFS or using SELECT+L3 then reboot after you see "Refresh XML: OK"

    The option /dev_ntfs in /setup.ps3 executes the internal prepNTFS, which first deletes all the *.ntfs[PS3ISO] files during the content scanning.

    When the option is unmarked, webMAN will not try to scan the NTFS, but will still use the existing .ntfs[PS3ISO] files generated by IRISMAN or prepNTFS 1.19.

    I have edited the steps above to include the uncheck of /dev_ntfs before execute prepNTFS 1.19, to avoid webMAN clear the existing .ntfs[PS3ISO] files from /dev_hdd0/tmp/wmtmp when webMAN scans for content.

    The option /dev_ntfs must be unchecked only when the external prepNTFS application or IRISMAN are used to scan the NTFS content.
    If the internal prepNTFS is working fine, keep that option checked to avoid the use of the external prepNTFS.
     
    Last edited: Apr 1, 2019
    T.A.U, DeViL303 and Joonie like this.
  15. 3,084
    3,028
    372
    Joonie

    Joonie Developer

    Joined:
    Oct 15, 2014
    Messages:
    3,084
    Likes Received:
    3,028
    Trophy Points:
    372
    Location:
    Southwest US
    @aldostools This isn't the first time I hear about people have issues with NTFS, this has somewhat become a "known" issue since dev_ntfs0 became a thing. A lot of people still stuck in old ways of doing things and have hard time being adopted to sMan/wMM +NTFS lib way to play their games, that being said I'm preparing myself to use NTFS to see if I can reproduce this infamous issue.
     
    T.A.U and aldostools like this.
  16. 3,153
    5,074
    522
    aldostools

    aldostools Developer Developer

    Joined:
    Oct 30, 2014
    Messages:
    3,153
    Likes Received:
    5,074
    Trophy Points:
    522
    I guess that I should add a note in /setup.ps3 next to the option /dev_ntfs indicating that it will use the internal prepNTFS (aka "sMAN" way of scan NTFS content), and that the current cache will be cleared in the process.
     
    T.A.U likes this.
  17. 3,084
    3,028
    372
    Joonie

    Joonie Developer

    Joined:
    Oct 15, 2014
    Messages:
    3,084
    Likes Received:
    3,028
    Trophy Points:
    372
    Location:
    Southwest US
    I managed to reproduce the issue that OP reported. I could see dev_ntfs0 mounted and can see ISO files inside of it

    However both prepNTFS and internal ntfslib fail to list them on XMB as well as HTML.

    I can confirm Managunz list and mount them just fine though.


    upload_2019-4-1_13-21-56.png

    upload_2019-4-1_13-22-19.png

    upload_2019-4-1_13-22-33.png

    upload_2019-4-1_13-22-53.png

    upload_2019-4-1_13-23-18.png
     
    T.A.U and aldostools like this.
  18. 3,084
    3,028
    372
    Joonie

    Joonie Developer

    Joined:
    Oct 15, 2014
    Messages:
    3,084
    Likes Received:
    3,028
    Trophy Points:
    372
    Location:
    Southwest US
    @aldostools

    So then I checked all of them below (dev_usb000~ntfs), and now I can see them listed

    upload_2019-4-1_13-26-39.png

    upload_2019-4-1_13-27-6.png

    upload_2019-4-1_13-28-6.png
     
    T.A.U and aldostools like this.
  19. 3,153
    5,074
    522
    aldostools

    aldostools Developer Developer

    Joined:
    Oct 30, 2014
    Messages:
    3,153
    Likes Received:
    5,074
    Trophy Points:
    522
    Thank you @Joonie for the detailed report. A picture tells a thousand words.
    I'll try to check if I can fix the issue when I get home ;)
     
    T.A.U and Joonie like this.
  20. 3,084
    3,028
    372
    Joonie

    Joonie Developer

    Joined:
    Oct 15, 2014
    Messages:
    3,084
    Likes Received:
    3,028
    Trophy Points:
    372
    Location:
    Southwest US
    @S-E-G-A-G-E-S

    [​IMG]

    Please try this method I mentioned above to see if you can fix your issue as well.
     
    T.A.U likes this.

Share This Page